Edit patch not to require spice-protocol 0.14.1

We didn't bump the protocol version when backporting the new
capabilities to the spice-protocol package (as we didn't
backport any other changes in 0.14.1), so we can't require that
version here
This commit is contained in:
Adam Williamson 2019-10-04 08:19:44 -07:00
parent d8ed1c90a5
commit 78bb04c06a
2 changed files with 3 additions and 15 deletions

View File

@ -9,24 +9,10 @@ Content-Transfer-Encoding: 8bit
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
meson.build | 2 +-
src/channel-main.c | 2 ++
src/spice-gtk-session.c | 9 ++++++++-
3 files changed, 11 insertions(+), 2 deletions(-)
2 files changed, 10 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 171a3f6..b89a15b 100644
--- a/meson.build
+++ b/meson.build
@@ -81,7 +81,7 @@ endforeach
#
# check for mandatory dependencies
#
-spice_protocol_version='>= 0.12.15'
+spice_protocol_version='>= 0.14.1'
glib_version = '2.46'
glib_version_info = '>= @0@'.format(glib_version)
diff --git a/src/channel-main.c b/src/channel-main.c
index 4305dcd..adf6bab 100644
--- a/src/channel-main.c

View File

@ -25,6 +25,8 @@ Patch0003: 0002-clipboard-do-not-release-between-remote-grabs.patch
# ???
Patch0004: 0003-fixup-clipboard-do-not-release-between-remote-grabs.patch
# https://patchwork.freedesktop.org/series/58418/#rev1
# edited to not require protocol version 0.14.1 as we didn't bump
# the version in spice-protocol when backporting the patches there
Patch0005: 0004-clipboard-do-not-delay-release-if-agent-has-no-relea.patch
Patch0006: 0005-clipboard-pre-condition-on-selection-value-256.patch
Patch0007: 0006-clipboard-implement-CAP_CLIPBOARD_GRAB_SERIAL.patch