Add patch fixing symbol versioning
This inadvertantly broke spice-gtk ABI
This commit is contained in:
parent
80607bad2a
commit
29be6f4185
27
0002-build-sys-Fix-symbol-versioning.patch
Normal file
27
0002-build-sys-Fix-symbol-versioning.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From df49129c9ee14ada3c6bcb45fc72057255bd0d9a Mon Sep 17 00:00:00 2001
|
||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
||||
Date: Mon, 10 Sep 2012 14:49:44 +0200
|
||||
Subject: [spice-gtk] build-sys: Fix symbol versioning
|
||||
|
||||
My changes in bug 5bf72a2e had a typo which broke symbol versioning
|
||||
of libspice-client-gtk.so when -Wl,--version-script is available...
|
||||
---
|
||||
gtk/Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
|
||||
index 928f914..06cc6e1 100644
|
||||
--- a/gtk/Makefile.am
|
||||
+++ b/gtk/Makefile.am
|
||||
@@ -58,7 +58,7 @@ endif
|
||||
|
||||
if HAVE_LD_VERSION_SCRIPT
|
||||
GLIB_VERSION_LDFLAGS = -Wl,--version-script=${srcdir}/map-file
|
||||
-GTK_VERSION_LD_FLAGS = $(GLIB_VERSION_LDFLAGS)
|
||||
+GTK_VERSION_LDFLAGS = $(GLIB_VERSION_LDFLAGS)
|
||||
else
|
||||
GLIB_VERSION_LDFLAGS = -export-symbols ${srcdir}/spice-glib-sym-file
|
||||
GTK_VERSION_LDFLAGS = -export-symbols ${srcdir}/spice-gtk-sym-file
|
||||
--
|
||||
1.7.11.4
|
||||
|
@ -13,7 +13,7 @@
|
||||
|
||||
Name: spice-gtk
|
||||
Version: 0.13.29
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: A GTK+ widget for SPICE clients
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -22,6 +22,7 @@ URL: http://spice-space.org/page/Spice-Gtk
|
||||
#VCS: git:git://anongit.freedesktop.org/spice/spice-gtk
|
||||
Source0: http://www.spice-space.org/download/gtk/%{name}-%{version}%{?_version_suffix}.tar.bz2
|
||||
Patch1: 0001-G_GNUC_DEPRECATED_FOR-must-be-defined-publicly.patch
|
||||
Patch2: 0002-build-sys-Fix-symbol-versioning.patch
|
||||
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gtk2-devel >= 2.14
|
||||
@ -149,6 +150,7 @@ fi
|
||||
|
||||
pushd spice-gtk-%{version}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
popd
|
||||
|
||||
%if %{with_gtk3}
|
||||
@ -268,6 +270,9 @@ rm -rf %{buildroot}%{_datadir}/pkgconfig/spice-protocol.pc
|
||||
%{_bindir}/spicy-stats
|
||||
|
||||
%changelog
|
||||
* Tue Sep 11 2012 Christophe Fergeau <cfergeau@redhat.com> - 0.13.29-2
|
||||
- Add patch to fix symbol versioning
|
||||
|
||||
* Fri Sep 7 2012 Hans de Goede <hdegoede@redhat.com> - 0.13.29-1
|
||||
- Update to the spice-gtk 0.13.29 development release
|
||||
- Rebuild for new usbredir
|
||||
|
Loading…
Reference in New Issue
Block a user