Update to 4.0.0. Fixes rhbz#2154501

This commit is contained in:
Kevin Fenzi 2022-12-19 14:27:45 -08:00
parent 334f632b16
commit b880b43049
3 changed files with 13 additions and 74 deletions

View File

@ -1,7 +1,7 @@
diff -Nur Mail-SpamAssassin-3.3.2.orig/sa-update.raw Mail-SpamAssassin-3.3.2/sa-update.raw
--- Mail-SpamAssassin-3.3.2.orig/sa-update.raw 2011-06-06 17:59:19.000000000 -0600
+++ Mail-SpamAssassin-3.3.2/sa-update.raw 2014-01-28 13:29:33.933526585 -0700
@@ -281,7 +281,7 @@
diff --color -Nur Mail-SpamAssassin-4.0.0.orig/sa-update.raw Mail-SpamAssassin-4.0.0/sa-update.raw
--- Mail-SpamAssassin-4.0.0.orig/sa-update.raw 2022-12-13 22:03:27.000000000 -0800
+++ Mail-SpamAssassin-4.0.0/sa-update.raw 2022-12-19 12:28:57.058533774 -0800
@@ -361,7 +361,7 @@
if ($GPG_ENABLED || $opt{'import'}) {
# find GPG in the PATH
# bug 4958: for *NIX it's "gpg", in Windows it's "gpg.exe"

View File

@ -1,62 +0,0 @@
Avoid implicit function declarations in the configure script.
The undeclared exit function comes from autoconf-generated code.
The SHUT_RD and h_errno checks are specific to the spamassassin
package.
Submitted upstream: <https://bz.apache.org/SpamAssassin/show_bug.cgi?id=8076>
diff --git a/spamc/configure b/spamc/configure
index d8e5dcf8a21d6a3d..5472d2b009fb9083 100755
--- a/spamc/configure
+++ b/spamc/configure
@@ -2624,8 +2624,8 @@ main ()
for (i = 0; i < 256; i++)
if (XOR (islower (i), ISLOWER (i))
|| toupper (i) != TOUPPER (i))
- exit(2);
- exit (0);
+ return 2;
+ return 0;
}
_ACEOF
rm -f conftest$ac_exeext
@@ -3553,6 +3553,7 @@ _ACEOF
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <stdio.h>
#include <sys/types.h>
#include <sys/socket.h>
int
@@ -4252,6 +4253,7 @@ _ACEOF
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <stdio.h>
#include <netdb.h>
int
main ()
diff --git a/spamc/configure.in b/spamc/configure.in
index 42cc998412075086..96769105ef640bc8 100644
--- a/spamc/configure.in
+++ b/spamc/configure.in
@@ -47,7 +47,8 @@ dnl ----------------------------------------------------------------------
AC_CACHE_CHECK([for SHUT_RD],
shutrd, [
- AC_TRY_COMPILE([#include <sys/types.h>
+ AC_TRY_COMPILE([#include <stdio.h>
+#include <sys/types.h>
#include <sys/socket.h>],
[printf ("%d", SHUT_RD); return 0;],
[shutrd=yes],
@@ -89,7 +90,8 @@ dnl ----------------------------------------------------------------------
AC_CACHE_CHECK([for h_errno],
herrno, [
- AC_TRY_COMPILE([#include <netdb.h>],
+ AC_TRY_COMPILE([#include <stdio.h>
+#include <netdb.h>],
[printf ("%d", h_errno); return 0;],
[herrno=yes],
[herrno=no]),

View File

@ -53,19 +53,19 @@
%define real_name Mail-SpamAssassin
%{!?perl_vendorlib: %define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)}
%global saversion 3.004006
%global saversion 4.000000
#%%global prerev rc2
Summary: Spam filter for email which can be invoked from mail delivery agents
Name: spamassassin
Version: 3.4.6
Version: 4.0.0
#Release: 0.8.%%{prerev}%%{?dist}
Release: 8%{?dist}
Release: 1%{?dist}
License: ASL 2.0
URL: https://spamassassin.apache.org/
Source0: https://www.apache.org/dist/%{name}/source/%{real_name}-%{version}.tar.bz2
#Source0: %%{real_name}-%%{version}-%%{prerev}.tar.bz2
Source1: https://www.apache.org/dist/%{name}/source/%{real_name}-rules-%{version}.r1888502.tgz
Source1: https://www.apache.org/dist/%{name}/source/%{real_name}-rules-%{version}.r1905950.tgz
#Source1: %%{real_name}-rules-%%{version}.%%{prerev}.tgz
Source2: redhat_local.cf
Source3: spamassassin-default.rc
@ -88,9 +88,8 @@ Source17: sa-update.timer
# Patches 0-99 are RH specific
# https://bugzilla.redhat.com/show_bug.cgi?id=1055593
# Switch to using gnupg2 instead of gnupg1
Patch0: spamassassin-3.3.2-gnupg2.patch
Patch0: spamassassin-4.0.0-gnupg2.patch
Patch1: spamassassin-3.4.1-add-logfile-homedir-options.patch
Patch2: spamassassin-configure-c99.patch
# end of patches
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%if %{use_systemd} == 0
@ -209,8 +208,6 @@ To filter spam for all users, add that line to /etc/procmailrc
%setup -q -n Mail-SpamAssassin-%{version}
# Patches 0-99 are RH specific
%patch0 -p1
%patch1 -p1
%patch2 -p1
# end of patches
echo "RHEL=%{?rhel} FEDORA=%{?fedora}"
@ -279,6 +276,7 @@ cd -
find $RPM_BUILD_ROOT/usr -type f -print |
sed "s@^$RPM_BUILD_ROOT@@g" |
grep -v perllocal.pod |
grep -v %{_unitdir} |
grep -v "\.packlist" > %{name}-%{version}-filelist
if [ "$(cat %{name}-%{version}-filelist)X" = "X" ] ; then
echo "ERROR: EMPTY FILE LIST"
@ -390,6 +388,9 @@ exit 0
%endif
%changelog
* Sat Dec 17 2022 Kevin Fenzi <kevin@scrye.com> - 4.0.0-1
- Update to 4.0.0. Fixes rhbz#2154501
* Sun Nov 27 2022 Florian Weimer <fweimer@redhat.com> - 3.4.6-8
- Port configure script to C99