diff --git a/sa-update.cronscript b/sa-update.cronscript
index 14498b6..187b9a0 100644
--- a/sa-update.cronscript
+++ b/sa-update.cronscript
@@ -5,28 +5,6 @@
# Place files here to add custom channels.
#
-# list files in a directory consisting only of alphanumerics, hyphens and
-# underscores
-# $1 - directory to list
-# $2 - optional suffix to limit which files are selected
-run_parts_list() {
- if [ $# -lt 1 ]; then
- echo "ERROR: Usage: run_parts_list
" > /dev/stderr
- exit 1
- fi
- if [ ! -d "$1" ]; then
- echo "ERROR: Not a directory: $1" > /dev/stderr
- exit 1
- fi
-
- if [ -d "$1" ]; then
- if [ -n "$2" ]; then
- find_opts='-name *'$2
- fi
- find -L $1 -mindepth 1 -maxdepth 1 -type f $find_opts | sort -n
- fi
-}
-
# Proceed with sa-update if spam daemon is running or forced in /etc/sysconfig/sa-update
unset SAUPDATE
[ -f /etc/sysconfig/sa-update ] && . /etc/sysconfig/sa-update
@@ -48,7 +26,7 @@ fi
CHANNELLIST=""
KEYLIST=""
# Process each channel defined in /etc/mail/spamassassin/channel.d/
-for file in $(run_parts_list /etc/mail/spamassassin/channel.d/ .conf); do
+for file in $(find -L /etc/mail/spamassassin/channel.d/ -mindepth 1 -maxdepth 1 -type f -name '*.conf'); do
# Validate config file
PREFIXES="CHANNELURL KEYID BEGIN"
for prefix in $PREFIXES; do
diff --git a/spamassassin.spec b/spamassassin.spec
index a9d708d..c1c713d 100644
--- a/spamassassin.spec
+++ b/spamassassin.spec
@@ -264,6 +264,9 @@ fi
exit 0
%changelog
+* Sun Jan 24 2010 Warren Togami - 3.3.0-3
+- Fix update script to avoid error if .conf files are in CWD (thanks nirik!)
+
* Thu Jan 21 2010 Warren Togami - 3.3.0-2
- 3.3.0 (really this time!)
- README.RHEL.Fedora