2ed4d7e7af
- amended sos.spec to RHEL-specific - added sos-audit - forward the fix from 8.4 (bz1925419) Signed-off-by: Pavel Moravec <pmoravec@redhat.com>
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From 4fb834ec862228afb276ccbd45aa86c66044ea66 Mon Sep 17 00:00:00 2001
|
|
From: Pavel Moravec <pmoravec@redhat.com>
|
|
Date: Mon, 15 Mar 2021 09:09:51 +0100
|
|
Subject: [PATCH] [gluster] collect public keys from the right dir
|
|
|
|
Collection of glusterfind dir is achieved by /var/lib/gluster
|
|
so it doesn't be collected explicitly.
|
|
|
|
/var/lib/glusterd/glusterfind/.keys/ subdir is required to be
|
|
explicitly collected, as add_copy_spec uses glob.glob() that skips
|
|
hidden files.
|
|
|
|
Resolves: #2451
|
|
|
|
Signed-off-by: Pavel Moravec <pmoravec@redhat.com>
|
|
Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
|
|
---
|
|
sos/report/plugins/gluster.py | 5 ++---
|
|
1 file changed, 2 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/sos/report/plugins/gluster.py b/sos/report/plugins/gluster.py
|
|
index e1a89df2..952cab63 100644
|
|
--- a/sos/report/plugins/gluster.py
|
|
+++ b/sos/report/plugins/gluster.py
|
|
@@ -76,9 +76,8 @@ class Gluster(Plugin, RedHatPlugin):
|
|
"/var/lib/glusterd/",
|
|
# collect nfs-ganesha related configuration
|
|
"/run/gluster/shared_storage/nfs-ganesha/",
|
|
- # collect status files and public ssh keys
|
|
- "/var/lib/glusterd/.keys/",
|
|
- "/var/lib/glusterd/glusterfind/"
|
|
+ # collect public ssh keys (a_s_c skips implicit hidden files)
|
|
+ "/var/lib/glusterd/glusterfind/.keys/",
|
|
] + glob.glob('/run/gluster/*tier-dht/*'))
|
|
|
|
if not self.get_option("all_logs"):
|
|
--
|
|
2.26.2
|
|
|