diff --git a/SOURCES/sos-patch-upstream-3870.patch b/SOURCES/sos-patch-upstream-3870.patch
new file mode 100644
index 0000000..c807edb
--- /dev/null
+++ b/SOURCES/sos-patch-upstream-3870.patch
@@ -0,0 +1,43 @@
+From e2bd0d93a73c3613dd6eb758437fd54f72e83433 Mon Sep 17 00:00:00 2001
+From: Koichiro Iwao
+Date: Wed, 11 Dec 2024 14:59:00 +0900
+Subject: [PATCH] [policies] Fix bug in distro identification
+
+Fixes a bug in #3764.
+
+A bug in the distro-identifying logic caused incorrect identification
+of the distro as CentOS, Fedora, or RHEL under the following conditions:
+
+1. Distro inherits RedHatPolicy
+2. Distro has either of /etc/{centos,fedora,redhat}-release
+3. Policy file appears earlier than redhat.py in dictionary order
+
+The issue occurs because the distro-identifying logic relies on the
+existence of the above os_release_file without examining its contents,
+more than checking NAME or ID in the /etc/os-release file. As a result,
+once /etc/{centos,fedora,redhat}-release is found, the contents of
+/etc/os-release are never checked, leading to distro misidentification.
+
+At least AlmaLinux is affected by this bug.
+
+Signed-off-by: Koichiro Iwao
+---
+ sos/policies/distros/__init__.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/sos/policies/distros/__init__.py b/sos/policies/distros/__init__.py
+index 66970c72d..a2a07a91f 100644
+--- a/sos/policies/distros/__init__.py
++++ b/sos/policies/distros/__init__.py
+@@ -164,7 +164,10 @@ def _check_release(content):
+ if remote:
+ return _check_release(remote)
+ # use the os-specific file primarily
+- if os.path.isfile(cls.os_release_file):
++ # also check the symlink destination
++ if (os.path.isfile(cls.os_release_file) and
++ os.path.basename(cls.os_release_file)
++ == os.path.basename(os.path.realpath(cls.os_release_file))):
+ return True
+ # next check os-release for a NAME or ID value we expect
+ with open(OS_RELEASE, "r", encoding='utf-8') as f:
diff --git a/SPECS/sos.spec b/SPECS/sos.spec
index 3c6722e..69becc9 100644
--- a/SPECS/sos.spec
+++ b/SPECS/sos.spec
@@ -5,7 +5,7 @@
Summary: A set of tools to gather troubleshooting information from a system
Name: sos
Version: 4.8.1
-Release: 1%{?dist}
+Release: 1%{?dist}.alma.1
Group: Applications/System
Source0: https://github.com/sosreport/sos/archive/%{version}/sos-%{version}.tar.gz
Source1: sos-audit-%{auditversion}.tgz
@@ -23,6 +23,9 @@ Recommends: python3-pyyaml
Conflicts: vdsm < 4.40
Obsoletes: sos-collector <= 1.9
+# AlmaLinux patches
+Patch1000: sos-patch-upstream-3870.patch
+
%description
Sos is a set of tools that gathers information about system
hardware and configuration. The information can then be used for
@@ -33,6 +36,9 @@ support technicians and developers.
%setup -qn %{name}-%{version}
%setup -T -D -a1 -q
+# AlmaLinux patches
+%patch1000 -p1
+
%build
%py3_build
@@ -104,6 +110,10 @@ of the system. Currently storage and filesystem commands are audited.
%changelog
+* Fri Dec 13 2024 Koichiro Iwao - 4.8.1-1.alma.1
+- Backport upstream patch to fix distro detection
+ Obtained from: https://github.com/sosreport/sos/pull/3870
+
* Wed Oct 23 2024 Jan Jansky = 4.8.1-1
- Update to 4.8.1 in RHEL 9
Resolves: RHEL-64159