Update to 4.1 (#1933183)
Signed-off-by: Sandro Bonazzola <sbonazzo@redhat.com>
This commit is contained in:
parent
608f343ab6
commit
44a1d21bb5
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ sos-2.2.tar.gz
|
|||||||
/3.8.tar.gz
|
/3.8.tar.gz
|
||||||
/3.9.1.tar.gz
|
/3.9.1.tar.gz
|
||||||
/4.0.tar.gz
|
/4.0.tar.gz
|
||||||
|
/4.1.tar.gz
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From 1d7bab6c7ce3f78758113ca3cdf3e9fa1762df24 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Desrochers <eric.desrochers@canonical.com>
|
|
||||||
Date: Wed, 19 Aug 2020 17:44:07 -0400
|
|
||||||
Subject: [PATCH 01/27] [options] Fix dict order py38 incompatibility
|
|
||||||
|
|
||||||
python-3.8 dict changes introduce a traceback during our config file
|
|
||||||
parsing for options with `-` characters in them.
|
|
||||||
|
|
||||||
Fix this by changing an iteration of the dict keys from `dict.keys()`
|
|
||||||
that returns a dict_keys view, to `list(dict)` which returns a list copy
|
|
||||||
of the keys.
|
|
||||||
|
|
||||||
Closes: #2206
|
|
||||||
Resolves: #2207
|
|
||||||
|
|
||||||
Signed-off-by: Eric Desrochers <eric.desrochers@canonical.com>
|
|
||||||
Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
|
|
||||||
Signed-off-by: Sandro Bonazzola <sbonazzo@redhat.com>
|
|
||||||
---
|
|
||||||
sos/options.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/sos/options.py b/sos/options.py
|
|
||||||
index 3a2b4292..ba3db130 100644
|
|
||||||
--- a/sos/options.py
|
|
||||||
+++ b/sos/options.py
|
|
||||||
@@ -186,7 +186,7 @@ class SoSOptions():
|
|
||||||
if 'verbose' in odict.keys():
|
|
||||||
odict['verbosity'] = int(odict.pop('verbose'))
|
|
||||||
# convert options names
|
|
||||||
- for key in odict.keys():
|
|
||||||
+ for key in list(odict):
|
|
||||||
if '-' in key:
|
|
||||||
odict[key.replace('-', '_')] = odict.pop(key)
|
|
||||||
# set the values according to the config file
|
|
||||||
--
|
|
||||||
2.18.4
|
|
||||||
|
|
11
sos.spec
11
sos.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: A set of tools to gather troubleshooting information from a system
|
Summary: A set of tools to gather troubleshooting information from a system
|
||||||
Name: sos
|
Name: sos
|
||||||
Version: 4.0
|
Version: 4.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: https://github.com/sosreport/sos/archive/%{version}.tar.gz
|
Source0: https://github.com/sosreport/sos/archive/%{version}.tar.gz
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -17,7 +17,6 @@ Requires: bzip2
|
|||||||
Requires: xz
|
Requires: xz
|
||||||
Requires: python3-pexpect
|
Requires: python3-pexpect
|
||||||
Obsoletes: sos-collector <= 1.9
|
Obsoletes: sos-collector <= 1.9
|
||||||
Patch1: 0001-options-Fix-dict-order-py38-incompatibility.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sos is a set of tools that gathers information about system
|
Sos is a set of tools that gathers information about system
|
||||||
@ -27,7 +26,6 @@ support technicians and developers.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -qn %{name}-%{version}
|
%setup -qn %{name}-%{version}
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -42,6 +40,8 @@ install -d -m 755 %{buildroot}%{_sysconfdir}/%{name}/groups.d
|
|||||||
install -d -m 755 %{buildroot}%{_sysconfdir}/%{name}/extras.d
|
install -d -m 755 %{buildroot}%{_sysconfdir}/%{name}/extras.d
|
||||||
install -m 644 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
|
install -m 644 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
|
||||||
|
|
||||||
|
rm -rf %{buildroot}/usr/config/
|
||||||
|
|
||||||
%find_lang %{name} || echo 0
|
%find_lang %{name} || echo 0
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
@ -60,6 +60,9 @@ install -m 644 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
|
|||||||
%config(noreplace) %{_sysconfdir}/sos/sos.conf
|
%config(noreplace) %{_sysconfdir}/sos/sos.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 10 2021 Sandro Bonazzola <sbonazzo@redhat.com> - 4.1-1
|
||||||
|
- Update to 4.1 (#1933183)
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.0-3
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (4.0.tar.gz) = a98a6b4309c982fea73df9c1f7bafec13eb3a40dc7ef613332bb753520850c1e23514efcf61cf3ca144a467abc1b720fae8c2791a972894520bf1b5a72b6774b
|
SHA512 (4.1.tar.gz) = dff6526383531d615a3b8ffe5d9f10b5f5f342220efc3d94ab2490106c52db0ed0a1947596790c2ef8432d2831332885396cf0d22027b4a2d3079fb22a37d4a7
|
||||||
|
Loading…
Reference in New Issue
Block a user