sos updates to 8.9
Resolves: bz2218873 Signed-off-by: Jan Jansky <jjansky@redhat.com>
This commit is contained in:
parent
a7a3d12711
commit
2534cb8bff
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
|||||||
/sos-4.5.3.tar.gz
|
/sos-4.5.3.tar.gz
|
||||||
/sos-4.5.4.tar.gz
|
/sos-4.5.4.tar.gz
|
||||||
/sos-4.5.6.tar.gz
|
/sos-4.5.6.tar.gz
|
||||||
|
/sos-4.6.0.tar.gz
|
||||||
|
@ -1,42 +0,0 @@
|
|||||||
From 0af74a8b24ec9dab0ca0089d5b834ab9908173ac Mon Sep 17 00:00:00 2001
|
|
||||||
From: Periyasamy Palanisamy <pepalani@redhat.com>
|
|
||||||
Date: Fri, 21 Jul 2023 15:03:01 +0530
|
|
||||||
Subject: [PATCH] Collect db files for ovn interconnect environment
|
|
||||||
|
|
||||||
This updates openshift_ovn plugin to collect ovn db files
|
|
||||||
when it is running with interconnect configuration.
|
|
||||||
|
|
||||||
Signed-off-by: Periyasamy Palanisamy <pepalani@redhat.com>
|
|
||||||
---
|
|
||||||
sos/report/plugins/openshift_ovn.py | 10 ++++++++++
|
|
||||||
1 file changed, 10 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/sos/report/plugins/openshift_ovn.py b/sos/report/plugins/openshift_ovn.py
|
|
||||||
index 98522b1ed6..d81fc97aae 100644
|
|
||||||
--- a/sos/report/plugins/openshift_ovn.py
|
|
||||||
+++ b/sos/report/plugins/openshift_ovn.py
|
|
||||||
@@ -27,7 +27,13 @@ def setup(self):
|
|
||||||
"/var/log/openvswitch/libreswan.log",
|
|
||||||
"/var/log/openvswitch/ovs-monitor-ipsec.log"
|
|
||||||
])
|
|
||||||
+ # Collect ovn interconnect specific files if exists.
|
|
||||||
+ self.add_copy_spec([
|
|
||||||
+ "/var/lib/ovn-ic/etc/ovnnb_db.db",
|
|
||||||
+ "/var/lib/ovn-ic/etc/ovnsb_db.db"
|
|
||||||
+ ])
|
|
||||||
|
|
||||||
+ # The ovn cluster/status is not valid anymore for interconnect setup.
|
|
||||||
self.add_cmd_output([
|
|
||||||
'ovn-appctl -t /var/run/ovn/ovnnb_db.ctl ' +
|
|
||||||
'cluster/status OVN_Northbound',
|
|
||||||
@@ -38,6 +44,10 @@ def setup(self):
|
|
||||||
'ovs-appctl -t /var/run/ovn/ovn-controller.*.ctl ' +
|
|
||||||
'ct-zone-list'],
|
|
||||||
container='ovnkube-node')
|
|
||||||
+ # Collect ovs ct-zone-list directly on host for interconnect setup.
|
|
||||||
+ self.add_cmd_output([
|
|
||||||
+ 'ovs-appctl -t /var/run/ovn-ic/ovn-controller.*.ctl ' +
|
|
||||||
+ 'ct-zone-list'])
|
|
||||||
self.add_cmd_output([
|
|
||||||
'ovs-appctl -t ovs-monitor-ipsec tunnels/show',
|
|
||||||
'ipsec status',
|
|
8
sos.spec
8
sos.spec
@ -4,7 +4,7 @@
|
|||||||
|
|
||||||
Summary: A set of tools to gather troubleshooting information from a system
|
Summary: A set of tools to gather troubleshooting information from a system
|
||||||
Name: sos
|
Name: sos
|
||||||
Version: 4.5.6
|
Version: 4.6.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source0: https://github.com/sosreport/sos/archive/%{version}/sos-%{version}.tar.gz
|
Source0: https://github.com/sosreport/sos/archive/%{version}/sos-%{version}.tar.gz
|
||||||
@ -22,7 +22,6 @@ Recommends: python3-pexpect
|
|||||||
Recommends: python3-pyyaml
|
Recommends: python3-pyyaml
|
||||||
Conflicts: vdsm < 4.40
|
Conflicts: vdsm < 4.40
|
||||||
Obsoletes: sos-collector
|
Obsoletes: sos-collector
|
||||||
Patch1: sos-bz2226682-ovn-ic-db-files.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sos is a set of tools that gathers information about system
|
Sos is a set of tools that gathers information about system
|
||||||
@ -33,7 +32,6 @@ support technicians and developers.
|
|||||||
%prep
|
%prep
|
||||||
%setup -qn %{name}-%{version}
|
%setup -qn %{name}-%{version}
|
||||||
%setup -T -D -a1 -q
|
%setup -T -D -a1 -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -106,6 +104,10 @@ of the system. Currently storage and filesystem commands are audited.
|
|||||||
%ghost /etc/audit/rules.d/40-sos-storage.rules
|
%ghost /etc/audit/rules.d/40-sos-storage.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 23 2023 Jan Jansky <jjansky@redhat.com> = 4.6.0-1
|
||||||
|
- [cleaner] Use data filter for extraction
|
||||||
|
Resolves: bz2218873
|
||||||
|
|
||||||
* Thu Jul 27 2023 Pavel Moravec <pmoravec@redhat.com> = 4.5.6-1
|
* Thu Jul 27 2023 Pavel Moravec <pmoravec@redhat.com> = 4.5.6-1
|
||||||
- Rebase sos to 4.5.6
|
- Rebase sos to 4.5.6
|
||||||
Resolves: bz2226724
|
Resolves: bz2226724
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (sos-4.5.6.tar.gz) = 075b7767115dfb112b6a45f75851874c6740b133553659424cffd0a4af40fb6c6a5d5232e3c3c6a82d7868695a42e67e460067de5b9c7964d7b2ff584c091d0b
|
SHA512 (sos-4.6.0.tar.gz) = 55bf85135833969aed78ba69a24737de6d4d687bbeb94a763e663855ab21b4563d222e2b85c5bcbe1b0553e110c2134c486e0d3eef49527be49be293baa45630
|
||||||
SHA512 (sos-audit-0.3.tgz) = 32597baf6350804d08179a0dbe48470a93df148e83d2e49bb3288f6bcc2d151bb1433761913bfbccd912c14de92435939fef5bcd7e091dfe33a345d61ea842ea
|
SHA512 (sos-audit-0.3.tgz) = 32597baf6350804d08179a0dbe48470a93df148e83d2e49bb3288f6bcc2d151bb1433761913bfbccd912c14de92435939fef5bcd7e091dfe33a345d61ea842ea
|
||||||
|
Loading…
Reference in New Issue
Block a user