softhsm-2.3.0 (#1467329)
This commit is contained in:
parent
60e26f9869
commit
3bfd9fcd36
2
.gitignore
vendored
2
.gitignore
vendored
@ -12,3 +12,5 @@
|
||||
/softhsm-2.1.0.tar.gz.sig
|
||||
/softhsm-2.2.0.tar.gz.sig
|
||||
/softhsm-2.2.0.tar.gz
|
||||
/softhsm-2.3.0.tar.gz
|
||||
/softhsm-2.3.0.tar.gz.sig
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff --git a/src/lib/SoftHSM.cpp b/src/lib/SoftHSM.cpp
|
||||
index 2e5504a..b857418 100644
|
||||
--- a/src/lib/SoftHSM.cpp
|
||||
+++ b/src/lib/SoftHSM.cpp
|
||||
@@ -474,7 +474,7 @@ CK_RV SoftHSM::C_Initialize(CK_VOID_PTR pInitArgs)
|
||||
objectStore = new ObjectStore(Configuration::i()->getString("directories.tokendir", DEFAULT_TOKENDIR));
|
||||
if (!objectStore->isValid())
|
||||
{
|
||||
- ERROR_MSG("Could not load the object store");
|
||||
+ WARNING_MSG("Could not load the object store");
|
||||
delete objectStore;
|
||||
objectStore = NULL;
|
||||
delete sessionObjectStore;
|
||||
diff --git a/src/lib/common/softhsm2.conf.in b/src/lib/common/softhsm2.conf.in
|
||||
index b208cb6..bd0a60b 100644
|
||||
--- a/src/lib/common/softhsm2.conf.in
|
||||
+++ b/src/lib/common/softhsm2.conf.in
|
||||
@@ -4,4 +4,4 @@ directories.tokendir = @softhsmtokendir@
|
||||
objectstore.backend = file
|
||||
|
||||
# ERROR, WARNING, INFO, DEBUG
|
||||
-log.level = INFO
|
||||
+log.level = ERROR
|
||||
diff --git a/src/lib/object_store/ObjectStore.cpp b/src/lib/object_store/ObjectStore.cpp
|
||||
index 171cede..3cde15f 100644
|
||||
--- a/src/lib/object_store/ObjectStore.cpp
|
||||
+++ b/src/lib/object_store/ObjectStore.cpp
|
||||
@@ -56,7 +56,7 @@ ObjectStore::ObjectStore(std::string inStorePath)
|
||||
|
||||
if (!storeDir.isValid())
|
||||
{
|
||||
- ERROR_MSG("Failed to enumerate object store in %s", storePath.c_str());
|
||||
+ WARNING_MSG("Failed to enumerate object store in %s", storePath.c_str());
|
||||
|
||||
return;
|
||||
}
|
11
softhsm.spec
11
softhsm.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Software version of a PKCS#11 Hardware Security Module
|
||||
Name: softhsm
|
||||
Version: 2.2.0
|
||||
Release: %{?prever:0.}2%{?prever:.%{prever}}%{?dist}.2
|
||||
Version: 2.3.0
|
||||
Release: %{?prever:0.}1%{?prever:.%{prever}}%{?dist}
|
||||
License: BSD
|
||||
Url: http://www.opendnssec.org/
|
||||
Source: http://dist.opendnssec.org/source/%{?prever:testing/}%{name}-%{version}.tar.gz
|
||||
@ -11,8 +11,6 @@ Source1: http://dist.opendnssec.org/source/%{?prever:testing/}%{name}-%{version}
|
||||
# taken from coolkey which is not build on all arches we build on
|
||||
Source3: softhsm2-pk11install.c
|
||||
|
||||
Patch0: softhsm-v2.2.0-no-stderr.patch
|
||||
|
||||
Group: Applications/System
|
||||
BuildRequires: openssl-devel >= 1.0.1k-6, sqlite-devel >= 3.4.2, cppunit-devel
|
||||
BuildRequires: gcc-c++, pkgconfig, p11-kit-devel, nss-devel
|
||||
@ -46,8 +44,6 @@ The devel package contains the libsofthsm include files
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prever}
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
%if 0%{?prever:1}
|
||||
autoreconf -fiv
|
||||
%endif
|
||||
@ -131,6 +127,9 @@ if [ -f /var/softhsm/slot0.db ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Dec 05 2017 Jakub Jelen <jjelen@redhat.com> - 2.3.0-1
|
||||
- New upstream release (#1467329)
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-2.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (softhsm-2.2.0.tar.gz.sig) = 949f34efc2a24fb4f95f3c372ceafa83e7828f27e1ee8530f4648839d1c930048ba3634ba0c7824ea1be6e3dfdab6c29431455a2e6cc15789419ee21aef3a69d
|
||||
SHA512 (softhsm-2.2.0.tar.gz) = 6ef17deef491f7298244a3d2ddefe25843fc17534c4e5f2e08927f05cafdaf05601beb953539fce5d34fa02fe355cbd4ab3aaabb6e5a106936b04c06aae9793c
|
||||
SHA512 (softhsm-2.3.0.tar.gz) = ef9ee41aa6eaeeb004d4ff5c78ca6e00895cc47e36551025a4422806eee8eead985cfd28476a867761a810f6957b0759edaac769bcdedf4ad974e426cfefce0f
|
||||
SHA512 (softhsm-2.3.0.tar.gz.sig) = 40df888f981b1ec5bb9e83bf087de29948268d8b5a2d9ef95781d07ba409d59d10c7ba709e3476c72ed1b03d7863e15af787e8ec350d47ece5d7719a379926a6
|
||||
|
Loading…
Reference in New Issue
Block a user