* Mon Jun 24 2019 Paul Wouters <pwouters@redhat.com> - 1.7.3.3-1
- Resolves: rhbz#1696931 socat-1.7.3.3 is available - Resolves: rhbz#1612274 Man page scan results for socat - Disabled --enable-fips as its requires fipsld which we don't have.
This commit is contained in:
parent
d1eb3cb5ac
commit
d0fe07422f
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@ socat-1.7.2.0.tar.gz
|
||||
/socat-1.7.2.4.tar.gz
|
||||
/socat-1.7.3.1.tar.gz
|
||||
/socat-1.7.3.2.tar.gz
|
||||
/socat-1.7.3.3.tar.gz
|
||||
|
43
socat-1.7.3.3-warn.patch
Normal file
43
socat-1.7.3.3-warn.patch
Normal file
@ -0,0 +1,43 @@
|
||||
diff -Naur socat-1.7.3.3-orig/sysutils.c socat-1.7.3.3/sysutils.c
|
||||
--- socat-1.7.3.3-orig/sysutils.c 2017-01-08 05:38:53.000000000 -0500
|
||||
+++ socat-1.7.3.3/sysutils.c 2019-06-24 17:02:56.693056583 -0400
|
||||
@@ -614,7 +614,7 @@
|
||||
return -1;
|
||||
}
|
||||
|
||||
- strncpy(ifr.ifr_name, ifname, IFNAMSIZ); /* ok */
|
||||
+ strncpy(ifr.ifr_name, ifname, IFNAMSIZ - 1); /* ok */
|
||||
if (Ioctl(s, SIOCGIFINDEX, &ifr) < 0) {
|
||||
Info3("ioctl(%d, SIOCGIFINDEX, {\"%s\"}): %s",
|
||||
s, ifr.ifr_name, strerror(errno));
|
||||
diff -Naur socat-1.7.3.3-orig/xio-socket.c socat-1.7.3.3/xio-socket.c
|
||||
--- socat-1.7.3.3-orig/xio-socket.c 2017-01-08 04:56:00.000000000 -0500
|
||||
+++ socat-1.7.3.3/xio-socket.c 2019-06-24 17:04:48.684491835 -0400
|
||||
@@ -1710,7 +1710,6 @@
|
||||
int xiocheckpeer(xiosingle_t *xfd,
|
||||
union sockaddr_union *pa, union sockaddr_union *la) {
|
||||
char infobuff[256];
|
||||
- int result;
|
||||
|
||||
#if WITH_IP4
|
||||
if (xfd->para.socket.dorange) {
|
||||
@@ -1778,6 +1777,7 @@
|
||||
#endif /* WITH_TCP || WITH_UDP */
|
||||
|
||||
#if (WITH_TCP || WITH_UDP) && WITH_LIBWRAP
|
||||
+ int result;
|
||||
result = xio_tcpwrap_check(xfd, la, pa);
|
||||
if (result < 0) {
|
||||
char infobuff[256];
|
||||
diff -Naur socat-1.7.3.3-orig/xio-tun.c socat-1.7.3.3/xio-tun.c
|
||||
--- socat-1.7.3.3-orig/xio-tun.c 2017-01-06 15:58:40.000000000 -0500
|
||||
+++ socat-1.7.3.3/xio-tun.c 2019-06-24 17:03:55.276797729 -0400
|
||||
@@ -106,7 +106,7 @@
|
||||
memset(&ifr, 0,sizeof(ifr));
|
||||
|
||||
if (retropt_string(opts, OPT_TUN_NAME, &tunname) == 0) {
|
||||
- strncpy(ifr.ifr_name, tunname, IFNAMSIZ); /* ok */
|
||||
+ strncpy(ifr.ifr_name, tunname, IFNAMSIZ - 1); /* ok */
|
||||
free(tunname);
|
||||
} else {
|
||||
ifr.ifr_name[0] = '\0';
|
20
socat.spec
20
socat.spec
@ -2,11 +2,14 @@
|
||||
|
||||
Summary: Bidirectional data relay between two data channels ('netcat++')
|
||||
Name: socat
|
||||
Version: 1.7.3.2
|
||||
Release: 9%{?dist}
|
||||
Version: 1.7.3.3
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Url: http://www.dest-unreach.org/socat/
|
||||
Source: http://www.dest-unreach.org/socat/download/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch1: socat-1.7.3.3-warn.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: openssl-devel readline-devel ncurses-devel
|
||||
BuildRequires: autoconf kernel-headers > 2.6.18
|
||||
@ -25,6 +28,7 @@ line editor (readline), a program, or a combination of two of these.
|
||||
%setup -q
|
||||
iconv -f iso8859-1 -t utf-8 CHANGES > CHANGES.utf8
|
||||
mv CHANGES.utf8 CHANGES
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -36,7 +40,7 @@ mv CHANGES.utf8 CHANGES
|
||||
--enable-listen --enable-proxy --enable-exec \
|
||||
--enable-system --enable-pty --enable-readline \
|
||||
--enable-openssl --enable-sycls --enable-filan \
|
||||
--enable-retry --enable-fips
|
||||
--enable-retry # --enable-fips
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -44,12 +48,15 @@ make %{?_smp_mflags}
|
||||
make DESTDIR=%{buildroot} install
|
||||
install -d %{buildroot}/%{_docdir}/socat
|
||||
install -m 0644 *.sh %{buildroot}/%{_docdir}/socat/
|
||||
echo ".so man1/socat.1" | gzip > %{buildroot}/%{_mandir}/man1/filan.1.gz
|
||||
cp -a %{buildroot}/%{_mandir}/man1/filan.1.gz %{buildroot}/%{_mandir}/man1/procan.1.gz
|
||||
|
||||
%check
|
||||
export TERM=ansi
|
||||
export OD_C=/usr/bin/od
|
||||
# intermittently, a test sometimes just fails and hangs, mostly on arm
|
||||
#timeout 30m make test
|
||||
make test
|
||||
|
||||
%files
|
||||
%doc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ PORTING
|
||||
@ -58,9 +65,14 @@ export OD_C=/usr/bin/od
|
||||
%{_bindir}/socat
|
||||
%{_bindir}/filan
|
||||
%{_bindir}/procan
|
||||
%doc %{_mandir}/man1/socat.1*
|
||||
%doc %{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 24 2019 Paul Wouters <pwouters@redhat.com> - 1.7.3.3-1
|
||||
- Resolves: rhbz#1696931 socat-1.7.3.3 is available
|
||||
- Resolves: rhbz#1612274 Man page scan results for socat
|
||||
- Disabled --enable-fips as its requires fipsld which we don't have.
|
||||
|
||||
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.7.3.2-9
|
||||
- Rebuild for readline 8.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (socat-1.7.3.2.tar.gz) = 540658b2a3d1b87673196282e5c62b97681bd0f1d1e4759ff9d72909d11060235ee9e9521a973603c1b00376436a9444248e5fbc0ffac65f8edb9c9bc28e7972
|
||||
SHA512 (socat-1.7.3.3.tar.gz) = b3ea4cb6081f7778a0281a3ec36ea7e5daf07dc19f2e0de08f767417112776e96e1bcac7962ebb6dd8b960ad91fc4a452f0da8327736d50e215e4ab43947ff78
|
||||
|
Loading…
Reference in New Issue
Block a user