update to version 1.1.10

This commit is contained in:
Martin Gieseking 2023-03-09 10:38:06 +01:00
parent d54a43d99b
commit e51b3156f7
5 changed files with 14 additions and 24 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/snappy-1.1.7.tar.gz
/snappy-1.1.8.tar.gz
/snappy-1.1.9.tar.gz
/snappy-1.1.10.tar.gz

View File

@ -1,12 +0,0 @@
diff -r fd16c2ca3237 snappy.cc
--- a/snappy.cc Sat May 15 15:06:59 2021 +0200
+++ b/snappy.cc Sat May 15 15:07:31 2021 +0200
@@ -1014,7 +1014,7 @@
}
SNAPPY_ATTRIBUTE_ALWAYS_INLINE
-size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
const uint8_t*& ip = *ip_p;
// This section is crucial for the throughput of the decompression loop.
// The latency of an iteration is fundamentally constrained by the

View File

@ -1,7 +1,7 @@
diff -r efdeda5cdfa2 CMakeLists.txt
--- a/CMakeLists.txt Sat May 15 14:50:17 2021 +0200
+++ b/CMakeLists.txt Sat May 15 14:54:41 2021 +0200
@@ -284,29 +284,12 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -306,29 +306,12 @@
if(SNAPPY_BUILD_TESTS)
enable_testing()
@ -32,7 +32,7 @@ diff -r efdeda5cdfa2 CMakeLists.txt
add_test(
NAME snappy_unittest
@@ -327,12 +310,11 @@
@@ -349,12 +332,11 @@
PRIVATE
"snappy_benchmark.cc"
)

View File

@ -1,7 +1,7 @@
%global __cmake_in_source_build 1
Name: snappy
Version: 1.1.9
Release: 7%{?dist}
Version: 1.1.10
Release: 1%{?dist}
Summary: Fast compression and decompression library
License: BSD
@ -11,11 +11,8 @@ Source0: https://github.com/google/snappy/releases/download/%{version}/%{
# Remove dependency on bundled gtest and google-benchmark.
Patch0: %{name}-thirdparty.patch
# Prevent compiler error due to missing 'inline'.
Patch1: %{name}-inline.patch
# Do not forcibly disable RTTI
Patch2: %{name}-do-not-disable-rtti.patch
Patch1: %{name}-do-not-disable-rtti.patch
BuildRequires: make
BuildRequires: cmake
@ -96,6 +93,10 @@ ctest -V %{?_smp_mflags}
%changelog
* Thu Mar 09 2023 Martin Gieseking <martin.gieseking@uos.de> - 1.1.10-1
- Updated to version 1.1.10.
- Removed snappy-inline.patch as it's no longer required.
* Tue Jan 31 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 1.1.9-7
- Build with C++14 instead of C++11; gtest 1.13.0 requires it

View File

@ -1 +1 @@
SHA512 (snappy-1.1.9.tar.gz) = f1f8a90f5f7f23310423574b1d8c9acb84c66ea620f3999d1060395205e5760883476837aba02f0aa913af60819e34c625d8308c18a5d7a9c4e190f35968b024
SHA512 (snappy-1.1.10.tar.gz) = 3578597f1d4ec09104ce0296b825b013590351230dfe56c635081fd282ce7a13a34caf2c283ac77bd24065e2d27af6db068d1f84b98cec2fd39a0e37a0d77070