updated to version 1.1.8
This commit is contained in:
parent
8b79280e7b
commit
c784597487
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/snappy-1.1.3.tar.gz
|
||||
/snappy-1.1.4.tar.gz
|
||||
/snappy-1.1.7.tar.gz
|
||||
/snappy-1.1.8.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -118,7 +118,7 @@
|
||||
"${PROJECT_SOURCE_DIR}/snappy-test.cc"
|
||||
@@ -212,7 +212,7 @@
|
||||
"snappy-test.cc"
|
||||
)
|
||||
target_compile_definitions(snappy_unittest PRIVATE -DHAVE_CONFIG_H)
|
||||
- target_link_libraries(snappy_unittest snappy ${GFLAGS_LIBRARIES})
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/snappy-stubs-public.h.in b/snappy-stubs-public.h.in
|
||||
index 3fd79bb..bb5b222 100644
|
||||
--- a/snappy-stubs-public.h.in
|
||||
+++ b/snappy-stubs-public.h.in
|
||||
@@ -48,9 +48,9 @@
|
||||
#include <sys/uio.h>
|
||||
#endif // HAVE_SYS_UIO_H
|
||||
|
||||
-#define SNAPPY_MAJOR ${SNAPPY_MAJOR}
|
||||
-#define SNAPPY_MINOR ${SNAPPY_MINOR}
|
||||
-#define SNAPPY_PATCHLEVEL ${SNAPPY_PATCHLEVEL}
|
||||
+#define SNAPPY_MAJOR ${PROJECT_VERSION_MAJOR}
|
||||
+#define SNAPPY_MINOR ${PROJECT_VERSION_MINOR}
|
||||
+#define SNAPPY_PATCHLEVEL ${PROJECT_VERSION_PATCH}
|
||||
#define SNAPPY_VERSION \
|
||||
((SNAPPY_MAJOR << 16) | (SNAPPY_MINOR << 8) | SNAPPY_PATCHLEVEL)
|
||||
|
11
snappy.spec
11
snappy.spec
@ -1,6 +1,6 @@
|
||||
Name: snappy
|
||||
Version: 1.1.7
|
||||
Release: 9%{?dist}
|
||||
Version: 1.1.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Fast compression and decompression library
|
||||
|
||||
License: BSD
|
||||
@ -9,8 +9,6 @@ Source0: https://github.com/google/snappy/releases/download/%{version}/%{
|
||||
|
||||
# add missing dependency on gtest to snappy_unittest
|
||||
Patch0: %{name}-gtest.patch
|
||||
# fix version macros in snappy-stubs-public.h.in (BZ #1527850)
|
||||
Patch1: %{name}-version-macros.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -39,7 +37,6 @@ developing applications that use %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake .
|
||||
@ -88,6 +85,10 @@ ctest -V %{?_smp_mflags}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 15 2020 Martin Gieseking <martin.gieseking@uos.de> - 1.1.8-1
|
||||
- Updated to new release.
|
||||
- Dropped version-related patch which has been applied upstream (BZ #1527850).
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.7-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (snappy-1.1.7.tar.gz) = 32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf
|
||||
SHA512 (snappy-1.1.8.tar.gz) = efe18ff1b3edda1b4b6cefcbc6da8119c05d63afdbf7a784f3490353c74dced76baed7b5f1aa34b99899729192b9d657c33c76de4b507a51553fa8001ae75c1c
|
||||
|
Loading…
Reference in New Issue
Block a user