update to version 1.1.7
This commit is contained in:
parent
18954ee426
commit
511fd951d2
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
|||||||
/snappy-1.1.1.tar.gz
|
/snappy-1.1.1.tar.gz
|
||||||
/snappy-1.1.3.tar.gz
|
/snappy-1.1.3.tar.gz
|
||||||
/snappy-1.1.4.tar.gz
|
/snappy-1.1.4.tar.gz
|
||||||
|
/snappy-1.1.7.tar.gz
|
||||||
|
12
snappy-gtest.patch
Normal file
12
snappy-gtest.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -118,7 +118,7 @@
|
||||||
|
"${PROJECT_SOURCE_DIR}/snappy-test.cc"
|
||||||
|
)
|
||||||
|
target_compile_definitions(snappy_unittest PRIVATE -DHAVE_CONFIG_H)
|
||||||
|
- target_link_libraries(snappy_unittest snappy ${GFLAGS_LIBRARIES})
|
||||||
|
+ target_link_libraries(snappy_unittest snappy ${GTEST_LIBRARIES} ${GFLAGS_LIBRARIES})
|
||||||
|
|
||||||
|
if(HAVE_LIBZ)
|
||||||
|
target_link_libraries(snappy_unittest z)
|
53
snappy.spec
53
snappy.spec
@ -1,18 +1,19 @@
|
|||||||
Name: snappy
|
Name: snappy
|
||||||
Version: 1.1.4
|
Version: 1.1.7
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Fast compression and decompression library
|
Summary: Fast compression and decompression library
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://code.google.com/p/snappy/
|
URL: https://github.com/google/snappy
|
||||||
Source0: https://github.com/google/snappy/releases/download/%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/google/snappy/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
# add missing dependency on gtest to snappy_unittest
|
||||||
|
Patch0: %{name}-gtest.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake
|
||||||
BuildRequires: gtest-devel
|
BuildRequires: gtest-devel
|
||||||
BuildRequires: autoconf
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: libtool
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Snappy is a compression/decompression library. It does not aim for maximum
|
Snappy is a compression/decompression library. It does not aim for maximum
|
||||||
@ -27,6 +28,7 @@ bigger.
|
|||||||
Summary: Development files for %{name}
|
Summary: Development files for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: cmake-filesystem
|
||||||
Requires: pkgconfig
|
Requires: pkgconfig
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
@ -36,26 +38,42 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
%cmake .
|
||||||
%configure CXXFLAGS="%{optflags} -DNDEBUG" --disable-static
|
%make_build
|
||||||
make %{?_smp_mflags}
|
|
||||||
|
# create pkgconfig file
|
||||||
|
cat << EOF >snappy.pc
|
||||||
|
prefix=%{_prefix}
|
||||||
|
exec_prefix=%{_exec_prefix}
|
||||||
|
includedir=%{_includedir}
|
||||||
|
libdir=%{_libdir}
|
||||||
|
|
||||||
|
Name: %{name}
|
||||||
|
Description: A fast compression/decompression library
|
||||||
|
Version: %{version}
|
||||||
|
Cflags: -I\${includedir}
|
||||||
|
Libs: -L\${libdir} -lsnappy
|
||||||
|
EOF
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
chmod 644 *.txt AUTHORS ChangeLog COPYING NEWS README
|
chmod 644 *.txt AUTHORS COPYING NEWS README.md
|
||||||
make install DESTDIR=%{buildroot}
|
%make_install
|
||||||
|
install -m644 -D snappy.pc %{buildroot}%{_libdir}/pkgconfig/snappy.pc
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/cmake/Modules/
|
||||||
|
mv %{buildroot}%{_libdir}/cmake/Snappy/*cmake %{buildroot}%{_datadir}/cmake/Modules/
|
||||||
rm -rf %{buildroot}%{_datadir}/doc/snappy/
|
rm -rf %{buildroot}%{_datadir}/doc/snappy/
|
||||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
rm -rf %{buildroot}%{_datadir}/doc/snappy-devel/
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check
|
ctest -V %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
@ -65,7 +83,7 @@ make check
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc AUTHORS ChangeLog COPYING NEWS README
|
%doc AUTHORS COPYING NEWS README.md
|
||||||
%{_libdir}/libsnappy.so.*
|
%{_libdir}/libsnappy.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -74,9 +92,14 @@ make check
|
|||||||
%{_includedir}/snappy*.h
|
%{_includedir}/snappy*.h
|
||||||
%{_libdir}/libsnappy.so
|
%{_libdir}/libsnappy.so
|
||||||
%{_libdir}/pkgconfig/snappy.pc
|
%{_libdir}/pkgconfig/snappy.pc
|
||||||
|
%{_datadir}/cmake/Modules/*.cmake
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 25 2017 Martin Gieseking <martin.gieseking@uos.de> - 1.1.7-1
|
||||||
|
- Updated to new release.
|
||||||
|
- Build with CMake since autotool support is deprecated.
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-5
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (snappy-1.1.4.tar.gz) = 873f655713611f4bdfc13ab2a6d09245681f427fbd4f6a7a880a49b8c526875dbdd623e203905450268f542be24a2dc9dae50e6acc1516af1d2ffff3f96553da
|
SHA512 (snappy-1.1.7.tar.gz) = 32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf
|
||||||
|
Loading…
Reference in New Issue
Block a user