- fix LDFLAGS injection (#1567902)
This commit is contained in:
parent
ae8c539903
commit
1ef1168f10
@ -25,3 +25,17 @@ diff -up smc-tools-1.0.0/Makefile.ldflags smc-tools-1.0.0/Makefile
|
||||
else
|
||||
$(warning "Warning: Skipping 31/32-bit library build because 31/32-bit \
|
||||
build tools are unavailable. SMC-R will not support 31 and 32 bit TCP \
|
||||
diff -up smc-tools-1.0.0/Makefile.ldflags smc-tools-1.0.0/Makefile
|
||||
--- smc-tools-1.0.0/Makefile.ldflags 2018-04-16 14:04:44.000000000 +0200
|
||||
+++ smc-tools-1.0.0/Makefile 2018-04-16 14:05:06.000000000 +0200
|
||||
@@ -96,8 +96,8 @@ endif
|
||||
|
||||
smc_pnet: smc_pnet.c smc.h
|
||||
@if [ -e /usr/include/libnl3/netlink/netlink.h ]; then \
|
||||
- echo ${CC} ${CFLAGS} ${SMC_PNET_CFLAGS} -o $@ $< ${SMC_PNET_LFLAGS}; \
|
||||
- ${CC} ${CFLAGS} ${SMC_PNET_CFLAGS} -o $@ $< ${SMC_PNET_LFLAGS}; \
|
||||
+ echo ${CC} ${CFLAGS} ${SMC_PNET_CFLAGS} ${LDFLAGS} -o $@ $< ${SMC_PNET_LFLAGS}; \
|
||||
+ ${CC} ${CFLAGS} ${SMC_PNET_CFLAGS} ${LDFLAGS} -o $@ $< ${SMC_PNET_LFLAGS}; \
|
||||
else \
|
||||
printf "*********************************************\n" >&2; \
|
||||
printf "* Missing build requirement for: %-45s\n" $@ >&2; \
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: smc-tools
|
||||
Version: 1.0.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Shared Memory Communication Tools
|
||||
|
||||
License: EPL
|
||||
@ -48,6 +48,9 @@ sockets in Linux.
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 16 2018 Dan Horák <dan@danny.cz> - 1.0.0-4
|
||||
- fix LDFLAGS injection (#1567902)
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user