Update to 1.6.1
Related: rhbz#2017065 Signed-off-by: Čestmír Kalina <ckalina@redhat.com>
This commit is contained in:
parent
c3b8660d3c
commit
00ab0f7850
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/smc-tools-*.tar.gz
|
||||
/1.6.1.tar.gz
|
||||
|
@ -1,90 +0,0 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 427fc71..b80eaf1 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -61,16 +61,16 @@ endif
|
||||
all: libsmc-preload.so libsmc-preload32.so smcd smcr smcss smc_pnet
|
||||
|
||||
CFLAGS ?= -Wall -O3 -g
|
||||
-ALL_CFLAGS = -DSMC_TOOLS_RELEASE=$(SMC_TOOLS_RELEASE) $(CFLAGS)
|
||||
-
|
||||
ifneq ($(shell sh -c 'command -v pkg-config'),)
|
||||
-SMC_PNET_CFLAGS = $(shell pkg-config --silence-errors --cflags libnl-genl-3.0)
|
||||
-SMC_PNET_LFLAGS = $(shell pkg-config --silence-errors --libs libnl-genl-3.0)
|
||||
+LIBNL_CFLAGS = $(shell pkg-config --silence-errors --cflags libnl-genl-3.0)
|
||||
+LIBNL_LFLAGS = $(shell pkg-config --silence-errors --libs libnl-genl-3.0)
|
||||
else
|
||||
-SMC_PNET_CFLAGS = -I /usr/include/libnl3
|
||||
-SMC_PNET_LFLAGS = -lnl-genl-3 -lnl-3
|
||||
+LIBNL_CFLAGS = -I /usr/include/libnl3
|
||||
+LIBNL_LFLAGS = -lnl-genl-3 -lnl-3
|
||||
endif
|
||||
-CFLAGS += ${SMC_PNET_CFLAGS}
|
||||
+ALL_CFLAGS += ${CFLAGS} -DSMC_TOOLS_RELEASE=$(SMC_TOOLS_RELEASE) \
|
||||
+ ${LIBNL_CFLAGS} ${OPTFLAGS}
|
||||
+ALL_LDFLAGS += ${LDFLAGS} ${LIBNL_LFLAGS}
|
||||
|
||||
ifeq ($(ARCHTYPE),s390x)
|
||||
MACHINE_OPT32="-m31"
|
||||
@@ -79,23 +79,23 @@ else
|
||||
endif
|
||||
|
||||
util.o: util.c util.h
|
||||
- ${CCC} ${CFLAGS} -c util.c
|
||||
+ ${CCC} ${ALL_CFLAGS} -c util.c
|
||||
|
||||
libnetlink.o: libnetlink.c libnetlink.h
|
||||
- ${CCC} ${CFLAGS} ${LDFLAGS} -c libnetlink.c
|
||||
+ ${CCC} ${ALL_CFLAGS} ${ALL_LDFLAGS} -c libnetlink.c
|
||||
|
||||
smc-preload.o: smc-preload.c
|
||||
- ${CCC} ${CFLAGS} -fPIC -c smc-preload.c
|
||||
+ ${CCC} ${ALL_CFLAGS} -fPIC -c smc-preload.c
|
||||
|
||||
libsmc-preload.so: smc-preload.o
|
||||
- ${LINK} ${LDFLAGS} -shared smc-preload.o -ldl -Wl,-z,defs,-soname,$@.$(VER_MAJOR) -o $@
|
||||
+ ${LINK} ${ALL_LDFLAGS} -shared smc-preload.o -ldl -Wl,-z,defs,-soname,$@.$(VER_MAJOR) -o $@
|
||||
chmod u+s $@
|
||||
|
||||
libsmc-preload32.so: smc-preload.c
|
||||
ifeq ($(ARCH),64)
|
||||
ifeq ($(STUFF_32BIT),1)
|
||||
- ${CCC} ${CFLAGS} -fPIC -c ${MACHINE_OPT32} $< -o smc-preload32.o
|
||||
- ${LINK} ${LDFLAGS} -shared smc-preload32.o ${MACHINE_OPT32} -ldl -Wl,-soname,$@.$(VER_MAJOR) -o $@
|
||||
+ ${CCC} ${ALL_CFLAGS} -fPIC -c ${MACHINE_OPT32} $< -o smc-preload32.o
|
||||
+ ${LINK} ${ALL_LDFLAGS} -shared smc-preload32.o ${MACHINE_OPT32} -ldl -Wl,-soname,$@.$(VER_MAJOR) -o $@
|
||||
chmod u+s $@
|
||||
else
|
||||
$(warning "Warning: Skipping 31/32-bit library build because 31/32-bit build tools")
|
||||
@@ -116,13 +116,13 @@ endif
|
||||
${CCC} ${ALL_CFLAGS} -c $< -o $@
|
||||
|
||||
smc: smc.o dev.o linkgroup.o libnetlink.o util.o
|
||||
- ${CCC} ${ALL_CFLAGS} ${LDFLAGS} $^ ${SMC_PNET_LFLAGS} -o $@
|
||||
+ ${CCC} ${ALL_CFLAGS} ${ALL_LDFLAGS} $^ -o $@
|
||||
|
||||
smcd: smcd.o infod.o devd.o linkgroupd.o libnetlink.o util.o
|
||||
- ${CCC} ${ALL_CFLAGS} ${LDFLAGS} $^ ${SMC_PNET_LFLAGS} -o $@
|
||||
+ ${CCC} ${ALL_CFLAGS} $^ ${ALL_LDFLAGS} -o $@
|
||||
|
||||
smcr: smcr.o infor.o devr.o linkgroupr.o libnetlink.o util.o
|
||||
- ${CCC} ${ALL_CFLAGS} ${LDFLAGS} $^ ${SMC_PNET_LFLAGS} -o $@
|
||||
+ ${CCC} ${ALL_CFLAGS} $^ ${ALL_LDFLAGS} -o $@
|
||||
|
||||
smc_pnet: smc_pnet.c smctools_common.h
|
||||
@if [ ! -e /usr/include/libnl3/netlink/netlink.h ]; then \
|
||||
@@ -135,12 +135,10 @@ smc_pnet: smc_pnet.c smctools_common.h
|
||||
printf "**************************************************************\n" >&2; \
|
||||
exit 1; \
|
||||
fi
|
||||
- ${CCC} ${ALL_CFLAGS} ${SMC_PNET_CFLAGS} ${LDFLAGS} -o $@ $< ${SMC_PNET_LFLAGS}
|
||||
+ ${CCC} ${ALL_CFLAGS} $< ${ALL_LDFLAGS} -o $@
|
||||
|
||||
smcss: smcss.o libnetlink.o
|
||||
- ${CCC} ${ALL_CFLAGS} ${LDFLAGS} $^ ${SMC_PNET_LFLAGS} -o $@
|
||||
-#smcss: smcss.c smctools_common.h libnetlink.h
|
||||
-# ${CCC} ${ALL_CFLAGS} ${LDFLAGS} $< -o $@
|
||||
+ ${CCC} ${ALL_CFLAGS} $^ ${ALL_LDFLAGS} -o $@
|
||||
|
||||
install: all
|
||||
echo " INSTALL"
|
@ -1,29 +0,0 @@
|
||||
From c3d1f45abff2433afefaea9d31cd9cda0a7408d3 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Raspl <raspl@de.ibm.com>
|
||||
Date: Mon, 8 Feb 2021 16:43:01 +0100
|
||||
Subject: [PATCH] Makefile: Install smc_chk.8 on s390 only
|
||||
|
||||
Since smc_chk depends on smc_rnics (which is s390-only), we should not
|
||||
install the man-page on non-s390 platforms, too.
|
||||
|
||||
Signed-off-by: Stefan Raspl <raspl@linux.ibm.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
README.md | 1 +
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index a9068d0..427fc71 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -161,9 +161,9 @@ ifeq ($(shell uname -m | cut -c1-4),s390)
|
||||
install $(INSTALL_FLAGS_BIN) smc_rnics $(DESTDIR)$(BINDIR)
|
||||
install $(INSTALL_FLAGS_MAN) smc_rnics.8 $(DESTDIR)$(MANDIR)/man8
|
||||
install $(INSTALL_FLAGS_BIN) smc_chk $(DESTDIR)$(BINDIR)
|
||||
+ install $(INSTALL_FLAGS_MAN) smc_chk.8 $(DESTDIR)$(MANDIR)/man8
|
||||
endif
|
||||
install $(INSTALL_FLAGS_MAN) af_smc.7 $(DESTDIR)$(MANDIR)/man7
|
||||
- install $(INSTALL_FLAGS_MAN) smc_chk.8 $(DESTDIR)$(MANDIR)/man8
|
||||
install $(INSTALL_FLAGS_MAN) smc_run.8 $(DESTDIR)$(MANDIR)/man8
|
||||
install $(INSTALL_FLAGS_MAN) smc_pnet.8 $(DESTDIR)$(MANDIR)/man8
|
||||
install $(INSTALL_FLAGS_MAN) smcss.8 $(DESTDIR)$(MANDIR)/man8
|
@ -1,11 +1,11 @@
|
||||
Name: smc-tools
|
||||
Version: 1.6.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.6.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Shared Memory Communication Tools
|
||||
|
||||
License: EPL
|
||||
License: EPL-1.0
|
||||
URL: https://github.com/ibm-s390-linux/smc-tools
|
||||
Source0: https://github.com/ibm-s390-linux/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Source0: https://github.com/ibm-s390-linux/%{name}/archive/refs/tags/%{version}.tar.gz
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -62,6 +62,9 @@ sockets in Linux.
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 26 2021 Čestmír Kalina <ckalina@redhat.com> - 1.6.1-1
|
||||
- Resolves: #2017065 Update smc-tools to 1.6.1
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.6.0-2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (smc-tools-1.6.0.tar.gz) = 8df94698b0d5b5d9148b1c2501c278cee6ff620b1845ab5c3ada465a449f0d928dd324aa67f033a48d5cfd359ea22363e2569a3b6d8aa471f36622078a7c7d23
|
||||
SHA512 (1.6.1.tar.gz) = b5801414cf0e9e6dbbe2d289ad116668f367fafeb6e3a4e3a288a8f4d34f3dd42440817b67e506a7baf1c43b796047672330650d61df045427d811cf83141ab8
|
||||
|
Loading…
Reference in New Issue
Block a user