import slf4j-1.7.25-4.module+el8.1.0+3366+6dfb954c
This commit is contained in:
commit
4932e10124
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/slf4j-1.7.25.tar.gz
|
1
.slf4j.metadata
Normal file
1
.slf4j.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
f564e3825b62172e81874ec73fafcc2747fb3d3b SOURCES/slf4j-1.7.25.tar.gz
|
@ -0,0 +1,44 @@
|
|||||||
|
From b1c0ca75ca38a7a8b50bfdfdf2c324169a6ddf02 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
|
Date: Mon, 19 Mar 2018 16:01:57 +0100
|
||||||
|
Subject: [PATCH] Disallow EventData deserialization by default
|
||||||
|
|
||||||
|
---
|
||||||
|
.../src/main/java/org/slf4j/ext/EventData.java | 21 +++++++++++++++------
|
||||||
|
1 file changed, 15 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/slf4j-ext/src/main/java/org/slf4j/ext/EventData.java b/slf4j-ext/src/main/java/org/slf4j/ext/EventData.java
|
||||||
|
index dc5b502..fa5c125 100644
|
||||||
|
--- a/slf4j-ext/src/main/java/org/slf4j/ext/EventData.java
|
||||||
|
+++ b/slf4j-ext/src/main/java/org/slf4j/ext/EventData.java
|
||||||
|
@@ -76,12 +76,21 @@ public class EventData implements Serializable {
|
||||||
|
*/
|
||||||
|
@SuppressWarnings("unchecked")
|
||||||
|
public EventData(String xml) {
|
||||||
|
- ByteArrayInputStream bais = new ByteArrayInputStream(xml.getBytes());
|
||||||
|
- try {
|
||||||
|
- XMLDecoder decoder = new XMLDecoder(bais);
|
||||||
|
- this.eventData = (Map<String, Object>) decoder.readObject();
|
||||||
|
- } catch (Exception e) {
|
||||||
|
- throw new EventException("Error decoding " + xml, e);
|
||||||
|
+ if ("1".equals(System.getProperty("org.slf4j.ext.allowInsecureDeserialization"))) {
|
||||||
|
+ ByteArrayInputStream bais = new ByteArrayInputStream(xml.getBytes());
|
||||||
|
+ try {
|
||||||
|
+ XMLDecoder decoder = new XMLDecoder(bais);
|
||||||
|
+ this.eventData = (Map<String, Object>) decoder.readObject();
|
||||||
|
+ } catch (Exception e) {
|
||||||
|
+ throw new EventException("Error decoding " + xml, e);
|
||||||
|
+ }
|
||||||
|
+ } else {
|
||||||
|
+ throw new UnsupportedOperationException(
|
||||||
|
+ "Constructing EventData from XML is vulnerable to remote " +
|
||||||
|
+ "excution and is not allowed by default. If you're " +
|
||||||
|
+ "completely sure the source data is trusted, you can enable " +
|
||||||
|
+ "it by setting org.slf4j.ext.allowInsecureDeserialization " +
|
||||||
|
+ "JVM property to 1");
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.14.3
|
||||||
|
|
202
SOURCES/LICENSE-2.0.txt
Normal file
202
SOURCES/LICENSE-2.0.txt
Normal file
@ -0,0 +1,202 @@
|
|||||||
|
|
||||||
|
Apache License
|
||||||
|
Version 2.0, January 2004
|
||||||
|
http://www.apache.org/licenses/
|
||||||
|
|
||||||
|
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
|
||||||
|
|
||||||
|
1. Definitions.
|
||||||
|
|
||||||
|
"License" shall mean the terms and conditions for use, reproduction,
|
||||||
|
and distribution as defined by Sections 1 through 9 of this document.
|
||||||
|
|
||||||
|
"Licensor" shall mean the copyright owner or entity authorized by
|
||||||
|
the copyright owner that is granting the License.
|
||||||
|
|
||||||
|
"Legal Entity" shall mean the union of the acting entity and all
|
||||||
|
other entities that control, are controlled by, or are under common
|
||||||
|
control with that entity. For the purposes of this definition,
|
||||||
|
"control" means (i) the power, direct or indirect, to cause the
|
||||||
|
direction or management of such entity, whether by contract or
|
||||||
|
otherwise, or (ii) ownership of fifty percent (50%) or more of the
|
||||||
|
outstanding shares, or (iii) beneficial ownership of such entity.
|
||||||
|
|
||||||
|
"You" (or "Your") shall mean an individual or Legal Entity
|
||||||
|
exercising permissions granted by this License.
|
||||||
|
|
||||||
|
"Source" form shall mean the preferred form for making modifications,
|
||||||
|
including but not limited to software source code, documentation
|
||||||
|
source, and configuration files.
|
||||||
|
|
||||||
|
"Object" form shall mean any form resulting from mechanical
|
||||||
|
transformation or translation of a Source form, including but
|
||||||
|
not limited to compiled object code, generated documentation,
|
||||||
|
and conversions to other media types.
|
||||||
|
|
||||||
|
"Work" shall mean the work of authorship, whether in Source or
|
||||||
|
Object form, made available under the License, as indicated by a
|
||||||
|
copyright notice that is included in or attached to the work
|
||||||
|
(an example is provided in the Appendix below).
|
||||||
|
|
||||||
|
"Derivative Works" shall mean any work, whether in Source or Object
|
||||||
|
form, that is based on (or derived from) the Work and for which the
|
||||||
|
editorial revisions, annotations, elaborations, or other modifications
|
||||||
|
represent, as a whole, an original work of authorship. For the purposes
|
||||||
|
of this License, Derivative Works shall not include works that remain
|
||||||
|
separable from, or merely link (or bind by name) to the interfaces of,
|
||||||
|
the Work and Derivative Works thereof.
|
||||||
|
|
||||||
|
"Contribution" shall mean any work of authorship, including
|
||||||
|
the original version of the Work and any modifications or additions
|
||||||
|
to that Work or Derivative Works thereof, that is intentionally
|
||||||
|
submitted to Licensor for inclusion in the Work by the copyright owner
|
||||||
|
or by an individual or Legal Entity authorized to submit on behalf of
|
||||||
|
the copyright owner. For the purposes of this definition, "submitted"
|
||||||
|
means any form of electronic, verbal, or written communication sent
|
||||||
|
to the Licensor or its representatives, including but not limited to
|
||||||
|
communication on electronic mailing lists, source code control systems,
|
||||||
|
and issue tracking systems that are managed by, or on behalf of, the
|
||||||
|
Licensor for the purpose of discussing and improving the Work, but
|
||||||
|
excluding communication that is conspicuously marked or otherwise
|
||||||
|
designated in writing by the copyright owner as "Not a Contribution."
|
||||||
|
|
||||||
|
"Contributor" shall mean Licensor and any individual or Legal Entity
|
||||||
|
on behalf of whom a Contribution has been received by Licensor and
|
||||||
|
subsequently incorporated within the Work.
|
||||||
|
|
||||||
|
2. Grant of Copyright License. Subject to the terms and conditions of
|
||||||
|
this License, each Contributor hereby grants to You a perpetual,
|
||||||
|
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
|
||||||
|
copyright license to reproduce, prepare Derivative Works of,
|
||||||
|
publicly display, publicly perform, sublicense, and distribute the
|
||||||
|
Work and such Derivative Works in Source or Object form.
|
||||||
|
|
||||||
|
3. Grant of Patent License. Subject to the terms and conditions of
|
||||||
|
this License, each Contributor hereby grants to You a perpetual,
|
||||||
|
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
|
||||||
|
(except as stated in this section) patent license to make, have made,
|
||||||
|
use, offer to sell, sell, import, and otherwise transfer the Work,
|
||||||
|
where such license applies only to those patent claims licensable
|
||||||
|
by such Contributor that are necessarily infringed by their
|
||||||
|
Contribution(s) alone or by combination of their Contribution(s)
|
||||||
|
with the Work to which such Contribution(s) was submitted. If You
|
||||||
|
institute patent litigation against any entity (including a
|
||||||
|
cross-claim or counterclaim in a lawsuit) alleging that the Work
|
||||||
|
or a Contribution incorporated within the Work constitutes direct
|
||||||
|
or contributory patent infringement, then any patent licenses
|
||||||
|
granted to You under this License for that Work shall terminate
|
||||||
|
as of the date such litigation is filed.
|
||||||
|
|
||||||
|
4. Redistribution. You may reproduce and distribute copies of the
|
||||||
|
Work or Derivative Works thereof in any medium, with or without
|
||||||
|
modifications, and in Source or Object form, provided that You
|
||||||
|
meet the following conditions:
|
||||||
|
|
||||||
|
(a) You must give any other recipients of the Work or
|
||||||
|
Derivative Works a copy of this License; and
|
||||||
|
|
||||||
|
(b) You must cause any modified files to carry prominent notices
|
||||||
|
stating that You changed the files; and
|
||||||
|
|
||||||
|
(c) You must retain, in the Source form of any Derivative Works
|
||||||
|
that You distribute, all copyright, patent, trademark, and
|
||||||
|
attribution notices from the Source form of the Work,
|
||||||
|
excluding those notices that do not pertain to any part of
|
||||||
|
the Derivative Works; and
|
||||||
|
|
||||||
|
(d) If the Work includes a "NOTICE" text file as part of its
|
||||||
|
distribution, then any Derivative Works that You distribute must
|
||||||
|
include a readable copy of the attribution notices contained
|
||||||
|
within such NOTICE file, excluding those notices that do not
|
||||||
|
pertain to any part of the Derivative Works, in at least one
|
||||||
|
of the following places: within a NOTICE text file distributed
|
||||||
|
as part of the Derivative Works; within the Source form or
|
||||||
|
documentation, if provided along with the Derivative Works; or,
|
||||||
|
within a display generated by the Derivative Works, if and
|
||||||
|
wherever such third-party notices normally appear. The contents
|
||||||
|
of the NOTICE file are for informational purposes only and
|
||||||
|
do not modify the License. You may add Your own attribution
|
||||||
|
notices within Derivative Works that You distribute, alongside
|
||||||
|
or as an addendum to the NOTICE text from the Work, provided
|
||||||
|
that such additional attribution notices cannot be construed
|
||||||
|
as modifying the License.
|
||||||
|
|
||||||
|
You may add Your own copyright statement to Your modifications and
|
||||||
|
may provide additional or different license terms and conditions
|
||||||
|
for use, reproduction, or distribution of Your modifications, or
|
||||||
|
for any such Derivative Works as a whole, provided Your use,
|
||||||
|
reproduction, and distribution of the Work otherwise complies with
|
||||||
|
the conditions stated in this License.
|
||||||
|
|
||||||
|
5. Submission of Contributions. Unless You explicitly state otherwise,
|
||||||
|
any Contribution intentionally submitted for inclusion in the Work
|
||||||
|
by You to the Licensor shall be under the terms and conditions of
|
||||||
|
this License, without any additional terms or conditions.
|
||||||
|
Notwithstanding the above, nothing herein shall supersede or modify
|
||||||
|
the terms of any separate license agreement you may have executed
|
||||||
|
with Licensor regarding such Contributions.
|
||||||
|
|
||||||
|
6. Trademarks. This License does not grant permission to use the trade
|
||||||
|
names, trademarks, service marks, or product names of the Licensor,
|
||||||
|
except as required for reasonable and customary use in describing the
|
||||||
|
origin of the Work and reproducing the content of the NOTICE file.
|
||||||
|
|
||||||
|
7. Disclaimer of Warranty. Unless required by applicable law or
|
||||||
|
agreed to in writing, Licensor provides the Work (and each
|
||||||
|
Contributor provides its Contributions) on an "AS IS" BASIS,
|
||||||
|
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
|
||||||
|
implied, including, without limitation, any warranties or conditions
|
||||||
|
of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
|
||||||
|
PARTICULAR PURPOSE. You are solely responsible for determining the
|
||||||
|
appropriateness of using or redistributing the Work and assume any
|
||||||
|
risks associated with Your exercise of permissions under this License.
|
||||||
|
|
||||||
|
8. Limitation of Liability. In no event and under no legal theory,
|
||||||
|
whether in tort (including negligence), contract, or otherwise,
|
||||||
|
unless required by applicable law (such as deliberate and grossly
|
||||||
|
negligent acts) or agreed to in writing, shall any Contributor be
|
||||||
|
liable to You for damages, including any direct, indirect, special,
|
||||||
|
incidental, or consequential damages of any character arising as a
|
||||||
|
result of this License or out of the use or inability to use the
|
||||||
|
Work (including but not limited to damages for loss of goodwill,
|
||||||
|
work stoppage, computer failure or malfunction, or any and all
|
||||||
|
other commercial damages or losses), even if such Contributor
|
||||||
|
has been advised of the possibility of such damages.
|
||||||
|
|
||||||
|
9. Accepting Warranty or Additional Liability. While redistributing
|
||||||
|
the Work or Derivative Works thereof, You may choose to offer,
|
||||||
|
and charge a fee for, acceptance of support, warranty, indemnity,
|
||||||
|
or other liability obligations and/or rights consistent with this
|
||||||
|
License. However, in accepting such obligations, You may act only
|
||||||
|
on Your own behalf and on Your sole responsibility, not on behalf
|
||||||
|
of any other Contributor, and only if You agree to indemnify,
|
||||||
|
defend, and hold each Contributor harmless for any liability
|
||||||
|
incurred by, or claims asserted against, such Contributor by reason
|
||||||
|
of your accepting any such warranty or additional liability.
|
||||||
|
|
||||||
|
END OF TERMS AND CONDITIONS
|
||||||
|
|
||||||
|
APPENDIX: How to apply the Apache License to your work.
|
||||||
|
|
||||||
|
To apply the Apache License to your work, attach the following
|
||||||
|
boilerplate notice, with the fields enclosed by brackets "[]"
|
||||||
|
replaced with your own identifying information. (Don't include
|
||||||
|
the brackets!) The text should be enclosed in the appropriate
|
||||||
|
comment syntax for the file format. We also recommend that a
|
||||||
|
file or class name and description of purpose be included on the
|
||||||
|
same "printed page" as the copyright notice for easier
|
||||||
|
identification within third-party archives.
|
||||||
|
|
||||||
|
Copyright [yyyy] [name of copyright owner]
|
||||||
|
|
||||||
|
Licensed under the Apache License, Version 2.0 (the "License");
|
||||||
|
you may not use this file except in compliance with the License.
|
||||||
|
You may obtain a copy of the License at
|
||||||
|
|
||||||
|
http://www.apache.org/licenses/LICENSE-2.0
|
||||||
|
|
||||||
|
Unless required by applicable law or agreed to in writing, software
|
||||||
|
distributed under the License is distributed on an "AS IS" BASIS,
|
||||||
|
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
|
||||||
|
See the License for the specific language governing permissions and
|
||||||
|
limitations under the License.
|
476
SPECS/slf4j.spec
Normal file
476
SPECS/slf4j.spec
Normal file
@ -0,0 +1,476 @@
|
|||||||
|
# Copyright (c) 2000-2009, JPackage Project
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use in source and binary forms, with or without
|
||||||
|
# modification, are permitted provided that the following conditions
|
||||||
|
# are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of source code must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
# 2. Redistributions in binary form must reproduce the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer in the
|
||||||
|
# documentation and/or other materials provided with the
|
||||||
|
# distribution.
|
||||||
|
# 3. Neither the name of the JPackage Project nor the names of its
|
||||||
|
# contributors may be used to endorse or promote products derived
|
||||||
|
# from this software without specific prior written permission.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||||
|
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||||
|
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||||
|
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||||
|
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||||
|
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||||
|
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||||
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
#
|
||||||
|
|
||||||
|
Name: slf4j
|
||||||
|
Version: 1.7.25
|
||||||
|
Release: 4%{?dist}
|
||||||
|
Epoch: 0
|
||||||
|
Summary: Simple Logging Facade for Java
|
||||||
|
# the log4j-over-slf4j and jcl-over-slf4j submodules are ASL 2.0, rest is MIT
|
||||||
|
License: MIT and ASL 2.0
|
||||||
|
URL: http://www.slf4j.org/
|
||||||
|
Source0: http://www.slf4j.org/dist/%{name}-%{version}.tar.gz
|
||||||
|
Source1: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||||
|
Patch0: 0001-Disallow-EventData-deserialization-by-default.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: maven-local
|
||||||
|
BuildRequires: mvn(ch.qos.cal10n:cal10n-api)
|
||||||
|
BuildRequires: mvn(commons-lang:commons-lang)
|
||||||
|
BuildRequires: mvn(commons-logging:commons-logging)
|
||||||
|
BuildRequires: mvn(javassist:javassist)
|
||||||
|
BuildRequires: mvn(log4j:log4j:1.2.17)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
|
||||||
|
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||||
|
|
||||||
|
%description
|
||||||
|
The Simple Logging Facade for Java or (SLF4J) is intended to serve
|
||||||
|
as a simple facade for various logging APIs allowing to the end-user
|
||||||
|
to plug in the desired implementation at deployment time. SLF4J also
|
||||||
|
allows for a gradual migration path away from
|
||||||
|
Jakarta Commons Logging (JCL).
|
||||||
|
|
||||||
|
Logging API implementations can either choose to implement the
|
||||||
|
SLF4J interfaces directly, e.g. NLOG4J or SimpleLogger. Alternatively,
|
||||||
|
it is possible (and rather easy) to write SLF4J adapters for the given
|
||||||
|
API implementation, e.g. Log4jLoggerAdapter or JDK14LoggerAdapter..
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: API documentation for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
This package provides %{summary}.
|
||||||
|
|
||||||
|
%package manual
|
||||||
|
Summary: Manual for %{name}
|
||||||
|
|
||||||
|
%description manual
|
||||||
|
This package provides documentation for %{name}.
|
||||||
|
|
||||||
|
%package jdk14
|
||||||
|
Summary: SLF4J JDK14 Binding
|
||||||
|
|
||||||
|
%description jdk14
|
||||||
|
SLF4J JDK14 Binding.
|
||||||
|
|
||||||
|
%package log4j12
|
||||||
|
Summary: SLF4J LOG4J-12 Binding
|
||||||
|
|
||||||
|
%description log4j12
|
||||||
|
SLF4J LOG4J-12 Binding.
|
||||||
|
|
||||||
|
%package jcl
|
||||||
|
Summary: SLF4J JCL Binding
|
||||||
|
|
||||||
|
%description jcl
|
||||||
|
SLF4J JCL Binding.
|
||||||
|
|
||||||
|
%package ext
|
||||||
|
Summary: SLF4J Extensions Module
|
||||||
|
|
||||||
|
%description ext
|
||||||
|
Extensions to the SLF4J API.
|
||||||
|
|
||||||
|
%package -n jcl-over-slf4j
|
||||||
|
Summary: JCL 1.1.1 implemented over SLF4J
|
||||||
|
|
||||||
|
%description -n jcl-over-slf4j
|
||||||
|
JCL 1.1.1 implemented over SLF4J.
|
||||||
|
|
||||||
|
%package -n log4j-over-slf4j
|
||||||
|
Summary: Log4j implemented over SLF4J
|
||||||
|
|
||||||
|
%description -n log4j-over-slf4j
|
||||||
|
Log4j implemented over SLF4J.
|
||||||
|
|
||||||
|
%package -n jul-to-slf4j
|
||||||
|
Summary: JUL to SLF4J bridge
|
||||||
|
|
||||||
|
%description -n jul-to-slf4j
|
||||||
|
JUL to SLF4J bridge.
|
||||||
|
|
||||||
|
%package sources
|
||||||
|
Summary: SLF4J Source JARs
|
||||||
|
|
||||||
|
%description sources
|
||||||
|
SLF4J Source JARs.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
find . -name "*.jar" | xargs rm
|
||||||
|
cp -p %{SOURCE1} APACHE-LICENSE
|
||||||
|
|
||||||
|
%pom_disable_module integration
|
||||||
|
%pom_disable_module osgi-over-slf4j
|
||||||
|
%pom_disable_module slf4j-android
|
||||||
|
%pom_disable_module slf4j-migrator
|
||||||
|
|
||||||
|
# Because of a non-ASCII comment in slf4j-api/src/main/java/org/slf4j/helpers/MessageFormatter.java
|
||||||
|
%pom_xpath_inject "pom:project/pom:properties" "
|
||||||
|
<project.build.sourceEncoding>ISO-8859-1</project.build.sourceEncoding>"
|
||||||
|
|
||||||
|
# Fix javadoc links
|
||||||
|
%pom_xpath_remove "pom:links"
|
||||||
|
%pom_xpath_inject "pom:plugin[pom:artifactId[text()='maven-javadoc-plugin']]/pom:configuration" "
|
||||||
|
<detectJavaApiLink>false</detectJavaApiLink>
|
||||||
|
<isOffline>false</isOffline>
|
||||||
|
<links><link>/usr/share/javadoc/java</link></links>"
|
||||||
|
|
||||||
|
# dos2unix
|
||||||
|
find -name "*.css" -o -name "*.js" -o -name "*.txt" | \
|
||||||
|
xargs -t sed -i 's/\r$//'
|
||||||
|
|
||||||
|
# Remove wagon-ssh build extension
|
||||||
|
%pom_xpath_remove pom:extensions
|
||||||
|
|
||||||
|
# Disable default-jar execution of maven-jar-plugin, which is causing
|
||||||
|
# problems with version 3.0.0 of the plugin.
|
||||||
|
%pom_xpath_inject "pom:plugin[pom:artifactId='maven-jar-plugin']/pom:executions" "
|
||||||
|
<execution>
|
||||||
|
<id>default-jar</id>
|
||||||
|
<phase>skip</phase>
|
||||||
|
</execution>" slf4j-api
|
||||||
|
|
||||||
|
# The general pattern is that the API package exports API classes and does
|
||||||
|
# not require impl classes. slf4j was breaking that causing "A cycle was
|
||||||
|
# detected when generating the classpath slf4j.api, slf4j.nop, slf4j.api."
|
||||||
|
# The API bundle requires impl package, so to avoid cyclic dependencies
|
||||||
|
# during build time, it is necessary to mark the imported package as an
|
||||||
|
# optional one.
|
||||||
|
# Reported upstream: http://bugzilla.slf4j.org/show_bug.cgi?id=283
|
||||||
|
sed -i "/Import-Package/s/.$/;resolution:=optional&/" slf4j-api/src/main/resources/META-INF/MANIFEST.MF
|
||||||
|
|
||||||
|
# Source JARs for are required by Maven 3.4.0
|
||||||
|
%mvn_package :::sources: sources
|
||||||
|
|
||||||
|
%mvn_package :%{name}-parent __noinstall
|
||||||
|
%mvn_package :%{name}-site __noinstall
|
||||||
|
%mvn_package :%{name}-api
|
||||||
|
%mvn_package :%{name}-simple
|
||||||
|
%mvn_package :%{name}-nop
|
||||||
|
|
||||||
|
%build
|
||||||
|
%mvn_build -f -s
|
||||||
|
|
||||||
|
%install
|
||||||
|
# Compat symlinks
|
||||||
|
%mvn_file ':%{name}-{*}' %{name}/%{name}-@1 %{name}/@1
|
||||||
|
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
# manual
|
||||||
|
install -d -m 0755 $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-manual
|
||||||
|
rm -rf target/site/{.htaccess,apidocs}
|
||||||
|
cp -pr target/site/* $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-manual
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%license LICENSE.txt APACHE-LICENSE
|
||||||
|
|
||||||
|
%files jdk14 -f .mfiles-%{name}-jdk14
|
||||||
|
%files log4j12 -f .mfiles-%{name}-log4j12
|
||||||
|
%files jcl -f .mfiles-%{name}-jcl
|
||||||
|
%files ext -f .mfiles-%{name}-ext
|
||||||
|
%files -n jcl-over-slf4j -f .mfiles-jcl-over-slf4j
|
||||||
|
%files -n log4j-over-slf4j -f .mfiles-log4j-over-slf4j
|
||||||
|
%files -n jul-to-slf4j -f .mfiles-jul-to-slf4j
|
||||||
|
|
||||||
|
%files sources -f .mfiles-sources
|
||||||
|
%license LICENSE.txt APACHE-LICENSE
|
||||||
|
|
||||||
|
%files javadoc -f .mfiles-javadoc
|
||||||
|
%license LICENSE.txt APACHE-LICENSE
|
||||||
|
|
||||||
|
%files manual
|
||||||
|
%license LICENSE.txt APACHE-LICENSE
|
||||||
|
%{_defaultdocdir}/%{name}-manual
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Mar 19 2018 Michael Simacek <msimacek@redhat.com> - 0:1.7.25-4
|
||||||
|
- Disallow EventData deserialization by default (CVE-2018-8088)
|
||||||
|
- Resolves rhbz#1549928
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.7.25-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.7.25-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 28 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.25-1
|
||||||
|
- Update to upstream version 1.7.25
|
||||||
|
|
||||||
|
* Wed Feb 22 2017 Michael Simacek <msimacek@redhat.com> - 0:1.7.22-4
|
||||||
|
- Avoid absolute paths
|
||||||
|
|
||||||
|
* Thu Feb 16 2017 Michael Simacek <msimacek@redhat.com> - 0:1.7.22-3
|
||||||
|
- Avoid literal carriage return
|
||||||
|
- Remove Group tag
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.7.22-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Dec 14 2016 Michael Simacek <msimacek@redhat.com> - 0:1.7.22-1
|
||||||
|
- Update to upstream version 1.7.22
|
||||||
|
|
||||||
|
* Fri Nov 18 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.21-4
|
||||||
|
- Install source JARs in separate package
|
||||||
|
|
||||||
|
* Mon Oct 3 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.21-3
|
||||||
|
- Remove build-requires on perl
|
||||||
|
|
||||||
|
* Tue May 31 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.21-2
|
||||||
|
- Fix build issue with maven-jar-plugin 3.0.0
|
||||||
|
|
||||||
|
* Wed Apr 6 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.21-1
|
||||||
|
- Update to upstream version 1.7.21
|
||||||
|
|
||||||
|
* Wed Mar 30 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.20-1
|
||||||
|
- Update to upstream version 1.7.20
|
||||||
|
|
||||||
|
* Thu Mar 24 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.19-1
|
||||||
|
- Update to upstream version 1.7.19
|
||||||
|
|
||||||
|
* Mon Feb 29 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.18-1
|
||||||
|
- Update to upstream version 1.7.18
|
||||||
|
|
||||||
|
* Mon Feb 22 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.17-1
|
||||||
|
- Update to upstream version 1.7.17
|
||||||
|
|
||||||
|
* Tue Feb 16 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.16-1
|
||||||
|
- Update to upstream version 1.7.16
|
||||||
|
|
||||||
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.7.14-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 25 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.14-1
|
||||||
|
- Update to upstream version 1.7.14
|
||||||
|
|
||||||
|
* Thu Nov 12 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.13-1
|
||||||
|
- Update to upstream version 1.7.13
|
||||||
|
|
||||||
|
* Mon Aug 03 2015 Michael Simacek <msimacek@redhat.com> - 0:1.7.12-3
|
||||||
|
- List manual files in %%files section
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7.12-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 14 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.12-1
|
||||||
|
- Update to upstream version 1.7.12
|
||||||
|
|
||||||
|
* Mon Jan 19 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.10-1
|
||||||
|
- Update to upstream version 1.7.10
|
||||||
|
|
||||||
|
* Fri Oct 24 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.7-3
|
||||||
|
- Remove workaround for MSHARED-325
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Apr 14 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.7-1
|
||||||
|
- Update to upstream version 1.7.7
|
||||||
|
|
||||||
|
* Thu Mar 20 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.6-5
|
||||||
|
- Disable filtering of bundled JavaScript binaries
|
||||||
|
- Resolves: rhbz#1078536
|
||||||
|
|
||||||
|
* Fri Mar 07 2014 Michael Simacek <msimacek@redhat.com> - 0:1.7.6-4
|
||||||
|
- Merge api, simple and nop back into main package
|
||||||
|
- Remove parent, migrator and site subpackages
|
||||||
|
|
||||||
|
* Fri Mar 07 2014 Michael Simacek <msimacek@redhat.com> - 0:1.7.6-3
|
||||||
|
- Split into subpackages
|
||||||
|
|
||||||
|
* Thu Mar 6 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.6-2
|
||||||
|
- Remove wagon-ssh build extension
|
||||||
|
- Disable slf4j-android module
|
||||||
|
|
||||||
|
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.7.6-2
|
||||||
|
- Use Requires: java-headless rebuild (#1067528)
|
||||||
|
|
||||||
|
* Thu Feb 6 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.6-1
|
||||||
|
- Update to upstream version 1.7.6
|
||||||
|
|
||||||
|
* Tue Aug 06 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.7.5-3
|
||||||
|
- Install manual to versionless docdir (#993551)
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Apr 5 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.5-1
|
||||||
|
- Update to upstream version 1.7.5
|
||||||
|
|
||||||
|
* Wed Mar 20 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.4-1
|
||||||
|
- Update to upstream version 1.7.4
|
||||||
|
|
||||||
|
* Fri Mar 15 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.3-1
|
||||||
|
- Update to upstream version 1.7.3
|
||||||
|
|
||||||
|
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7.2-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 0:1.7.2-8
|
||||||
|
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||||
|
- Replace maven BuildRequires with maven-local
|
||||||
|
|
||||||
|
* Wed Jan 9 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-7
|
||||||
|
- Fix install location of manual
|
||||||
|
|
||||||
|
* Tue Jan 8 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-6
|
||||||
|
- Rebuild to generate maven provides
|
||||||
|
|
||||||
|
* Fri Nov 30 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-5
|
||||||
|
- Build with xmvn
|
||||||
|
|
||||||
|
* Wed Nov 21 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-4
|
||||||
|
- Install Apache license file
|
||||||
|
- Resolves: rhbz#878996
|
||||||
|
|
||||||
|
* Thu Nov 15 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-3
|
||||||
|
- Avoid cyclic OSGi dependencies
|
||||||
|
|
||||||
|
* Thu Nov 08 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.7.2-2
|
||||||
|
- Fix license to ASL 2.0 and MIT
|
||||||
|
- Update to add_maven_depmap macro
|
||||||
|
- Use generated .mfiles list
|
||||||
|
- Small packaging cleanups
|
||||||
|
|
||||||
|
* Mon Oct 15 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.2-1
|
||||||
|
- Update to upstream version 1.7.2
|
||||||
|
|
||||||
|
* Mon Sep 17 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.1-1
|
||||||
|
- Update to upstream version 1.7.1
|
||||||
|
|
||||||
|
* Mon Sep 10 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.7.0-1
|
||||||
|
- Update to upstream version 1.7.0
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 11 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.6-1
|
||||||
|
- Update to upstream version 1.6.6
|
||||||
|
- Convert patches to POM macros
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Ville Skyttä <ville.skytta@iki.fi> - 0:1.6.1-5
|
||||||
|
- Crosslink with local JDK API docs.
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Ville Skyttä <ville.skytta@iki.fi> - 0:1.6.1-4
|
||||||
|
- Specify explicit source encoding to fix build with Java 1.7.
|
||||||
|
- Remove no longer needed javadoc dir upgrade hack.
|
||||||
|
|
||||||
|
* Wed Jun 8 2011 Alexander Kurtakov <akurtako@redhat.com> 0:1.6.1-3
|
||||||
|
- Build with maven 3.x.
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 25 2011 Alexander Kurtakov <akurtako@redhat.com> 0:1.6.1-1
|
||||||
|
- Update to new upstream version.
|
||||||
|
- Various guidelines fixes.
|
||||||
|
|
||||||
|
* Wed Sep 8 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.11-3
|
||||||
|
- Add maven-site-pugin BR.
|
||||||
|
- Use new package names.
|
||||||
|
|
||||||
|
* Wed Sep 8 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.11-2
|
||||||
|
- Skip installing tests jar that is no longer produced.
|
||||||
|
- Use javadoc aggregate.
|
||||||
|
- Use mavenpomdir macro.
|
||||||
|
|
||||||
|
* Thu Feb 25 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.11-1
|
||||||
|
- Update to 1.5.11.
|
||||||
|
- Drop depmap and component info files.
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 Mary Ellen Foster <mefoster at gmail.com> 0:1.5.10-5
|
||||||
|
- Require cal10n
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.10-4
|
||||||
|
- Fix javadoc files.
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.10-3
|
||||||
|
- BR maven-plugin-build-helper.
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.10-2
|
||||||
|
- BR cal10n.
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.10-1
|
||||||
|
- Update to upstream 1.5.10.
|
||||||
|
|
||||||
|
* Fri Sep 4 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.8-5
|
||||||
|
- Skip tests.
|
||||||
|
|
||||||
|
* Wed Sep 2 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.8-4
|
||||||
|
- Fix other line lenghts.
|
||||||
|
|
||||||
|
* Wed Sep 2 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.8-3
|
||||||
|
- Fix permissions.
|
||||||
|
- Fixed descriptions.
|
||||||
|
- Fix file lengths.
|
||||||
|
|
||||||
|
* Wed Sep 2 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.5.8-2
|
||||||
|
- Adapt for Fedora.
|
||||||
|
|
||||||
|
* Wed Jul 29 2009 Yong Yang <yyang@redhat.com> 0:1.5.8-1
|
||||||
|
- 1.5.8
|
||||||
|
- Replace slf4j-1.5.6-integration-tests-current-only.patch with
|
||||||
|
slf4j-1.5.8-skip-integration-tests.patch because of the failure of "testMatch"
|
||||||
|
|
||||||
|
* Fri Jun 12 2009 Ralph Apel <r.apel at r-apel.de> 0:1.5.6-2
|
||||||
|
- Add -ext jar, depmap and pom
|
||||||
|
- Save jcl104-over-slf4j as symlink
|
||||||
|
|
||||||
|
* Tue Feb 18 2009 David Walluck <dwalluck@redhat.com> 0:1.5.6-1
|
||||||
|
- 1.5.6
|
||||||
|
- add repolib
|
||||||
|
- fix file eol
|
||||||
|
- fix Release tag
|
||||||
|
|
||||||
|
* Fri Jul 18 2008 David Walluck <dwalluck@redhat.com> 0:1.5.2-2
|
||||||
|
- use excalibur for avalon
|
||||||
|
- remove javadoc scriptlets
|
||||||
|
- GCJ fixes
|
||||||
|
- fix maven directory ownership
|
||||||
|
- fix -bc --short-circuit by moving some of %%build to %%prep
|
||||||
|
|
||||||
|
* Sun Jul 06 2008 Ralph Apel <r.apel at r-apel.de> 0:1.5.2-1.jpp5
|
||||||
|
- 1.5.2
|
||||||
|
|
||||||
|
* Mon Feb 04 2008 Ralph Apel <r.apel at r-apel.de> 0:1.4.2-2jpp
|
||||||
|
- Fix macro misprint
|
||||||
|
- Add maven2-plugin BRs
|
||||||
|
|
||||||
|
* Wed Jul 18 2007 Ralph Apel <r.apel at r-apel.de> 0:1.4.2-1jpp
|
||||||
|
- Upgrade to 1.4.2
|
||||||
|
- Build with maven2
|
||||||
|
- Add poms and depmap frags
|
||||||
|
- Add gcj_support option
|
||||||
|
|
||||||
|
* Mon Jan 30 2006 Ralph Apel <r.apel at r-apel.de> 0:1.0-0.rc5.1jpp
|
||||||
|
- First JPackage release.
|
Loading…
Reference in New Issue
Block a user