diff --git a/.gitignore b/.gitignore
index 17e801f..9cc9853 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-SOURCES/slf4j-1.7.28.tar.gz
+SOURCES/v_1.7.36.tar.gz
diff --git a/.slf4j.metadata b/.slf4j.metadata
index c799724..9499230 100644
--- a/.slf4j.metadata
+++ b/.slf4j.metadata
@@ -1 +1 @@
-f57e8e97d434bdcd8ba87ab9933d8de64bafb071 SOURCES/slf4j-1.7.28.tar.gz
+573b4bc71ab5da60adfc095682a52aec34b5fbf4 SOURCES/v_1.7.36.tar.gz
diff --git a/SPECS/slf4j.spec b/SPECS/slf4j.spec
index c3c3e6c..abf9135 100644
--- a/SPECS/slf4j.spec
+++ b/SPECS/slf4j.spec
@@ -1,3 +1,5 @@
+%bcond_with bootstrap
+
# Copyright (c) 2000-2009, JPackage Project
# All rights reserved.
#
@@ -27,24 +29,28 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-
Name: slf4j
-Version: 1.7.28
-Release: 3%{?dist}
+Version: 1.7.36
+Release: 9%{?dist}
Summary: Simple Logging Facade for Java
# the log4j-over-slf4j and jcl-over-slf4j submodules are ASL 2.0, rest is MIT
-License: MIT and ASL 2.0
-URL: http://www.slf4j.org/
-Source0: http://www.slf4j.org/dist/%{name}-%{version}.tar.gz
-Source1: http://www.apache.org/licenses/LICENSE-2.0.txt
+License: MIT AND Apache-2.0
+URL: https://www.slf4j.org/
BuildArch: noarch
+ExclusiveArch: %{java_arches} noarch
-BuildRequires: maven-local-openjdk8
+Source0: https://github.com/qos-ch/slf4j/archive/v_%{version}.tar.gz
+Source1: https://www.apache.org/licenses/LICENSE-2.0.txt
+
+%if %{with bootstrap}
+BuildRequires: javapackages-bootstrap
+%else
+BuildRequires: maven-local
BuildRequires: mvn(commons-logging:commons-logging)
-BuildRequires: mvn(log4j:log4j:1.2.17)
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
+%endif
%description
The Simple Logging Facade for Java or (SLF4J) is intended to serve
@@ -58,8 +64,11 @@ SLF4J interfaces directly, e.g. NLOG4J or SimpleLogger. Alternatively,
it is possible (and rather easy) to write SLF4J adapters for the given
API implementation, e.g. Log4jLoggerAdapter or JDK14LoggerAdapter..
-%{?module_package}
-%{?javadoc_package}
+%package javadoc
+Summary: API documentation for %{name}
+
+%description javadoc
+API documentation for %{name}.
%package manual
Summary: Manual for %{name}
@@ -73,35 +82,35 @@ Summary: SLF4J JDK14 Binding
%description jdk14
SLF4J JDK14 Binding.
-%package log4j12
-Summary: SLF4J LOG4J-12 Binding
-
-%description log4j12
-SLF4J LOG4J-12 Binding.
-
%package jcl
Summary: SLF4J JCL Binding
%description jcl
SLF4J JCL Binding.
-%package -n %{?module_prefix}jcl-over-slf4j
+%package -n jcl-over-slf4j
Summary: JCL 1.1.1 implemented over SLF4J
-%description -n %{?module_prefix}jcl-over-slf4j
+%description -n jcl-over-slf4j
JCL 1.1.1 implemented over SLF4J.
+%package -n jul-to-slf4j
+Summary: JUL to SLF4J bridge
+
+%description -n jul-to-slf4j
+JUL to SLF4J bridge.
+
%package -n log4j-over-slf4j
Summary: Log4j implemented over SLF4J
%description -n log4j-over-slf4j
Log4j implemented over SLF4J.
-%package -n jul-to-slf4j
-Summary: JUL to SLF4J bridge
+%package migrator
+Summary: SLF4J Migrator
-%description -n jul-to-slf4j
-JUL to SLF4J bridge.
+%description migrator
+SLF4J Migrator.
%package sources
Summary: SLF4J Source JARs
@@ -110,15 +119,19 @@ Summary: SLF4J Source JARs
SLF4J Source JARs.
%prep
-%setup -q
-find . -name "*.jar" | xargs rm
-cp -p %{SOURCE1} APACHE-LICENSE
+%autosetup -p1 -n %{name}-v_%{version}
+find -name '*.jar' -delete
+install -p -m 0644 %{SOURCE1} LICENSE-2.0.txt
%pom_disable_module integration
%pom_disable_module osgi-over-slf4j
%pom_disable_module slf4j-android
%pom_disable_module slf4j-ext
-%pom_disable_module slf4j-migrator
+%pom_disable_module slf4j-log4j12
+%pom_disable_module slf4j-reload4j
+
+# Port to maven-antrun-plugin 3.0.0
+sed -i s/tasks/target/ slf4j-api/pom.xml
# Because of a non-ASCII comment in slf4j-api/src/main/java/org/slf4j/helpers/MessageFormatter.java
%pom_xpath_inject "pom:project/pom:properties" "
@@ -132,20 +145,11 @@ cp -p %{SOURCE1} APACHE-LICENSE
/usr/share/javadoc/java"
# dos2unix
-find -name "*.css" -o -name "*.js" -o -name "*.txt" | \
- xargs -t sed -i 's/\r$//'
+find -name '*.css' -o -name '*.js' -o -name '*.txt' -exec sed -i 's/\r//' {} +
# Remove wagon-ssh build extension
%pom_xpath_remove pom:extensions
-# Disable default-jar execution of maven-jar-plugin, which is causing
-# problems with version 3.0.0 of the plugin.
-%pom_xpath_inject "pom:plugin[pom:artifactId='maven-jar-plugin']/pom:executions" "
-
- default-jar
- skip
- " slf4j-api
-
# The general pattern is that the API package exports API classes and does
# not require impl classes. slf4j was breaking that causing "A cycle was
# detected when generating the classpath slf4j.api, slf4j.nop, slf4j.api."
@@ -153,7 +157,7 @@ find -name "*.css" -o -name "*.js" -o -name "*.txt" | \
# during build time, it is necessary to mark the imported package as an
# optional one.
# Reported upstream: http://bugzilla.slf4j.org/show_bug.cgi?id=283
-sed -i "/Import-Package/s/.$/;resolution:=optional&/" slf4j-api/src/main/resources/META-INF/MANIFEST.MF
+sed -i '/Import-Package/s/\}$/};resolution:=optional/' slf4j-api/src/main/resources/META-INF/MANIFEST.MF
# Source JARs for are required by Maven 3.4.0
%mvn_package :::sources: sources
@@ -165,7 +169,7 @@ sed -i "/Import-Package/s/.$/;resolution:=optional&/" slf4j-api/src/main/resourc
%mvn_package :%{name}-nop
%build
-%mvn_build -f -s -- -Drequired.jdk.version=1.6
+%mvn_build -f -s -- -Drequired.jdk.version=1.8
%install
# Compat symlinks
@@ -178,43 +182,152 @@ install -d -m 0755 $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-manual
rm -rf target/site/{.htaccess,apidocs}
cp -pr target/site/* $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-manual
-%files -n %{?module_prefix}%{name} -f .mfiles
-%license LICENSE.txt APACHE-LICENSE
+%files -f .mfiles
+%license LICENSE.txt LICENSE-2.0.txt
-%files jdk14 -f .mfiles-%{name}-jdk14
-%files log4j12 -f .mfiles-%{name}-log4j12
-%files jcl -f .mfiles-%{name}-jcl
-%files -n %{?module_prefix}jcl-over-slf4j -f .mfiles-jcl-over-slf4j
-%files -n log4j-over-slf4j -f .mfiles-log4j-over-slf4j
-%files -n jul-to-slf4j -f .mfiles-jul-to-slf4j
-
-%files sources -f .mfiles-sources
-%license LICENSE.txt APACHE-LICENSE
+%files javadoc -f .mfiles-javadoc
+%license LICENSE.txt LICENSE-2.0.txt
%files manual
-%license LICENSE.txt APACHE-LICENSE
+%license LICENSE.txt LICENSE-2.0.txt
%{_defaultdocdir}/%{name}-manual
+%files jdk14 -f .mfiles-%{name}-jdk14
+
+%files jcl -f .mfiles-%{name}-jcl
+
+%files -n jcl-over-slf4j -f .mfiles-jcl-over-slf4j
+
+%files -n jul-to-slf4j -f .mfiles-jul-to-slf4j
+
+%files -n log4j-over-slf4j -f .mfiles-log4j-over-slf4j
+
+%files migrator -f .mfiles-slf4j-migrator
+
+%files sources -f .mfiles-sources
+%license LICENSE.txt LICENSE-2.0.txt
+
%changelog
-* Sat Jan 25 2020 Mikolaj Izdebski - 1.7.28-3
+* Fri Nov 29 2024 Mikolaj Izdebski - 1.7.36-7
+- Update javapackages test plan to f42
+
+* Tue Sep 24 2024 Mikolaj Izdebski - 1.7.36-6
+- Rebuild to regenerate auto-requires
+
+* Sat Jul 20 2024 Fedora Release Engineering - 1.7.36-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
+
+* Mon Jul 15 2024 Marian Koncek - 1.7.36-1
+- Update to upstream version 1.7.36
+
+* Tue Feb 27 2024 Jiri Vanek - 1.7.32-12
+- Rebuilt for java-21-openjdk as system jdk
+
+* Fri Feb 23 2024 Jiri Vanek - 1.7.32-11
+- bump of release for for java-21-openjdk as system jdk
+
+* Sat Jan 27 2024 Fedora Release Engineering - 1.7.32-10
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
+
+* Wed Sep 20 2023 Mikolaj Izdebski - 1.7.32-9
+- Rebuild to regenerate auto-Requires on java
+
+* Fri Sep 01 2023 Mikolaj Izdebski - 1.7.32-8
+- Convert License tag to SPDX format
+
+* Tue Aug 15 2023 Mikolaj Izdebski - 1.7.32-7
+- Build with default JDK 17
+
+* Sat Jul 22 2023 Fedora Release Engineering - 1.7.32-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
+
+* Sat Jan 21 2023 Fedora Release Engineering - 1.7.32-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
+
+* Sat Jul 23 2022 Fedora Release Engineering - 1.7.32-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
+
+* Sat Feb 05 2022 Jiri Vanek - 1.7.32-3
+- Rebuilt for java-17-openjdk as system jdk
+
+* Sat Jan 22 2022 Fedora Release Engineering - 1.7.32-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
+
+* Mon Nov 22 2021 Simon Legner - 1.7.32-1
+- Update to upstream version 1.7.32
+
+* Tue Nov 16 2021 Didik Supriadi - 1.7.30-11
+- Enable slf4j-migrator and log4j-over-slf4j modules
+
+* Fri Jul 23 2021 Fedora Release Engineering - 1.7.30-10
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Mon May 17 2021 Mikolaj Izdebski - 1.7.30-9
+- Bootstrap build
+- Non-bootstrap build
+
+* Wed Jan 27 2021 Fedora Release Engineering - 0:1.7.30-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Wed Sep 09 2020 Fabio Valentini - 0:1.7.30-7
+- Disable unused log4j12 module.
+
+* Thu Jul 30 2020 Fabio Valentini - 0:1.7.30-6
+- Port to commons-lang3.
+
+* Wed Jul 29 2020 Fedora Release Engineering - 0:1.7.30-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Sat Jul 11 2020 Jiri Vanek - 0:1.7.30-4
+- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
+
+* Thu Jun 25 2020 Roland Grunberg - 0:1.7.30-3
+- Use source/target of 1.6 to build against Java 11.
+- Set javadoc plugin source value to 1.6.
+
+* Fri Mar 20 2020 Mat Booth - 0:1.7.30-2
+- Fix broken OSGi metadata
+
+* Wed Feb 05 2020 Dinesh Prasanth M K - 0:1.7.30-1
+- Update to upstream version 1.7.30
+
+* Thu Jan 30 2020 Fedora Release Engineering - 0:1.7.25-9
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Sat Jan 25 2020 Mikolaj Izdebski - 1.7.30-2
- Build with OpenJDK 8
+* Thu Jan 23 2020 Marian Koncek - 1.7.30-1
+- Update to upstream version 1.7.30
+
* Tue Nov 05 2019 Mikolaj Izdebski - 1.7.28-2
- Mass rebuild for javapackages-tools 201902
* Tue Aug 13 2019 Marian Koncek - 1.7.28-1
- Update to upstream version 1.7.28
+* Fri Jul 26 2019 Fedora Release Engineering - 0:1.7.25-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
* Fri May 24 2019 Mikolaj Izdebski - 1.7.26-3
- Mass rebuild for javapackages-tools 201901
* Fri May 24 2019 Mikolaj Izdebski - 1.7.26-2
- Disable slf4j-ext module
+* Thu May 09 2019 Dinesh Prasanth M K - 0:1.7.25-7
+- Rebuilt for Fedora 31
+
* Wed Feb 27 2019 Marian Koncek - 0:1.7.26-1
- Update to upstream version 1.7.26
- Fixes: RHBZ #1678877
+* Sat Feb 02 2019 Fedora Release Engineering - 0:1.7.25-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Sat Jul 14 2018 Fedora Release Engineering - 0:1.7.25-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
* Mon Mar 19 2018 Michael Simacek - 0:1.7.25-4
- Disallow EventData deserialization by default (CVE-2018-8088)
- Resolves rhbz#1549928