import slapi-nis-0.56.6-1.module+el8.4.0+9005+f55ff3e7

This commit is contained in:
CentOS Sources 2021-05-18 02:43:04 -04:00 committed by Andrew Lukoshko
parent 53b154d32a
commit 0b4f66317d
8 changed files with 24 additions and 184 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/slapi-nis-0.56.5.tar.gz
SOURCES/slapi-nis-0.56.6.tar.gz

View File

@ -1 +1 @@
3766addae0581012e6f2429270f093c3862db68c SOURCES/slapi-nis-0.56.5.tar.gz
c32d869856123cbecd7b3786bc2bd880d01c47ed SOURCES/slapi-nis-0.56.6.tar.gz

View File

@ -1,11 +0,0 @@
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEEb9A7wQ1zA7rMdssD2m7b4Oa3L0FAl6v1FsACgkQD2m7b4Oa
3L2MLwgAuQNbDTVFDLFBP2+tAXlPnvVL6q476BMffBDVA4U1L3F1OFABMmTRfOC8
WM8m90YjkOwUIC1wvwn+Mbw2Y0YWJY3AwR2xM/3KTxd2YVqIN68nPOax0BAYMJfS
drVV8asb8Cg4uQ+xUdcrGg0mpiYbC5slTX8p8zdAMylYgXxTKRBnqZItCkQ8zgtj
+euh8gof7ORMaRVNhHFH2UsMGAHQf9JfCnnKIPWOU2NO1bKS/v7P9I5vb3dOB4gF
/88GxWAMbME8/Y7syYQ314ROCqbQybBM0T7f6xixvHFF/tgI+V36wHN6XdpadbcU
6TrOLdyrQUbSXltmFbF6N0Od5/VAXw==
=rpl9
-----END PGP SIGNATURE-----

View File

@ -0,0 +1,16 @@
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEhAodHH8+xLL+UwQ1RxniuKu/YhoFAl/KPI0ACgkQRxniuKu/
Yhp7KA//aI0HHAGWn56NjsbLCdk98tpt3YekptGwKpaDiFan7An2JtnJe3CvC71q
pAWtj1VduHLx+cAxRaRPKSheMkqv9qKrIvhtDHKEgTs9zkxZ02AYa8Emof9x8v6h
KsnRYMpy5TmKlvT8urnNbrkQXcxGvfjkaBYdaLegT87tSuLsB5vmZpfDbcdMuZ6V
mfU7JOoKpq0aXg/cYfSc3Br8njZujQXjdUipwKQMBQivNdFzkUk/ly6v8eWXP0O5
TlD0Rg8QMcSVgqG8hcLVzka078AHzAlOK1B2hGRuFXfRrnd88mDxPps7UEbEfSy3
oULXpXdQGVet7kujo8JfUyS5D4yiJOS2q/KmES8IGpIUeiwrV+383/pU2UY+lCUU
Cjv62t4YAwsFOOo+2z0thmzvpEc6FtP9mMx88JRX01OkSCapThgPaGKMfr8wM5Ez
/3YK4RC14FybOF6jruoTkvlW0b4d6wsZwPHOKs+IeflO8UzncwfxY8L7GiSwTmC/
40QYCNrXmo79dyg9MGvXtBhUOnfZ41zSVdpzN3EZ5ulMZvdnsBeRK2ixImgQKLSf
80uZV0k/+koInWYnUQYMbTpKP1843KxZWnLmfd82w1ju5fAsSoDvu9MnomswiRhp
PzQdcWBSjcQxWjVxwN4RKXqcLCxm99xywTHYIP1xSCuN22KNOLk=
=EOmw
-----END PGP SIGNATURE-----

View File

@ -1,49 +0,0 @@
From e8c3ed416a442f5a431ca48f7ea384a6abc1fa53 Mon Sep 17 00:00:00 2001
From: Alexander Bokovoy <abokovoy@redhat.com>
Date: Wed, 6 May 2020 14:08:41 +0300
Subject: [PATCH] Initialize map lock in NIS plugin as well
Also if ignored_containers_sdn is NULL, we don't really need to check
whether a write could be ignored. It has to be processed, so bail out
early with FALSE.
Resolves: rhbz#1832331
Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
---
src/back-shr.c | 4 ++++
src/plug-nis.c | 3 +++
2 files changed, 7 insertions(+)
diff --git a/src/back-shr.c b/src/back-shr.c
index e2b5dd3..c6a181e 100644
--- a/src/back-shr.c
+++ b/src/back-shr.c
@@ -2960,6 +2960,10 @@ backend_shr_write_ignore(Slapi_PBlock *pb)
int i = 0;
PRBool ignore = PR_FALSE;
+ if (ignored_containers_sdn == NULL) {
+ return ignore;
+ }
+
/* Check if the target DN is a subordinates of
* on of the ignored containers
*/
diff --git a/src/plug-nis.c b/src/plug-nis.c
index ee90c37..0ce4ae6 100644
--- a/src/plug-nis.c
+++ b/src/plug-nis.c
@@ -540,6 +540,9 @@ nis_plugin_init(Slapi_PBlock *pb)
"error setting up plugin\n");
return -1;
}
+
+ init_map_lock();
+
/* Read global configuration. */
if ((slapi_pblock_get(pb, SLAPI_PLUGIN_CONFIG_ENTRY,
&plugin_entry) == 0) &&
--
2.25.4

View File

@ -1,61 +0,0 @@
From dbe1e300171e04cc328a4f31d0bffcac056e7cfa Mon Sep 17 00:00:00 2001
From: Alexander Bokovoy <abokovoy@redhat.com>
Date: Mon, 31 Aug 2020 16:53:47 +0300
Subject: [PATCH] idviews: clear intermediate target DN in all cases
When processing a search request, slapi-nis attempts to detect an ID
View lookup. A target DN is modified by extracting an ID view name. This
temporary string is freed in the successful case but left unotouched if
ID View wasn't requested. As a result, small leaks on each search
request accumulate and a memory can get lost.
Resolves: rhbz#1866113
Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
---
src/back-sch.c | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/src/back-sch.c b/src/back-sch.c
index 03abbeb..f8b04a3 100644
--- a/src/back-sch.c
+++ b/src/back-sch.c
@@ -1767,6 +1767,7 @@ backend_search_cb(Slapi_PBlock *pb)
/* Perform another check, now for rewritten DN */
cbdata.target_dn = slapi_sdn_new_dn_byval(target);
map_data_foreach_domain(cbdata.state, backend_search_find_set_dn_cb, &cbdata);
+
/* Rewritten DN might still be outside of our trees */
if (cbdata.answer == TRUE) {
slapi_log_error(SLAPI_LOG_PLUGIN, cbdata.state->plugin_desc->spd_id,
@@ -1774,19 +1775,21 @@ backend_search_cb(Slapi_PBlock *pb)
"for \"%s\" with scope %d%s. Filter may get overridden later.\n",
cbdata.idview, target, cbdata.strfilter, cbdata.scope,
backend_sch_scope_as_string(cbdata.scope));
- } else {
- slapi_sdn_free(&cbdata.target_dn);
- slapi_ch_free_string(&target);
- slapi_ch_free_string(&cbdata.idview);
+ }
+
+ slapi_sdn_free(&cbdata.target_dn);
+ slapi_ch_free_string(&cbdata.idview);
+
+ if (cbdata.answer == FALSE) {
slapi_log_error(SLAPI_LOG_PLUGIN,
cbdata.state->plugin_desc->spd_id,
"The search base didn't match any of the containers, "
"ignoring search\n");
+ slapi_ch_free_string(&target);
return 0;
}
- } else {
- slapi_ch_free_string(&target);
}
+ slapi_ch_free_string(&target);
}
cbdata.answer = FALSE;
#endif
--
2.26.2

View File

@ -1,53 +0,0 @@
From 61ea8f6a104da25329e301a8f56944f860de8177 Mon Sep 17 00:00:00 2001
From: Alexander Bokovoy <abokovoy@redhat.com>
Date: Sat, 12 Sep 2020 12:00:22 +0300
Subject: [PATCH] Ignore searches that do not match any of configured tree
Resolves: rhbz#1874015
Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
---
slapi-nis.spec | 5 ++++-
src/back-sch.c | 4 ++++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/slapi-nis.spec b/slapi-nis.spec
index 3eb3e37..8bde325 100644
--- a/slapi-nis.spec
+++ b/slapi-nis.spec
@@ -11,7 +11,7 @@
Name: slapi-nis
Version: 0.56.5
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: NIS Server and Schema Compatibility plugins for Directory Server
License: GPLv2
URL: http://pagure.io/slapi-nis/
@@ -81,6 +81,9 @@ make check
%{_sbindir}/nisserver-plugin-defs
%changelog
+* Sat Sep 12 2020 Alexander Bokovoy <abokovoy@redhat.com> - 0.56.5-3
+- Ignore searches which don't match any configured map
+
* Mon May 04 2020 Alexander Bokovoy <abokovoy@redhat.com> - 0.56.5-1
- New upstream release
- Resolves: rhbz#1751295: (2) When sync-repl is enabled, slapi-nis can deadlock during retrochanglog trimming
diff --git a/src/back-sch.c b/src/back-sch.c
index f8b04a3..a5e4c04 100644
--- a/src/back-sch.c
+++ b/src/back-sch.c
@@ -1790,6 +1790,10 @@ backend_search_cb(Slapi_PBlock *pb)
}
}
slapi_ch_free_string(&target);
+ if (cbdata.answer == FALSE) {
+ /* None of the configured trees in the sets matched the target at all, ignore search */
+ return 0;
+ }
}
cbdata.answer = FALSE;
#endif
--
2.26.2

View File

@ -10,17 +10,14 @@
%endif
Name: slapi-nis
Version: 0.56.5
Release: 4%{?dist}
Version: 0.56.6
Release: 1%{?dist}
Summary: NIS Server and Schema Compatibility plugins for Directory Server
Group: System Environment/Daemons
License: GPLv2
URL: http://pagure.io/slapi-nis/
Source0: https://releases.pagure.org/slapi-nis/slapi-nis-%{version}.tar.gz
Source1: https://releases.pagure.org/slapi-nis/slapi-nis-%{version}.tar.gz.asc
Patch1: slapi-nis-bz1832331.patch
Patch2: slapi-nis-fix-valgrind-issues.patch
Patch3: slapi-nis-ignore-unmatched-searches.patch
BuildRequires: autoconf
BuildRequires: automake
@ -59,9 +56,6 @@ for attributes from multiple entries in the tree.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build
autoconf --force
@ -90,6 +84,10 @@ make check
%{_sbindir}/nisserver-plugin-defs
%changelog
* Fri Dec 04 2020 Alexander Bokovoy <abokovoy@redhat.com> - 0.56.6-1
- Upstream release 0.56.6
- Resolves rhbz#1891741
* Mon Sep 14 2020 Alexander Bokovoy <abokovoy@redhat.com> - 0.56.5-4
- Ignore unmatched searches
- Resolves: rhbz#1874015