slang/slang-makefile.patch
Miroslav Lichvar da129e5a69 - don't build unpackaged stuff
- package just txt files from doc directory
2006-07-12 14:18:02 +00:00

21 lines
944 B
Diff

--- slang-2.0.6/src/Makefile.in.makefile 2006-02-05 21:47:31.000000000 +0100
+++ slang-2.0.6/src/Makefile.in 2006-05-24 09:39:24.000000000 +0200
@@ -166,14 +166,14 @@
$(MKINSDIR) $(DEST_INCDIR)
$(DEST_LIBDIR):
$(MKINSDIR) $(DEST_LIBDIR)
-install-elf: elf install
+install-elf: elf install_basic_lib
-$(RM) $(DEST_LIBDIR)/$(ELFLIB)
-$(RM) $(DEST_LIBDIR)/$(ELFLIB_MAJOR)
@echo installing $(ELFLIB_MAJOR_MINOR) in $(DEST_LIBDIR)
- $(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
+ $(INSTALL_DATA) -m 0755 $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
@echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
-cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB_MAJOR)
- -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB)
+ -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR) $(ELFLIB)
@echo ""
@echo $(ELFLIB_MAJOR_MINOR) created in $(DEST_LIBDIR).
@echo The links $(ELFLIB) and $(ELFLIB_MAJOR) to $(ELFLIB_MAJOR_MINOR) were also created.