- move .so.2 link to main package - don't package static library and utf8 link - remove requires for libtool and libtermcap - rearrange doc files (#191583)
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
--- slang-2.0.6/src/Makefile.in.makefile 2006-02-05 21:47:31.000000000 +0100
|
|
+++ slang-2.0.6/src/Makefile.in 2006-05-22 13:04:19.000000000 +0200
|
|
@@ -166,14 +166,16 @@
|
|
$(MKINSDIR) $(DEST_INCDIR)
|
|
$(DEST_LIBDIR):
|
|
$(MKINSDIR) $(DEST_LIBDIR)
|
|
-install-elf: elf install
|
|
+install-elf: elf $(DEST_LIBDIR) $(DEST_INCDIR)
|
|
+ $(INSTALL_DATA) $(SRCDIR)/slang.h $(DEST_INCDIR)
|
|
+ $(INSTALL_DATA) $(SRCDIR)/slcurses.h $(DEST_INCDIR)
|
|
-$(RM) $(DEST_LIBDIR)/$(ELFLIB)
|
|
-$(RM) $(DEST_LIBDIR)/$(ELFLIB_MAJOR)
|
|
@echo installing $(ELFLIB_MAJOR_MINOR) in $(DEST_LIBDIR)
|
|
- $(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
|
|
+ $(INSTALL_DATA) -m 0755 $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
|
|
@echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
|
|
-cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB_MAJOR)
|
|
- -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB)
|
|
+ -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR) $(ELFLIB)
|
|
@echo ""
|
|
@echo $(ELFLIB_MAJOR_MINOR) created in $(DEST_LIBDIR).
|
|
@echo The links $(ELFLIB) and $(ELFLIB_MAJOR) to $(ELFLIB_MAJOR_MINOR) were also created.
|