- update to 2.2.2
This commit is contained in:
parent
d39a8741de
commit
d6d9b63ed2
@ -1 +1 @@
|
||||
slang-2.2.1.tar.bz2
|
||||
slang-2.2.2.tar.bz2
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up slang-2.1.4/autoconf/Makefile.in.makefile slang-2.1.4/autoconf/Makefile.in
|
||||
--- slang-2.1.4/autoconf/Makefile.in.makefile 2008-09-06 06:29:27.000000000 +0200
|
||||
+++ slang-2.1.4/autoconf/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
@@ -32,8 +32,7 @@ help:
|
||||
diff -up slang-2.2.2/autoconf/Makefile.in.makefile slang-2.2.2/autoconf/Makefile.in
|
||||
--- slang-2.2.2/autoconf/Makefile.in.makefile 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ slang-2.2.2/autoconf/Makefile.in 2009-12-07 10:02:56.000000000 +0100
|
||||
@@ -47,8 +47,7 @@ help:
|
||||
@echo "make check : Build the library and run the regression tests"
|
||||
static: makefiles
|
||||
cd src; $(MAKE) static
|
||||
@ -11,10 +11,10 @@ diff -up slang-2.1.4/autoconf/Makefile.in.makefile slang-2.1.4/autoconf/Makefile
|
||||
cd src; $(MAKE) elf
|
||||
cd slsh; $(MAKE) all
|
||||
cd modules; $(MAKE) all
|
||||
diff -up slang-2.1.4/modules/Makefile.in.makefile slang-2.1.4/modules/Makefile.in
|
||||
--- slang-2.1.4/modules/Makefile.in.makefile 2008-08-25 01:57:48.000000000 +0200
|
||||
+++ slang-2.1.4/modules/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
@@ -53,7 +53,7 @@ SOCKET_LIBS = @X_EXTRA_LIBS@
|
||||
diff -up slang-2.2.2/modules/Makefile.in.makefile slang-2.2.2/modules/Makefile.in
|
||||
--- slang-2.2.2/modules/Makefile.in.makefile 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ slang-2.2.2/modules/Makefile.in 2009-12-07 10:02:56.000000000 +0100
|
||||
@@ -59,7 +59,7 @@ SOCKET_LIBS = @X_EXTRA_LIBS@
|
||||
MODULE_INSTALL_DIR = @libdir@/slang/v@slang_major_version@/modules
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
@ -23,7 +23,7 @@ diff -up slang-2.1.4/modules/Makefile.in.makefile slang-2.1.4/modules/Makefile.i
|
||||
MKINSDIR = ../autoconf/mkinsdir.sh
|
||||
SLSH_DIR = $(prefix)/share/slsh
|
||||
CMAPS_DIR = $(SLSH_DIR)/cmaps
|
||||
@@ -67,7 +67,7 @@ DEST_SLSH_DIR = $(DESTDIR)$(SLSH_DIR)
|
||||
@@ -73,7 +73,7 @@ DEST_SLSH_DIR = $(DESTDIR)$(SLSH_DIR)
|
||||
DEST_CMAPSDIR = $(DESTDIR)$(CMAPS_DIR)
|
||||
DEST_HELPDIR = $(DESTDIR)$(HELP_DIR)
|
||||
#---------------------------------------------------------------------------
|
||||
@ -32,9 +32,9 @@ diff -up slang-2.1.4/modules/Makefile.in.makefile slang-2.1.4/modules/Makefile.i
|
||||
|
||||
LIBS = $(LDFLAGS) $(RPATH) $(SLANG_LIB) $(DL_LIB) @M_LIB@
|
||||
#LIBS = $(RPATH) $(DL_LIB) @M_LIB@
|
||||
diff -up slang-2.1.4/slsh/Makefile.in.makefile slang-2.1.4/slsh/Makefile.in
|
||||
--- slang-2.1.4/slsh/Makefile.in.makefile 2008-08-25 01:57:48.000000000 +0200
|
||||
+++ slang-2.1.4/slsh/Makefile.in 2008-09-08 13:21:35.000000000 +0200
|
||||
diff -up slang-2.2.2/slsh/Makefile.in.makefile slang-2.2.2/slsh/Makefile.in
|
||||
--- slang-2.2.2/slsh/Makefile.in.makefile 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ slang-2.2.2/slsh/Makefile.in 2009-12-07 10:02:56.000000000 +0100
|
||||
@@ -15,7 +15,7 @@ SLANG_SRCINC = -I@SRCDIR@
|
||||
SLANG_SRCLIB = -L@ELFDIR@
|
||||
#---------------------------------------------------------------------------
|
||||
@ -44,18 +44,9 @@ diff -up slang-2.1.4/slsh/Makefile.in.makefile slang-2.1.4/slsh/Makefile.in
|
||||
#----------------------------------------------------------------------------
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
@@ -64,7 +64,7 @@ DEST_SLSH_DOC_DIR= $(DESTDIR)$(SLSH_DOC_
|
||||
#----------------------------------------------------------------------------
|
||||
@SET_MAKE@
|
||||
SHELL = /bin/sh
|
||||
-INST_LIBS = $(RPATH) $(SLANG_INST_LIB) $(DEST_LIB_DIR) -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
+INST_LIBS = $(RPATH) $(DEST_LIB_DIR) $(SLANG_INST_LIB) -lslang $(READLINE_LIB) $(OTHER_LIBS)
|
||||
DEFS = -DSLSH_CONF_DIR='"$(SLSH_CONF_DIR)"' -DSLSH_PATH='"$(SLSH_LIB_DIR)"' \
|
||||
-DSLSH_CONF_DIR_ENV='$(SLSH_CONF_DIR_ENV)' -DSLSH_LIB_DIR_ENV='$(SLSH_LIB_DIR_ENV)' \
|
||||
-DSLSH_PATH_ENV='$(SLSH_PATH_ENV)'
|
||||
diff -up slang-2.1.4/src/Makefile.in.makefile slang-2.1.4/src/Makefile.in
|
||||
--- slang-2.1.4/src/Makefile.in.makefile 2008-09-06 06:16:22.000000000 +0200
|
||||
+++ slang-2.1.4/src/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
diff -up slang-2.2.2/src/Makefile.in.makefile slang-2.2.2/src/Makefile.in
|
||||
--- slang-2.2.2/src/Makefile.in.makefile 2009-12-05 20:03:51.000000000 +0100
|
||||
+++ slang-2.2.2/src/Makefile.in 2009-12-07 10:02:56.000000000 +0100
|
||||
@@ -139,17 +139,21 @@ UPDATE_VERSION_SCRIPT = $(HOME)/bin/upda
|
||||
# Rules
|
||||
#---------------------------------------------------------------------------
|
@ -1,12 +1,12 @@
|
||||
Summary: The shared library for the S-Lang extension language
|
||||
Name: slang
|
||||
Version: 2.2.1
|
||||
Version: 2.2.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
Source: ftp://space.mit.edu/pub/davis/slang/v2.2/%{name}-%{version}.tar.bz2
|
||||
# fix file permissions, library symlink, parallel build, remove RPATH
|
||||
Patch1: slang-2.1.4-makefile.patch
|
||||
Patch1: slang-2.2.2-makefile.patch
|
||||
# don't use internal glibc symbol
|
||||
Patch2: slang-nointerlibc2.patch
|
||||
URL: http://www.jedsoft.org/slang/
|
||||
@ -114,6 +114,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libslang*.a
|
||||
|
||||
%changelog
|
||||
* Mon Dec 07 2009 Miroslav Lichvar <mlichvar@redhat.com> - 2.2.2-1
|
||||
- update to 2.2.2
|
||||
|
||||
* Mon Sep 07 2009 Miroslav Lichvar <mlichvar@redhat.com> - 2.2.1-1
|
||||
- update to 2.2.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user