- ignore background color of trailing spaces if terminal has bce (#217276)
- move static library to -static subpackage - spec cleanup Resolves: #217276
This commit is contained in:
parent
d5e60ff176
commit
a068015e62
14
slang-2.0.7-eol.patch
Normal file
14
slang-2.0.7-eol.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Index: slang/src/sldisply.c
|
||||||
|
===================================================================
|
||||||
|
--- slang/src/sldisply.c (revision 78)
|
||||||
|
+++ slang/src/sldisply.c (revision 79)
|
||||||
|
@@ -1808,7 +1808,8 @@
|
||||||
|
#endif
|
||||||
|
/* Find where the last non-blank character on old/new screen is */
|
||||||
|
|
||||||
|
- if (CHAR_EQS_SPACE(pmax-1))
|
||||||
|
+ /* if (CHAR_EQS_SPACE(pmax-1)) */
|
||||||
|
+ if (((pmax-1)->wchars[0]==' ') && ((pmax-1)->nchars==1))
|
||||||
|
{
|
||||||
|
/* If we get here, then we can erase to the end of the line to create
|
||||||
|
* the final space. However, this will only work _if_ erasing will
|
41
slang.spec
41
slang.spec
@ -1,13 +1,14 @@
|
|||||||
Summary: The shared library for the S-Lang extension language.
|
Summary: The shared library for the S-Lang extension language
|
||||||
Name: slang
|
Name: slang
|
||||||
Version: 2.0.7
|
Version: 2.0.7
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v2.0/slang-%{version}.tar.bz2
|
Source: ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v2.0/slang-%{version}.tar.bz2
|
||||||
Patch1: slang-makefile.patch
|
Patch1: slang-makefile.patch
|
||||||
Patch2: slang-nointerlibc2.patch
|
Patch2: slang-nointerlibc2.patch
|
||||||
Patch3: slang-LANG.patch
|
Patch3: slang-LANG.patch
|
||||||
|
Patch4: slang-2.0.7-eol.patch
|
||||||
Url: http://www.s-lang.org/
|
Url: http://www.s-lang.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -20,29 +21,37 @@ extension language. S-Lang's syntax resembles C, which makes it easy
|
|||||||
to recode S-Lang procedures in C if you need to.
|
to recode S-Lang procedures in C if you need to.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: The static library and header files for development using S-Lang.
|
Summary: Development files for the S-Lang extension language
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: slang = %{version}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains the S-Lang extension language static libraries
|
This package contains files which you'll need if you want to
|
||||||
and header files which you'll need if you want to develop S-Lang based
|
develop S-Lang based applications. Documentation which may help
|
||||||
applications. Documentation which may help you write S-Lang based
|
you write S-Lang based applications is also included.
|
||||||
applications is also included.
|
|
||||||
|
|
||||||
Install the slang-devel package if you want to develop applications
|
Install the slang-devel package if you want to develop applications
|
||||||
based on the S-Lang extension language.
|
based on the S-Lang extension language.
|
||||||
|
|
||||||
|
%package static
|
||||||
|
Summary: The static library for the S-Lang extension language
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
|
%description static
|
||||||
|
This package includes static library for the S-Lang extension
|
||||||
|
language.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -n slang-%{version} -q
|
%setup -q
|
||||||
%patch1 -p1 -b .makefile
|
%patch1 -p1 -b .makefile
|
||||||
%patch2 -p1 -b .nointerlibc2
|
%patch2 -p1 -b .nointerlibc2
|
||||||
%patch3 -p1 -b .LANG
|
%patch3 -p1 -b .LANG
|
||||||
|
%patch4 -p1 -b .eol
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --includedir=%{_includedir}/slang
|
%configure --includedir=%{_includedir}/slang
|
||||||
make -C src elf
|
make %{?_smp_mflags} -C src elf
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
@ -64,11 +73,19 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc doc/README doc/*/*.txt doc/*.txt
|
%doc doc/README doc/*/*.txt doc/*.txt
|
||||||
%{_libdir}/libslang*.a
|
|
||||||
%{_libdir}/libslang*.so
|
%{_libdir}/libslang*.so
|
||||||
%{_includedir}/slang
|
%{_includedir}/slang
|
||||||
|
|
||||||
|
%files static
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libslang*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 19 2007 Miroslav Lichvar <mlichvar@redhat.com> - 2.0.7-2
|
||||||
|
- ignore background color of trailing spaces if terminal has bce (#217276)
|
||||||
|
- move static library to -static subpackage
|
||||||
|
- spec cleanup
|
||||||
|
|
||||||
* Mon Nov 06 2006 Miroslav Lichvar <mlichvar@redhat.com> - 2.0.7-1
|
* Mon Nov 06 2006 Miroslav Lichvar <mlichvar@redhat.com> - 2.0.7-1
|
||||||
- update to 2.0.7
|
- update to 2.0.7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user