- update to slang-2.0.6
- move .so.2 link to main package - don't package static library and utf8 link - remove requires for libtool and libtermcap - rearrange doc files (#191583)
This commit is contained in:
parent
edd5da86b6
commit
907259176d
@ -1,44 +1,22 @@
|
|||||||
--- slang-2.0.5/autoconf/Makefile.in.orig 2005-10-17 08:00:18.000000000 +0200
|
--- slang-2.0.6/src/Makefile.in.makefile 2006-02-05 21:47:31.000000000 +0100
|
||||||
+++ slang-2.0.5/autoconf/Makefile.in 2005-11-21 14:16:51.000000000 +0100
|
+++ slang-2.0.6/src/Makefile.in 2006-05-22 13:04:19.000000000 +0200
|
||||||
@@ -8,12 +8,9 @@
|
@@ -166,14 +166,16 @@
|
||||||
|
$(MKINSDIR) $(DEST_INCDIR)
|
||||||
all:
|
$(DEST_LIBDIR):
|
||||||
cd src; $(MAKE) all
|
$(MKINSDIR) $(DEST_LIBDIR)
|
||||||
- cd slsh; $(MAKE) all
|
-install-elf: elf install
|
||||||
- cd modules; $(MAKE) all
|
+install-elf: elf $(DEST_LIBDIR) $(DEST_INCDIR)
|
||||||
+ cd src; $(MAKE) elf
|
+ $(INSTALL_DATA) $(SRCDIR)/slang.h $(DEST_INCDIR)
|
||||||
elf:
|
+ $(INSTALL_DATA) $(SRCDIR)/slcurses.h $(DEST_INCDIR)
|
||||||
cd src; $(MAKE) elf
|
-$(RM) $(DEST_LIBDIR)/$(ELFLIB)
|
||||||
- cd slsh; $(MAKE) all
|
-$(RM) $(DEST_LIBDIR)/$(ELFLIB_MAJOR)
|
||||||
- cd modules; $(MAKE) all
|
@echo installing $(ELFLIB_MAJOR_MINOR) in $(DEST_LIBDIR)
|
||||||
@echo Use make install-elf to install it.
|
- $(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
|
||||||
runtests:
|
+ $(INSTALL_DATA) -m 0755 $(ELFDIR_ELF_LIB) $(DEST_LIBDIR)
|
||||||
cd src; $(MAKE) all
|
@echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
|
||||||
@@ -23,17 +20,12 @@
|
-cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB_MAJOR)
|
||||||
clean:
|
- -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB)
|
||||||
/bin/rm -f *~
|
+ -cd $(DEST_LIBDIR); $(LN) $(ELFLIB_MAJOR) $(ELFLIB)
|
||||||
cd src; $(MAKE) clean
|
|
||||||
- cd modules; $(MAKE) clean
|
|
||||||
- cd slsh; $(MAKE) clean
|
|
||||||
cd demo; $(MAKE) clean
|
|
||||||
install:
|
|
||||||
cd src; $(MAKE) install
|
|
||||||
+ cd src; $(MAKE) install-elf
|
|
||||||
install-elf:
|
|
||||||
cd src; $(MAKE) install-elf
|
|
||||||
- @echo Now installing slsh
|
|
||||||
- cd slsh; $(MAKE) install
|
|
||||||
- @echo Now installing the modules
|
|
||||||
- cd modules; $(MAKE) install
|
|
||||||
@echo ""
|
@echo ""
|
||||||
@echo "On some systems, e.g., linux, you may also have to run ldconfig."
|
@echo $(ELFLIB_MAJOR_MINOR) created in $(DEST_LIBDIR).
|
||||||
@echo ""
|
@echo The links $(ELFLIB) and $(ELFLIB_MAJOR) to $(ELFLIB_MAJOR_MINOR) were also created.
|
||||||
@@ -44,8 +36,6 @@
|
|
||||||
/bin/rm -f *~ Makefile config.status config.log config.cache files.pck
|
|
||||||
cd src; $(MAKE) distclean
|
|
||||||
cd demo; $(MAKE) distclean
|
|
||||||
- cd modules; $(MAKE) distclean
|
|
||||||
- cd slsh; $(MAKE) distclean
|
|
||||||
#
|
|
||||||
configure: autoconf/aclocal.m4 autoconf/configure.ac
|
|
||||||
cd autoconf && autoconf && mv ./configure ..
|
|
||||||
|
@ -1,38 +1,11 @@
|
|||||||
--- slang-2.0.5/src/slcommon.c.nointerlibc 2005-10-17 08:00:18.000000000 +0200
|
--- slang-2.0.6/src/slcommon.c.nointerlibc 2006-02-05 21:47:31.000000000 +0100
|
||||||
+++ slang-2.0.5/src/slcommon.c 2005-11-21 14:26:28.000000000 +0100
|
+++ slang-2.0.6/src/slcommon.c 2006-05-22 13:20:01.000000000 +0200
|
||||||
@@ -191,19 +191,19 @@
|
@@ -191,7 +191,7 @@
|
||||||
return p;
|
return p;
|
||||||
}
|
}
|
||||||
|
|
||||||
-#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2)
|
-#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2)
|
||||||
-extern int __libc_enable_secure;
|
+#if 0 && !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2)
|
||||||
-# define HAVE___LIBC_ENABLE_SECURE 1
|
extern int __libc_enable_secure;
|
||||||
-#endif
|
# define HAVE___LIBC_ENABLE_SECURE 1
|
||||||
+/* #if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2) */
|
|
||||||
+/* extern int __libc_enable_secure; */
|
|
||||||
+/* # define HAVE___LIBC_ENABLE_SECURE 1 */
|
|
||||||
+/* #endif */
|
|
||||||
|
|
||||||
int _pSLsecure_issetugid (void)
|
|
||||||
{
|
|
||||||
#ifdef HAVE_ISSETUGID
|
|
||||||
return (1 == issetugid ());
|
|
||||||
#else
|
|
||||||
-# ifdef HAVE___LIBC_ENABLE_SECURE
|
|
||||||
- return __libc_enable_secure;
|
|
||||||
-# else
|
|
||||||
+/* # ifdef HAVE___LIBC_ENABLE_SECURE */
|
|
||||||
+/* return __libc_enable_secure; */
|
|
||||||
+/* # else */
|
|
||||||
# if defined(HAVE_GETUID) && defined(HAVE_GETEUID) && defined(HAVE_GETGID) && defined(HAVE_GETEUID)
|
|
||||||
static int enable_secure;
|
|
||||||
if (enable_secure == 0)
|
|
||||||
@@ -218,7 +218,7 @@
|
|
||||||
# else
|
|
||||||
return 0;
|
|
||||||
# endif
|
|
||||||
-# endif
|
|
||||||
+/* # endif */
|
|
||||||
#endif
|
#endif
|
||||||
}
|
|
||||||
|
|
||||||
|
38
slang.spec
38
slang.spec
@ -1,9 +1,7 @@
|
|||||||
%define _filter_GLIBC_PRIVATE 1
|
|
||||||
|
|
||||||
Summary: The shared library for the S-Lang extension language.
|
Summary: The shared library for the S-Lang extension language.
|
||||||
Name: slang
|
Name: slang
|
||||||
Version: 2.0.5
|
Version: 2.0.6
|
||||||
Release: 5.2.1
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v2.0/slang-%{version}.tar.bz2
|
Source: ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v2.0/slang-%{version}.tar.bz2
|
||||||
@ -12,8 +10,6 @@ Patch2: slang-nointerlibc2.patch
|
|||||||
Patch3: slang-LANG.patch
|
Patch3: slang-LANG.patch
|
||||||
Url: http://www.s-lang.org/
|
Url: http://www.s-lang.org/
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: libtool, libtermcap-devel
|
|
||||||
Requires: libtermcap
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
S-Lang is an interpreted language and a programming library. The
|
S-Lang is an interpreted language and a programming library. The
|
||||||
@ -27,7 +23,6 @@ to recode S-Lang procedures in C if you need to.
|
|||||||
Summary: The static library and header files for development using S-Lang.
|
Summary: The static library and header files for development using S-Lang.
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: slang = %{version}
|
Requires: slang = %{version}
|
||||||
Requires: libtermcap-devel
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains the S-Lang extension language static libraries
|
This package contains the S-Lang extension language static libraries
|
||||||
@ -46,25 +41,13 @@ based on the S-Lang extension language.
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
perl -p -i -e 's/(ELF_CFLAGS=\"[^\"]*)-O2([^\"]*\".*)/$1'"$RPM_OPT_FLAGS"' $2/gs' configure
|
|
||||||
%configure --includedir=%{_includedir}/slang
|
%configure --includedir=%{_includedir}/slang
|
||||||
make all
|
make -C src elf
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/slang
|
|
||||||
|
|
||||||
%makeinstall \
|
make -C src DESTDIR=${RPM_BUILD_ROOT} install-elf
|
||||||
install_lib_dir=${RPM_BUILD_ROOT}%{_libdir} \
|
|
||||||
install_include_dir=${RPM_BUILD_ROOT}%{_includedir}/slang install
|
|
||||||
chmod 0755 ${RPM_BUILD_ROOT}%{_libdir}/libslang*.so.*.*
|
|
||||||
ln -sf libslang.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libslang.so.2
|
|
||||||
ln -sf libslang.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libslang-utf8.so
|
|
||||||
ln -sf libslang.a ${RPM_BUILD_ROOT}%{_libdir}/libslang-utf8.a
|
|
||||||
|
|
||||||
|
|
||||||
# remove unpackaged files from the buildroot
|
|
||||||
rm -rf ${RPM_BUILD_ROOT}%{_prefix}/doc
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
@ -75,18 +58,23 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libslang.so.%{version}
|
%doc COPYING changes.txt
|
||||||
|
%{_libdir}/libslang*.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc doc README
|
%doc doc README
|
||||||
%{_libdir}/libslang*.a
|
|
||||||
%{_libdir}/libslang*.so
|
%{_libdir}/libslang*.so
|
||||||
%{_libdir}/libslang*.so.2
|
|
||||||
%{_datadir}/doc/slang/v2/*
|
|
||||||
%{_includedir}/slang
|
%{_includedir}/slang
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 22 2006 Miroslav Lichvar <mlichvar@redhat.com> - 2.0.6-1
|
||||||
|
- update to slang-2.0.6
|
||||||
|
- move .so.2 link to main package
|
||||||
|
- don't package static library and utf8 link
|
||||||
|
- remove requires for libtool and libtermcap
|
||||||
|
- rearrange doc files (#191583)
|
||||||
|
|
||||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.5-5.2.1
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.5-5.2.1
|
||||||
- bump again for double-long bug on ppc(64)
|
- bump again for double-long bug on ppc(64)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user