update to 2.3.3
This commit is contained in:
parent
9c0402fe52
commit
3b2de32999
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/slang-2.3.2.tar.bz2
|
/slang-2.3.3.tar.bz2
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
commit d338fd6e949ef62e7eac4eb5c024059e02158b06
|
|
||||||
Author: Miroslav Lichvar <mlichvar@redhat.com>
|
|
||||||
Date: Wed Jul 25 13:07:42 2018 +0200
|
|
||||||
|
|
||||||
Replaced memcpy in SLang_getkey
|
|
||||||
|
|
||||||
memcpy() is not defined for overlapping buffers, i.e. it may copy bytes
|
|
||||||
in any direction. As SLMEMMOVE is not defined in slang, replace the
|
|
||||||
SLMEMCPY call with a for loop.
|
|
||||||
|
|
||||||
diff --git a/src/slgetkey.c b/src/slgetkey.c
|
|
||||||
index 86e7946..d9bc678 100644
|
|
||||||
--- a/src/slgetkey.c
|
|
||||||
+++ b/src/slgetkey.c
|
|
||||||
@@ -40,13 +40,13 @@ unsigned int SLang_getkey (void)
|
|
||||||
|
|
||||||
if (SLang_Input_Buffer_Len)
|
|
||||||
{
|
|
||||||
- unsigned int imax;
|
|
||||||
+ unsigned int i, imax;
|
|
||||||
ch = (unsigned int) *SLang_Input_Buffer;
|
|
||||||
SLang_Input_Buffer_Len--;
|
|
||||||
imax = SLang_Input_Buffer_Len;
|
|
||||||
|
|
||||||
- SLMEMCPY ((char *) SLang_Input_Buffer,
|
|
||||||
- (char *) (SLang_Input_Buffer + 1), imax);
|
|
||||||
+ for (i = 0; i < imax; i++)
|
|
||||||
+ SLang_Input_Buffer[i] = SLang_Input_Buffer[i + 1];
|
|
||||||
}
|
|
||||||
else if (SLANG_GETKEY_ERROR == (ch = _pSLsys_getkey ())) return ch;
|
|
||||||
|
|
11
slang.spec
11
slang.spec
@ -6,13 +6,11 @@
|
|||||||
|
|
||||||
Summary: Shared library for the S-Lang extension language
|
Summary: Shared library for the S-Lang extension language
|
||||||
Name: slang
|
Name: slang
|
||||||
Version: 2.3.2
|
Version: 2.3.3
|
||||||
Release: 12%{?dist}
|
Release: 12%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://www.jedsoft.org/slang/
|
URL: https://www.jedsoft.org/slang/
|
||||||
Source: https://www.jedsoft.org/releases/%{name}/%{name}-%{version}.tar.bz2
|
Source: https://www.jedsoft.org/releases/%{name}/%{name}-%{version}.tar.bz2
|
||||||
# don't use memcpy() on overlapping buffers
|
|
||||||
Patch1: slang-getkey-memmove.patch
|
|
||||||
# disable test that fails with SIGHUP ignored (e.g. in koji)
|
# disable test that fails with SIGHUP ignored (e.g. in koji)
|
||||||
Patch2: slang-sighuptest.patch
|
Patch2: slang-sighuptest.patch
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -55,15 +53,8 @@ based on the S-Lang extension language.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .getkey-memmove
|
|
||||||
%patch2 -p1 -b .sighuptest
|
%patch2 -p1 -b .sighuptest
|
||||||
|
|
||||||
# fix permissions of installed modules
|
|
||||||
sed -i '/^INSTALL_MODULE=/s/_DATA//' configure
|
|
||||||
|
|
||||||
# disable test failing on 32-bit archs
|
|
||||||
sed -i '/TEST_SCRIPTS_SLC = /s/array //' src/test/Makefile
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--with-{pcre,png,z}lib=%{_libdir} \
|
--with-{pcre,png,z}lib=%{_libdir} \
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (slang-2.3.2.tar.bz2) = 35cdfe8af66dac62ee89cca60fa87ddbd02cae63b30d5c0e3786e77b1893c45697ace4ac7e82d9832b8a9ac342560bc35997674846c5022341481013e76f74b5
|
SHA512 (slang-2.3.3.tar.bz2) = f882f09e3fcd53427de0f233c9fc3ab15497f2323007be9a084696c8cf810ffe2726cd003149e757df26198b390b9f8c1ff411dc6473513457bd0f94722f8490
|
||||||
|
Loading…
Reference in New Issue
Block a user