- update to 2.1.4
This commit is contained in:
parent
6e7b735ec6
commit
2bc609fc1c
@ -1 +1 @@
|
||||
slang-2.1.3.tar.bz2
|
||||
slang-2.1.4.tar.bz2
|
||||
|
@ -1,6 +1,19 @@
|
||||
diff -up slang-2.1.3/modules/Makefile.in.makefile slang-2.1.3/modules/Makefile.in
|
||||
--- slang-2.1.3/modules/Makefile.in.makefile 2007-09-08 04:47:29.000000000 +0200
|
||||
+++ slang-2.1.3/modules/Makefile.in 2007-11-05 16:12:25.000000000 +0100
|
||||
diff -up slang-2.1.4/autoconf/Makefile.in.makefile slang-2.1.4/autoconf/Makefile.in
|
||||
--- slang-2.1.4/autoconf/Makefile.in.makefile 2008-09-06 06:29:27.000000000 +0200
|
||||
+++ slang-2.1.4/autoconf/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
@@ -32,8 +32,7 @@ help:
|
||||
@echo "make check : Build the library and run the regression tests"
|
||||
static: makefiles
|
||||
cd src; $(MAKE) static
|
||||
- cd slsh; $(MAKE) all
|
||||
-elf: makefiles
|
||||
+elf: makefiles static
|
||||
cd src; $(MAKE) elf
|
||||
cd slsh; $(MAKE) all
|
||||
cd modules; $(MAKE) all
|
||||
diff -up slang-2.1.4/modules/Makefile.in.makefile slang-2.1.4/modules/Makefile.in
|
||||
--- slang-2.1.4/modules/Makefile.in.makefile 2008-08-25 01:57:48.000000000 +0200
|
||||
+++ slang-2.1.4/modules/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
@@ -53,7 +53,7 @@ SOCKET_LIBS = @X_EXTRA_LIBS@
|
||||
MODULE_INSTALL_DIR = @libdir@/slang/v@slang_major_version@/modules
|
||||
INSTALL = @INSTALL@
|
||||
@ -17,15 +30,15 @@ diff -up slang-2.1.3/modules/Makefile.in.makefile slang-2.1.3/modules/Makefile.i
|
||||
-RPATH = @RPATH@
|
||||
+RPATH =
|
||||
|
||||
LIBS = $(LDFLAGS) $(RPATH) $(SLANG_LIB) $(DL_LIB) -lm
|
||||
#LIBS = $(RPATH) $(DL_LIB) -lm
|
||||
diff -up slang-2.1.3/slsh/Makefile.in.makefile slang-2.1.3/slsh/Makefile.in
|
||||
--- slang-2.1.3/slsh/Makefile.in.makefile 2007-09-09 03:39:18.000000000 +0200
|
||||
+++ slang-2.1.3/slsh/Makefile.in 2007-11-05 16:12:25.000000000 +0100
|
||||
LIBS = $(LDFLAGS) $(RPATH) $(SLANG_LIB) $(DL_LIB) @M_LIB@
|
||||
#LIBS = $(RPATH) $(DL_LIB) @M_LIB@
|
||||
diff -up slang-2.1.4/slsh/Makefile.in.makefile slang-2.1.4/slsh/Makefile.in
|
||||
--- slang-2.1.4/slsh/Makefile.in.makefile 2008-08-25 01:57:48.000000000 +0200
|
||||
+++ slang-2.1.4/slsh/Makefile.in 2008-09-08 13:21:35.000000000 +0200
|
||||
@@ -15,7 +15,7 @@ SLANG_SRCINC = -I@SRCDIR@
|
||||
SLANG_SRCLIB = -L@ELFDIR@
|
||||
#---------------------------------------------------------------------------
|
||||
OTHER_LIBS = @TERMCAP@ @DYNAMIC_LINK_LIB@ @LIBS@ -lm
|
||||
OTHER_LIBS = @TERMCAP@ @DYNAMIC_LINK_LIB@ @LIBS@ @M_LIB@
|
||||
-RPATH = @RPATH@
|
||||
+RPATH =
|
||||
#----------------------------------------------------------------------------
|
||||
@ -40,10 +53,10 @@ diff -up slang-2.1.3/slsh/Makefile.in.makefile slang-2.1.3/slsh/Makefile.in
|
||||
DEFS = -DSLSH_CONF_DIR='"$(SLSH_CONF_DIR)"' -DSLSH_PATH='"$(SLSH_LIB_DIR)"' \
|
||||
-DSLSH_CONF_DIR_ENV='$(SLSH_CONF_DIR_ENV)' -DSLSH_LIB_DIR_ENV='$(SLSH_LIB_DIR_ENV)' \
|
||||
-DSLSH_PATH_ENV='$(SLSH_PATH_ENV)'
|
||||
diff -up slang-2.1.3/src/Makefile.in.makefile slang-2.1.3/src/Makefile.in
|
||||
--- slang-2.1.3/src/Makefile.in.makefile 2007-09-08 04:47:29.000000000 +0200
|
||||
+++ slang-2.1.3/src/Makefile.in 2007-11-05 16:12:25.000000000 +0100
|
||||
@@ -137,17 +137,21 @@ UPDATE_VERSION_SCRIPT = $(HOME)/bin/upda
|
||||
diff -up slang-2.1.4/src/Makefile.in.makefile slang-2.1.4/src/Makefile.in
|
||||
--- slang-2.1.4/src/Makefile.in.makefile 2008-09-06 06:16:22.000000000 +0200
|
||||
+++ slang-2.1.4/src/Makefile.in 2008-09-08 13:18:42.000000000 +0200
|
||||
@@ -139,17 +139,21 @@ UPDATE_VERSION_SCRIPT = $(HOME)/bin/upda
|
||||
# Rules
|
||||
#---------------------------------------------------------------------------
|
||||
all: static elf
|
||||
@ -69,7 +82,7 @@ diff -up slang-2.1.3/src/Makefile.in.makefile slang-2.1.3/src/Makefile.in
|
||||
-$(RM) $(ELFDIR_ELF_LIB)
|
||||
cd $(ELFDIR); $(ELF_LINK_CMD) -o $(ELFLIB_BUILD_NAME) $(OFILES) $(LDFLAGS) $(ELF_DEP_LIBS)
|
||||
if [ $(ELFLIB_MAJOR) != $(ELFLIB_BUILD_NAME) ]; then \
|
||||
@@ -158,10 +162,12 @@ $(ELFDIR_ELF_LIB): $(ELFDIR) $(CONFIG_H)
|
||||
@@ -160,10 +164,12 @@ $(ELFDIR_ELF_LIB): $(ELFDIR) $(CONFIG_H)
|
||||
@echo $(ELFLIB_BUILD_NAME) created in $(ELFDIR).
|
||||
@echo The link $(ELFLIB) to $(ELFLIB_BUILD_NAME) was also created.
|
||||
@echo ""
|
||||
@ -84,7 +97,7 @@ diff -up slang-2.1.3/src/Makefile.in.makefile slang-2.1.3/src/Makefile.in
|
||||
$(CONFIG_H) : sysconf.h
|
||||
-$(CP) sysconf.h $(CONFIG_H)
|
||||
|
||||
@@ -192,9 +198,9 @@ install-elf-and-links:
|
||||
@@ -194,9 +200,9 @@ install-elf-and-links:
|
||||
-$(RM) $(DEST_LIBDIR)/$(ELFLIB)
|
||||
-$(RM) $(DEST_LIBDIR)/$(ELFLIB_MAJOR)
|
||||
@echo installing $(ELFLIB_BUILD_NAME) in $(DEST_LIBDIR)
|
||||
@ -96,16 +109,3 @@ diff -up slang-2.1.3/src/Makefile.in.makefile slang-2.1.3/src/Makefile.in
|
||||
@echo ""
|
||||
@echo $(ELFLIB_BUILD_NAME) created in $(DEST_LIBDIR).
|
||||
@echo The links $(ELFLIB) and $(ELFLIB_MAJOR) to $(ELFLIB_BUILD_NAME) were also created.
|
||||
diff -up slang-2.1.3/autoconf/Makefile.in.makefile slang-2.1.3/autoconf/Makefile.in
|
||||
--- slang-2.1.3/autoconf/Makefile.in.makefile 2007-09-11 04:57:09.000000000 +0200
|
||||
+++ slang-2.1.3/autoconf/Makefile.in 2007-11-05 16:29:44.000000000 +0100
|
||||
@@ -28,8 +28,7 @@ help:
|
||||
@echo "make check : Build the library and run the regression tests"
|
||||
static: makefiles
|
||||
cd src; $(MAKE) static
|
||||
- cd slsh; $(MAKE) all
|
||||
-elf: makefiles
|
||||
+elf: makefiles static
|
||||
cd src; $(MAKE) elf
|
||||
cd slsh; $(MAKE) all
|
||||
cd modules; $(MAKE) all
|
18
slang.spec
18
slang.spec
@ -1,11 +1,11 @@
|
||||
Summary: The shared library for the S-Lang extension language
|
||||
Name: slang
|
||||
Version: 2.1.3
|
||||
Release: 3%{?dist}
|
||||
Version: 2.1.4
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
|
||||
Patch1: slang-2.1.3-makefile.patch
|
||||
Patch1: slang-2.1.4-makefile.patch
|
||||
Patch2: slang-nointerlibc2.patch
|
||||
URL: http://www.jedsoft.org/slang/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -60,7 +60,12 @@ language.
|
||||
%patch2 -p1 -b .nointerlibc2
|
||||
|
||||
%build
|
||||
%configure --includedir=%{_includedir}/slang
|
||||
%configure \
|
||||
--includedir=%{_includedir}/slang \
|
||||
--with-{pcre,onig,png}lib=%{_libdir} \
|
||||
--with-{pcre,onig,png}inc=%{_includedir} \
|
||||
;
|
||||
|
||||
make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
|
||||
|
||||
%install
|
||||
@ -78,7 +83,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
|
||||
%doc COPYING NEWS doc/README changes.txt doc/*/slang*.txt doc/*.txt
|
||||
%{_libdir}/libslang*.so.*
|
||||
|
||||
%files slsh
|
||||
@ -101,6 +106,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libslang*.a
|
||||
|
||||
%changelog
|
||||
* Mon Sep 08 2008 Miroslav Lichvar <mlichvar@redhat.com> - 2.1.4-1
|
||||
- update to 2.1.4
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.3-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user