Support for OCI V1.0 Images
Update to image-spec v1.0.0 and revendor Fixes for authentication
This commit is contained in:
parent
4a700a5c49
commit
d0cb1ff87f
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/skopeo-0b73154.tar.gz
|
||||
/skopeo-d5e34c1.tar.gz
|
||||
/skopeo-5d24b67.tar.gz
|
||||
/skopeo-1bbd87f.tar.gz
|
||||
|
39
ostree.patch
39
ostree.patch
@ -1,39 +0,0 @@
|
||||
diff --git a/vendor/github.com/ostreedev/ostree-go/pkg/otbuiltin/commit.go b/vendor/github.com/ostreedev/ostree-go/pkg/otbuiltin/commit.go
|
||||
index 7842cf9..9550f80 100644
|
||||
--- a/vendor/github.com/ostreedev/ostree-go/pkg/otbuiltin/commit.go
|
||||
+++ b/vendor/github.com/ostreedev/ostree-go/pkg/otbuiltin/commit.go
|
||||
@@ -222,7 +222,7 @@ func (repo *Repo) Commit(commitPath, branch string, opts commitOptions) (string,
|
||||
filter_data.skip_list = (*C.GHashTable)(skipList.Ptr())
|
||||
C._set_owner_uid((C.guint32)(options.OwnerUID))
|
||||
C._set_owner_gid((C.guint32)(options.OwnerGID))
|
||||
- modifier = C._ostree_repo_commit_modifier_new_wrapper(flags, &filter_data, nil)
|
||||
+ modifier = C._ostree_repo_commit_modifier_new_wrapper(flags, C.gpointer(&filter_data), nil)
|
||||
}
|
||||
|
||||
if strings.Compare(options.Parent, "") != 0 {
|
||||
@@ -245,7 +245,7 @@ func (repo *Repo) Commit(commitPath, branch string, opts commitOptions) (string,
|
||||
if len(commitPath) == 0 && (len(options.Tree) == 0 || len(options.Tree[0]) == 0) {
|
||||
currentDir := (*C.char)(C.g_get_current_dir())
|
||||
objectToCommit = glib.ToGFile(unsafe.Pointer(C.g_file_new_for_path(currentDir)))
|
||||
- C.g_free(currentDir)
|
||||
+ C.g_free(C.gpointer(currentDir))
|
||||
|
||||
if !glib.GoBool(glib.GBoolean(C.ostree_repo_write_directory_to_mtree(repo.native(), (*C.GFile)(objectToCommit.Ptr()), mtree, modifier, cancellable, &cerr))) {
|
||||
goto out
|
||||
@@ -469,14 +469,14 @@ func handleStatOverrideLine(line string, table *glib.GHashTable) error {
|
||||
}
|
||||
|
||||
modeAdd = (C.guint)(C.g_ascii_strtod((*C.gchar)(C.CString(line)), nil))
|
||||
- C.g_hash_table_insert((*C.GHashTable)(table.Ptr()), C.g_strdup((*C.gchar)(C.CString(line[space+1:]))), C._guint_to_pointer(modeAdd))
|
||||
+ C.g_hash_table_insert((*C.GHashTable)(table.Ptr()), C.gpointer(C.g_strdup((*C.gchar)(C.CString(line[space+1:])))), C._guint_to_pointer(modeAdd))
|
||||
|
||||
return nil
|
||||
}
|
||||
|
||||
// Handle an individual line from a Skiplist file
|
||||
func handleSkipListline(line string, table *glib.GHashTable) error {
|
||||
- C.g_hash_table_add((*C.GHashTable)(table.Ptr()), C.g_strdup((*C.gchar)(C.CString(line))))
|
||||
+ C.g_hash_table_add((*C.GHashTable)(table.Ptr()), C.gpointer( C.g_strdup((*C.gchar)(C.CString(line)))))
|
||||
|
||||
return nil
|
||||
}
|
11
skopeo.spec
11
skopeo.spec
@ -25,7 +25,7 @@
|
||||
# https://github.com/projectatomic/skopeo
|
||||
%global provider_prefix %{provider}.%{provider_tld}/%{project}/%{repo}
|
||||
%global import_path %{provider_prefix}
|
||||
%global commit 5d24b67f5eeeca348966adb412d8119837faa1c2
|
||||
%global commit 1bbd87f4356fed4f21b860b18c50dbe72027b1a0
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
|
||||
# e.g. el6 has ppc64 arch without gcc-go, so EA tag is required
|
||||
@ -36,8 +36,8 @@ Name: skopeo
|
||||
%if 0%{?centos}
|
||||
Epoch: 1
|
||||
%endif # centos
|
||||
Version: 0.1.22
|
||||
Release: 2.git%{shortcommit}%{?dist}
|
||||
Version: 0.1.23
|
||||
Release: 1.git%{shortcommit}%{?dist}
|
||||
Summary: Inspect Docker images and repositories on registries
|
||||
License: ASL 2.0
|
||||
URL: https://%{provider_prefix}
|
||||
@ -288,6 +288,11 @@ export GOPATH=%{buildroot}/%{gopath}:$(pwd)/vendor:%{gopath}
|
||||
%{_datadir}/bash-completion/completions/%{name}
|
||||
|
||||
%changelog
|
||||
* Fri Jul 21 2017 dwalsh <dwalsh@redhat.com> - 0.1.23-1.dev.git1bbd87
|
||||
- Support for OCI V1.0 Images
|
||||
- Update to image-spec v1.0.0 and revendor
|
||||
- Fixes for authentication
|
||||
|
||||
* Sat Jul 01 2017 Lokesh Mandvekar <lsm5@fedoraproject.org> - 0.1.22-2.dev.git5d24b67
|
||||
- Epoch: 1 for CentOS as CentOS Extras' build already has epoch set to 1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (skopeo-5d24b67.tar.gz) = cb3905dfde258ab07e28b39818dcb52277938a9fcfb8da2b9977fa854ae4dd78dd05aff150ff55e02d5cc0025017dddfabb48d6625a8fbbf1c2681b5019cef9e
|
||||
SHA512 (skopeo-1bbd87f.tar.gz) = 46b53a488c34432e4a15827b6193c70c76a505a24e133ca378d0f77bc7612cdce25969efba42e0e9e7fdad170a05774209a303dcaa8cd6a08ba544f07daf6211
|
||||
|
Loading…
Reference in New Issue
Block a user