Update to 2.1.1
- Update patch - Disable guice-eclipse for now
This commit is contained in:
parent
5119d34a78
commit
d172bc0dcb
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/sonatype-sisu-sisu-1.4.2-0-gae9a407.tar.gz
|
||||
/sisu-1.4.3.2.tar.gz
|
||||
/sisu-2.1.1.tar.bz2
|
||||
|
@ -1,75 +0,0 @@
|
||||
From dc9fcf7a07ea3d7f0796625523ef8bd8fc248357 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Wed, 2 Feb 2011 13:59:28 +0100
|
||||
Subject: [PATCH] Fix shading
|
||||
|
||||
---
|
||||
sisu-inject/guice-bean/sisu-inject-bean/pom.xml | 13 +++----------
|
||||
.../guice-plexus/sisu-inject-plexus/pom.xml | 8 --------
|
||||
2 files changed, 3 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/sisu-inject/guice-bean/sisu-inject-bean/pom.xml b/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
index 2b129c6..6a9a9b4 100644
|
||||
--- a/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
+++ b/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
@@ -58,10 +58,9 @@
|
||||
</DynamicImport-Package>
|
||||
<Export-Package>
|
||||
org.sonatype.inject.*;-noimport:=true;-split-package:=merge-first;version=${project.version},
|
||||
- javax.*|org.aopalliance.*;version=1
|
||||
</Export-Package>
|
||||
<Private-Package>
|
||||
- org.sonatype.guice.*,org.objectweb.asm
|
||||
+ org.sonatype.guice.*
|
||||
</Private-Package>
|
||||
</instructions>
|
||||
</configuration>
|
||||
@@ -80,18 +79,12 @@
|
||||
<include>${project.groupId}:${project.artifactId}</include>
|
||||
</includes>
|
||||
</artifactSet>
|
||||
- <relocations>
|
||||
- <relocation>
|
||||
- <pattern>org.objectweb</pattern>
|
||||
- <shadedPattern>org.sonatype.guice</shadedPattern>
|
||||
- </relocation>
|
||||
- </relocations>
|
||||
<filters>
|
||||
<filter>
|
||||
<artifact>*:*</artifact>
|
||||
<excludes>
|
||||
- <exclude>org/objectweb/asm/*Adapter*</exclude>
|
||||
- <exclude>org/objectweb/asm/*Writer*</exclude>
|
||||
+ <exclude>org.objectweb.asm:asm</exclude>
|
||||
+ <exclude>javax.inject:javax.inject</exclude>
|
||||
</excludes>
|
||||
</filter>
|
||||
</filters>
|
||||
diff --git a/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml b/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
index 0eef00e..48fe364 100644
|
||||
--- a/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
+++ b/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
@@ -81,20 +81,12 @@
|
||||
<include>${project.groupId}:${project.artifactId}</include>
|
||||
</includes>
|
||||
</artifactSet>
|
||||
- <relocations>
|
||||
- <relocation>
|
||||
- <pattern>org.objectweb</pattern>
|
||||
- <shadedPattern>org.sonatype.guice</shadedPattern>
|
||||
- </relocation>
|
||||
- </relocations>
|
||||
<filters>
|
||||
<filter>
|
||||
<artifact>*:*</artifact>
|
||||
<includes>
|
||||
<include>META-INF/**</include>
|
||||
- <include>org/codehaus/plexus/**</include>
|
||||
<include>org/sonatype/guice/plexus/**</include>
|
||||
- <include>org/objectweb/asm/*Writer*</include>
|
||||
</includes>
|
||||
</filter>
|
||||
</filters>
|
||||
--
|
||||
1.7.3.5
|
||||
|
38
0001-Remove-test-deps.patch
Normal file
38
0001-Remove-test-deps.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From 3851989abd3be705ed6e2bdeed733192e795c654 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Mon, 28 Feb 2011 13:52:40 +0100
|
||||
Subject: [PATCH 1/2] Remove test deps
|
||||
|
||||
---
|
||||
pom.xml | 15 ---------------
|
||||
1 files changed, 0 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 35ecf55..5f4ac89 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -98,21 +98,6 @@
|
||||
<forgeReleaseUrl>https://repository.sonatype.org/service/local/staging/deploy/maven2</forgeReleaseUrl>
|
||||
</properties>
|
||||
|
||||
- <dependencies>
|
||||
- <dependency>
|
||||
- <groupId>ch.qos.logback</groupId>
|
||||
- <artifactId>logback-classic</artifactId>
|
||||
- <version>0.9.28</version>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.testng</groupId>
|
||||
- <artifactId>testng</artifactId>
|
||||
- <version>5.14.9</version>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
- </dependencies>
|
||||
-
|
||||
<dependencyManagement>
|
||||
<dependencies>
|
||||
|
||||
--
|
||||
1.7.4
|
||||
|
39
0002-Fix-plexus-bundling.patch
Normal file
39
0002-Fix-plexus-bundling.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 754a250de67f064662072c87f4f3e129ee149991 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Mon, 28 Feb 2011 16:41:30 +0100
|
||||
Subject: [PATCH 2/2] Fix plexus bundling
|
||||
|
||||
---
|
||||
sisu-inject/guice-bean/sisu-inject-bean/pom.xml | 1 -
|
||||
.../guice-plexus/sisu-inject-plexus/pom.xml | 3 ---
|
||||
2 files changed, 0 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/sisu-inject/guice-bean/sisu-inject-bean/pom.xml b/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
index 44f53bd..adbccd0 100644
|
||||
--- a/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
+++ b/sisu-inject/guice-bean/sisu-inject-bean/pom.xml
|
||||
@@ -74,7 +74,6 @@
|
||||
</DynamicImport-Package>
|
||||
<Export-Package>
|
||||
org.sonatype.inject;-noimport:=true;-split-package:=merge-first;version=${project.version},
|
||||
- javax.*|org.aopalliance.*;version=1
|
||||
</Export-Package>
|
||||
<Private-Package>
|
||||
org.sonatype.guice.bean.*
|
||||
diff --git a/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml b/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
index c49291f..6afb568 100644
|
||||
--- a/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
+++ b/sisu-inject/guice-plexus/sisu-inject-plexus/pom.xml
|
||||
@@ -74,9 +74,6 @@
|
||||
<DynamicImport-Package>
|
||||
org.slf4j,junit.framework
|
||||
</DynamicImport-Package>
|
||||
- <Export-Package>
|
||||
- org.codehaus.plexus.*;-noimport:=true;-split-package:=merge-first
|
||||
- </Export-Package>
|
||||
<Private-Package>
|
||||
META-INF.plexus,org.sonatype.guice.plexus.*
|
||||
</Private-Package>
|
||||
--
|
||||
1.7.4
|
||||
|
31
sisu.spec
31
sisu.spec
@ -1,6 +1,6 @@
|
||||
Name: sisu
|
||||
Version: 1.4.3.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.1.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Sonatype dependency injection framework
|
||||
|
||||
|
||||
@ -9,16 +9,17 @@ License: ASL 2.0
|
||||
URL: http://github.com/sonatype/sisu
|
||||
|
||||
# git clone git://github.com/sonatype/sisu
|
||||
# git archive --prefix="sonatype-sisu-1.4.3.2/" --format=tar sisu-1.4.3.2 > sisu-1.4.3.2.tar.gz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# git archive --prefix="sisu-2.1.1/" --format=tar sisu-2.1.1 | bzip2 > sisu-2.1.1.tar.bz2
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
Source1: %{name}-depmap.xml
|
||||
Patch0: 0001-Fix-shading.patch
|
||||
Patch0: 0001-Remove-test-deps.patch
|
||||
Patch1: 0002-Fix-plexus-bundling.patch
|
||||
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: google-guice
|
||||
BuildRequires: maven2
|
||||
BuildRequires: maven
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-enforcer-plugin
|
||||
BuildRequires: maven-invoker-plugin
|
||||
@ -55,13 +56,16 @@ Requires: jpackage-utils
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
# TODO enable guice-eclipse
|
||||
sed -i 's:.*guice-eclipse.*::g' sisu-inject/pom.xml
|
||||
rm -rf sisu-inject/guice-eclipse
|
||||
|
||||
%build
|
||||
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||
mkdir -p $MAVEN_REPO_LOCAL
|
||||
mvn-jpp \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
-Dmaven2.jpp.depmap.file=%{SOURCE1} \
|
||||
mvn-rpmbuild \
|
||||
-Dmaven.local.depmap.file=%{SOURCE1} \
|
||||
-Dmaven.test.skip=true \
|
||||
install javadoc:aggregate
|
||||
|
||||
@ -134,6 +138,11 @@ rm -rf $(readlink -f %{_javadocdir}/%{name}) %{_javadocdir}/%{name} || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 28 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.1.1-1
|
||||
- Update to 2.1.1
|
||||
- Update patch
|
||||
- Disable guice-eclipse for now
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user