Update to upstream version 0.3.0
This commit is contained in:
parent
5428a6665e
commit
c1fc5d9a59
2
.gitignore
vendored
2
.gitignore
vendored
@ -18,3 +18,5 @@
|
||||
/org.eclipse.sisu.plexus-0.2.1.tar.bz2
|
||||
/org.eclipse.sisu.inject-0.3.0.M1.tar.bz2
|
||||
/org.eclipse.sisu.plexus-0.3.0.M1.tar.bz2
|
||||
/org.eclipse.sisu.inject-0.3.0.tar.bz2
|
||||
/org.eclipse.sisu.plexus-0.3.0.tar.bz2
|
||||
|
@ -8,3 +8,13 @@
|
||||
org.osgi.framework;version="1.5",
|
||||
org.osgi.util.tracker;version="1.4",
|
||||
org.slf4j;resolution:=optional,
|
||||
--- sisu-inject/org.eclipse.sisu.inject/build.properties~ 2015-02-25 14:46:42.392037463 +0100
|
||||
+++ sisu-inject/org.eclipse.sisu.inject/build.properties 2015-02-25 14:44:56.626803789 +0100
|
||||
@@ -17,5 +17,5 @@
|
||||
.
|
||||
|
||||
# build with JSR250 v1.2 and workaround indirect Guava dependency via Guice 4
|
||||
-extra.. = platform:/plugin/javax.annotation,platform:/plugin/com.google.guava
|
||||
-additional.bundles = javax.annotation,com.google.guava
|
||||
+extra.. = platform:/plugin/javax.annotation-api,platform:/plugin/com.google.guava
|
||||
+additional.bundles = javax.annotation-api,com.google.guava
|
||||
|
@ -1,38 +0,0 @@
|
||||
--- sisu-inject/org.eclipse.sisu.inject.tests/src/org/eclipse/sisu/inject/TypeArgumentsTest.java.~ 2014-04-21 16:32:25.000000000 +0200
|
||||
+++ sisu-inject/org.eclipse.sisu.inject.tests/src/org/eclipse/sisu/inject/TypeArgumentsTest.java 2014-09-12 08:14:58.641201053 +0200
|
||||
@@ -10,6 +10,8 @@
|
||||
*******************************************************************************/
|
||||
package org.eclipse.sisu.inject;
|
||||
|
||||
+import java.lang.annotation.Annotation;
|
||||
+import java.lang.reflect.AnnotatedType;
|
||||
import java.lang.reflect.GenericDeclaration;
|
||||
import java.lang.reflect.ParameterizedType;
|
||||
import java.lang.reflect.Type;
|
||||
@@ -362,6 +364,26 @@
|
||||
return new Type[] { String.class };
|
||||
}
|
||||
|
||||
+ public AnnotatedType[] getAnnotatedBounds()
|
||||
+ {
|
||||
+ return new AnnotatedType[0];
|
||||
+ }
|
||||
+
|
||||
+ public Annotation[] getAnnotations()
|
||||
+ {
|
||||
+ return new Annotation[0];
|
||||
+ }
|
||||
+
|
||||
+ public Annotation[] getDeclaredAnnotations()
|
||||
+ {
|
||||
+ return new Annotation[0];
|
||||
+ }
|
||||
+
|
||||
+ public <T extends Annotation> T getAnnotation(Class<T> annotationClass)
|
||||
+ {
|
||||
+ return null;
|
||||
+ }
|
||||
+
|
||||
public GenericDeclaration getGenericDeclaration()
|
||||
{
|
||||
return null;
|
11
sisu.spec
11
sisu.spec
@ -1,11 +1,11 @@
|
||||
# Release type, either "milestone" or "release"
|
||||
%global reltype milestone
|
||||
%global reltag .M1
|
||||
%global reltype release
|
||||
#global reltag .M1
|
||||
|
||||
Name: sisu
|
||||
Epoch: 1
|
||||
Version: 0.3.0
|
||||
Release: 0.2%{?reltag}%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Eclipse dependency injection framework
|
||||
License: EPL
|
||||
URL: http://eclipse.org/sisu
|
||||
@ -14,7 +14,6 @@ Source0: http://git.eclipse.org/c/%{name}/org.eclipse.%{name}.inject.git/
|
||||
Source1: http://git.eclipse.org/c/%{name}/org.eclipse.%{name}.plexus.git/snapshot/%{reltype}s/%{version}%{?reltag}.tar.bz2#/org.eclipse.%{name}.plexus-%{version}%{?reltag}.tar.bz2
|
||||
|
||||
Patch0: %{name}-OSGi-import-guava.patch
|
||||
Patch1: %{name}-java8.patch
|
||||
Patch2: %{name}-ignored-tests.patch
|
||||
Patch3: %{name}-plexus-utils-3.0.18.patch
|
||||
|
||||
@ -119,7 +118,6 @@ tar xf %{SOURCE0} && mv %{reltype}s/* sisu-inject && rmdir %{reltype}s
|
||||
tar xf %{SOURCE1} && mv %{reltype}s/* sisu-plexus && rmdir %{reltype}s
|
||||
|
||||
%patch0
|
||||
%patch1
|
||||
%patch2
|
||||
%patch3
|
||||
|
||||
@ -208,6 +206,9 @@ EOF
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 23 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:0.3.0-1
|
||||
- Update to upstream version 0.3.0
|
||||
|
||||
* Wed Feb 18 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:0.3.0-0.2.M1
|
||||
- Unbundle ASM
|
||||
- Resolves: rhbz#1085903
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
7c8e0b75878b71e5b77e2a8e1b35ffa8 org.eclipse.sisu.inject-0.3.0.M1.tar.bz2
|
||||
4afe3fb24ff0d93066b670e288c365b3 org.eclipse.sisu.plexus-0.3.0.M1.tar.bz2
|
||||
ed53df7106aac1e8746301f65de3691b org.eclipse.sisu.inject-0.3.0.tar.bz2
|
||||
6ec9b89577a98add2b9a58c5e35acf5d org.eclipse.sisu.plexus-0.3.0.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user