update to version 0.3.4
This commit is contained in:
parent
70f89ddbab
commit
49e00e4262
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,3 +1,6 @@
|
||||
/results_*
|
||||
/*.src.rpm
|
||||
|
||||
/sonatype-sisu-sisu-1.4.2-0-gae9a407.tar.gz
|
||||
/sisu-1.4.3.2.tar.gz
|
||||
/sisu-2.1.1.tar.bz2
|
||||
@ -26,3 +29,5 @@
|
||||
/org.eclipse.sisu.plexus-0.3.2.tar.bz2
|
||||
/org.eclipse.sisu.inject-0.3.3.tar.bz2
|
||||
/org.eclipse.sisu.plexus-0.3.3.tar.bz2
|
||||
/org.eclipse.sisu.inject-0.3.4.tar.gz
|
||||
/org.eclipse.sisu.plexus-0.3.4.tar.gz
|
||||
|
98
0001-Remove-dependency-on-glassfish-servlet-api.patch
Normal file
98
0001-Remove-dependency-on-glassfish-servlet-api.patch
Normal file
@ -0,0 +1,98 @@
|
||||
From b14ee1ef509d9717eaa29e672282901847f2f735 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Mon, 16 Sep 2019 10:48:10 +0200
|
||||
Subject: [PATCH] Remove dependency on glassfish-servlet-api
|
||||
|
||||
---
|
||||
.../eclipse/sisu/inject/Implementations.java | 56 +------------------
|
||||
1 file changed, 1 insertion(+), 55 deletions(-)
|
||||
|
||||
diff --git a/sisu-inject/org.eclipse.sisu.inject/src/org/eclipse/sisu/inject/Implementations.java b/sisu-inject/org.eclipse.sisu.inject/src/org/eclipse/sisu/inject/Implementations.java
|
||||
index 523c9b2..89db5da 100644
|
||||
--- a/sisu-inject/org.eclipse.sisu.inject/src/org/eclipse/sisu/inject/Implementations.java
|
||||
+++ b/sisu-inject/org.eclipse.sisu.inject/src/org/eclipse/sisu/inject/Implementations.java
|
||||
@@ -38,17 +38,6 @@ final class Implementations
|
||||
|
||||
static
|
||||
{
|
||||
- boolean hasGuiceServlet;
|
||||
- try
|
||||
- {
|
||||
- hasGuiceServlet = BindingTargetVisitor.class.isInstance( ServletFinder.THIS );
|
||||
- }
|
||||
- catch ( final LinkageError e )
|
||||
- {
|
||||
- hasGuiceServlet = false;
|
||||
- }
|
||||
- HAS_GUICE_SERVLET = hasGuiceServlet;
|
||||
-
|
||||
boolean hasJsr250Priority;
|
||||
try
|
||||
{
|
||||
@@ -65,8 +54,6 @@ final class Implementations
|
||||
// Constants
|
||||
// ----------------------------------------------------------------------
|
||||
|
||||
- private static final boolean HAS_GUICE_SERVLET;
|
||||
-
|
||||
private static final boolean HAS_JSR250_PRIORITY;
|
||||
|
||||
// ----------------------------------------------------------------------
|
||||
@@ -106,7 +93,7 @@ final class Implementations
|
||||
|
||||
// peek behind servlet/filter extension bindings when checking priority, so we can order them by rank
|
||||
final Class<?> implementation =
|
||||
- binding.acceptTargetVisitor( HAS_GUICE_SERVLET && isPriority ? ServletFinder.THIS : ClassFinder.THIS );
|
||||
+ binding.acceptTargetVisitor( ClassFinder.THIS );
|
||||
|
||||
T annotation = null;
|
||||
if ( null != implementation )
|
||||
@@ -215,45 +202,4 @@ final class Implementations
|
||||
return binding.getPrivateElements().getInjector().getBinding( binding.getKey() ).acceptTargetVisitor( this );
|
||||
}
|
||||
}
|
||||
-
|
||||
- /**
|
||||
- * {@link ClassFinder} that can also peek behind servlet/filter bindings.
|
||||
- */
|
||||
- static final class ServletFinder
|
||||
- extends ClassFinder
|
||||
- implements com.google.inject.servlet.ServletModuleTargetVisitor<Object, Class<?>>
|
||||
- {
|
||||
- // ----------------------------------------------------------------------
|
||||
- // Constants
|
||||
- // ----------------------------------------------------------------------
|
||||
-
|
||||
- @SuppressWarnings( "hiding" )
|
||||
- static final BindingTargetVisitor<Object, Class<?>> THIS = new ServletFinder();
|
||||
-
|
||||
- // ----------------------------------------------------------------------
|
||||
- // Public methods
|
||||
- // ----------------------------------------------------------------------
|
||||
-
|
||||
- public Class<?> visit( final com.google.inject.servlet.InstanceFilterBinding binding )
|
||||
- {
|
||||
- return binding.getFilterInstance().getClass();
|
||||
- }
|
||||
-
|
||||
- public Class<?> visit( final com.google.inject.servlet.InstanceServletBinding binding )
|
||||
- {
|
||||
- return binding.getServletInstance().getClass();
|
||||
- }
|
||||
-
|
||||
- public Class<?> visit( final com.google.inject.servlet.LinkedFilterBinding binding )
|
||||
- {
|
||||
- // this assumes only one level of indirection: api-->impl
|
||||
- return binding.getLinkedKey().getTypeLiteral().getRawType();
|
||||
- }
|
||||
-
|
||||
- public Class<?> visit( final com.google.inject.servlet.LinkedServletBinding binding )
|
||||
- {
|
||||
- // this assumes only one level of indirection: api-->impl
|
||||
- return binding.getLinkedKey().getTypeLiteral().getRawType();
|
||||
- }
|
||||
- }
|
||||
}
|
||||
--
|
||||
2.21.0
|
||||
|
43
sisu.spec
43
sisu.spec
@ -1,27 +1,23 @@
|
||||
# Release type, either "milestone" or "release"
|
||||
%global reltype release
|
||||
#global reltag .M1
|
||||
|
||||
Name: sisu
|
||||
Epoch: 1
|
||||
Version: 0.3.3
|
||||
Release: 9%{?dist}
|
||||
Summary: Eclipse dependency injection framework
|
||||
# sisu is EPL-1.0
|
||||
# bundled asm is BSD
|
||||
Epoch: 1
|
||||
Version: 0.3.4
|
||||
Release: 1%{?dist}
|
||||
# sisu is EPL-1.0, the bundled asm is BSD
|
||||
License: EPL-1.0 and BSD
|
||||
|
||||
URL: http://eclipse.org/sisu
|
||||
Source0: http://git.eclipse.org/c/sisu/org.eclipse.sisu.inject.git/snapshot/releases/%{version}.tar.gz#/org.eclipse.sisu.inject-%{version}.tar.gz
|
||||
Source1: http://git.eclipse.org/c/sisu/org.eclipse.sisu.plexus.git/snapshot/releases/%{version}.tar.gz#/org.eclipse.sisu.plexus-%{version}.tar.gz
|
||||
|
||||
Source0: http://git.eclipse.org/c/%{name}/org.eclipse.%{name}.inject.git/snapshot/%{reltype}s/%{version}%{?reltag}.tar.bz2#/org.eclipse.%{name}.inject-%{version}%{?reltag}.tar.bz2
|
||||
Source1: http://git.eclipse.org/c/%{name}/org.eclipse.%{name}.plexus.git/snapshot/%{reltype}s/%{version}%{?reltag}.tar.bz2#/org.eclipse.%{name}.plexus-%{version}%{?reltag}.tar.bz2
|
||||
Source100: sisu-parent.pom
|
||||
Source101: sisu-inject.pom
|
||||
Source102: sisu-plexus.pom
|
||||
|
||||
Source100: %{name}-parent.pom
|
||||
Source101: %{name}-inject.pom
|
||||
Source102: %{name}-plexus.pom
|
||||
|
||||
Patch0: %{name}-OSGi-import-guava.patch
|
||||
Patch2: %{name}-ignored-tests.patch
|
||||
Patch3: %{name}-osgi-api.patch
|
||||
Patch0: sisu-OSGi-import-guava.patch
|
||||
Patch2: sisu-ignored-tests.patch
|
||||
Patch3: sisu-osgi-api.patch
|
||||
Patch4: 0001-Remove-dependency-on-glassfish-servlet-api.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -31,7 +27,6 @@ BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
||||
BuildRequires: mvn(javax.annotation:javax.annotation-api)
|
||||
BuildRequires: mvn(javax.enterprise:cdi-api)
|
||||
BuildRequires: mvn(javax.inject:javax.inject)
|
||||
BuildRequires: mvn(javax.servlet:servlet-api)
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-classworlds)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
|
||||
@ -68,8 +63,8 @@ This package contains %{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -c -T
|
||||
tar xf %{SOURCE0} && mv %{reltype}s/* sisu-inject && rmdir %{reltype}s
|
||||
tar xf %{SOURCE1} && mv %{reltype}s/* sisu-plexus && rmdir %{reltype}s
|
||||
tar xf %{SOURCE0} && mv releases/* sisu-inject && rmdir releases
|
||||
tar xf %{SOURCE1} && mv releases/* sisu-plexus && rmdir releases
|
||||
|
||||
cp %{SOURCE100} pom.xml
|
||||
cp %{SOURCE101} sisu-inject/pom.xml
|
||||
@ -78,6 +73,9 @@ cp %{SOURCE102} sisu-plexus/pom.xml
|
||||
%patch0
|
||||
%patch2
|
||||
%patch3
|
||||
%patch4 -p1
|
||||
|
||||
%pom_remove_dep :servlet-api sisu-inject
|
||||
|
||||
%pom_xpath_set -r /pom:project/pom:version %{version}
|
||||
|
||||
@ -102,6 +100,9 @@ cp %{SOURCE102} sisu-plexus/pom.xml
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 13 2020 Fabio Valentini <decathorpe@gmail.com> - 1:0.3.4-1
|
||||
- Update to version 0.3.4.
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:0.3.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (org.eclipse.sisu.inject-0.3.3.tar.bz2) = 5c99bba3bb9698394c76715c6f917f51041f9bc1f1c34b7036213a4a826746f5252c70def58283b75b97da1ecaba0e38704a46b8b993a1d54814e2e2050b15e0
|
||||
SHA512 (org.eclipse.sisu.plexus-0.3.3.tar.bz2) = e9e73d51abbbdbd18a739650aa4f7ab084bd47de711d9ba1db107f054bdeac358a4dbc5ab6e050f86aca1f3e16dcef99c14bc93dc297039d7f986afe95fd71ce
|
||||
SHA512 (org.eclipse.sisu.inject-0.3.4.tar.gz) = 317a63ddea93b8ed2a1c6c878bc9171c2b1b00a8f7b8a39f0a993359efe5b8657d72a78b3608b208f7e6b7b7b2186c4adf57d05b8ad294631d05a3b378dd6a24
|
||||
SHA512 (org.eclipse.sisu.plexus-0.3.4.tar.gz) = 49bbbc7479e3be7a87b6d69f94e6bd004a78b8d02d41581e9315c9229728e2e531495bedffff94cb05bc8cbdb5ac6672cc14d5925844db05b199e07d1c9751e5
|
||||
|
Loading…
Reference in New Issue
Block a user