Import from AlmaLinux stable repository
This commit is contained in:
parent
6aa290316a
commit
e75d7e7764
12
SOURCES/sip6-fix-exception-handling.patch
Normal file
12
SOURCES/sip6-fix-exception-handling.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/sipbuild/generator/parser/rules.py b/sipbuild/generator/parser/rules.py
|
||||||
|
index c221ad7..e79e1b8 100644
|
||||||
|
--- a/sipbuild/generator/parser/rules.py
|
||||||
|
+++ b/sipbuild/generator/parser/rules.py
|
||||||
|
@@ -2293,6 +2293,7 @@ def p_opt_base_exception(p):
|
||||||
|
|
||||||
|
if len(p) == 4:
|
||||||
|
base = p[2]
|
||||||
|
+ base.make_absolute()
|
||||||
|
|
||||||
|
# See if it is a project-defined exception.
|
||||||
|
for xd in p.parser.pm.spec.exceptions:
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: sip6
|
Name: sip6
|
||||||
Version: 6.6.2
|
Version: 6.6.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: SIP - Python/C++ Bindings Generator
|
Summary: SIP - Python/C++ Bindings Generator
|
||||||
%py_provides python3-sip6
|
%py_provides python3-sip6
|
||||||
|
|
||||||
@ -12,6 +12,9 @@ URL: https://www.riverbankcomputing.com/software/sip
|
|||||||
Source0: %{pypi_source}
|
Source0: %{pypi_source}
|
||||||
Patch0: 323d39a2d602
|
Patch0: 323d39a2d602
|
||||||
|
|
||||||
|
# Bug 2225259 - regression bug when using sub-classed C++ exceptions
|
||||||
|
Patch1: sip6-fix-exception-handling.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: %{py3_dist packaging ply setuptools toml}
|
BuildRequires: %{py3_dist packaging ply setuptools toml}
|
||||||
@ -46,6 +49,10 @@ Python bindings for wxWidgets.}
|
|||||||
%{python3_sitearch}/sipbuild/
|
%{python3_sitearch}/sipbuild/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 25 2023 Jan Grulich <jgrulich@redhat.com> - 6.6.2-2
|
||||||
|
- Fixed the handling of exceptions that sub-class C++ exceptions
|
||||||
|
Resolves: bz#2225259
|
||||||
|
|
||||||
* Mon Oct 24 2022 Jan Grulich <jgrulich@redhat.com> - 6.6.2-1
|
* Mon Oct 24 2022 Jan Grulich <jgrulich@redhat.com> - 6.6.2-1
|
||||||
- 6.6.2
|
- 6.6.2
|
||||||
Resolves: bz#2118862
|
Resolves: bz#2118862
|
||||||
|
Loading…
Reference in New Issue
Block a user