- Fixed the handling of exceptions that sub-class C++ exceptions

This commit is contained in:
eabdullin 2023-09-12 15:59:08 +03:00
parent 6aa290316a
commit c393ee9227
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff --git a/sipbuild/generator/parser/rules.py b/sipbuild/generator/parser/rules.py
index c221ad7..e79e1b8 100644
--- a/sipbuild/generator/parser/rules.py
+++ b/sipbuild/generator/parser/rules.py
@@ -2293,6 +2293,7 @@ def p_opt_base_exception(p):
if len(p) == 4:
base = p[2]
+ base.make_absolute()
# See if it is a project-defined exception.
for xd in p.parser.pm.spec.exceptions:

View File

@ -2,7 +2,7 @@
Name: sip6
Version: 6.6.2
Release: 1%{?dist}
Release: 1%{?dist}.1.alma.1
Summary: SIP - Python/C++ Bindings Generator
%py_provides python3-sip6
@ -11,6 +11,9 @@ License: (GPLv2 or GPLv3) and (GPLv2+ with exceptions)
URL: https://www.riverbankcomputing.com/software/sip
Source0: %{pypi_source}
Patch0: 323d39a2d602
# Patch was taken from:
# https://gitlab.com/redhat/centos-stream/rpms/sip6/-/blob/c9s/sip6-fix-exception-handling.patch
Patch1: sip6-fix-exception-handling.patch
BuildRequires: gcc
BuildRequires: python3-devel
@ -46,6 +49,9 @@ Python bindings for wxWidgets.}
%{python3_sitearch}/sipbuild/
%changelog
* Tue Sep 12 2023 Eduard Abdullin <eabdullin@almalinux.org> - 6.6.2-1.1.alma.1
- Fixed the handling of exceptions that sub-class C++ exceptions
* Mon Oct 24 2022 Jan Grulich <jgrulich@redhat.com> - 6.6.2-1
- 6.6.2
Resolves: bz#2118862