Fixed the handling of exceptions that sub-class C++ exceptions

Resolves: bz#2225259
This commit is contained in:
Jan Grulich 2023-07-25 08:50:14 +02:00
parent 6ad65740d0
commit 2abaa695db
1 changed files with 12 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff --git a/sipbuild/generator/parser/rules.py b/sipbuild/generator/parser/rules.py
index c221ad7..e79e1b8 100644
--- a/sipbuild/generator/parser/rules.py
+++ b/sipbuild/generator/parser/rules.py
@@ -2293,6 +2293,7 @@ def p_opt_base_exception(p):
if len(p) == 4:
base = p[2]
+ base.make_absolute()
# See if it is a project-defined exception.
for xd in p.parser.pm.spec.exceptions: