import sip-4.19.24-6.el9
This commit is contained in:
commit
7379277691
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/sip-4.19.24.tar.gz
|
1
.sip.metadata
Normal file
1
.sip.metadata
Normal file
@ -0,0 +1 @@
|
||||
bc509d2a9999e454751f1ccb674d01d204c09286 SOURCES/sip-4.19.24.tar.gz
|
3
SOURCES/macros.sip
Normal file
3
SOURCES/macros.sip
Normal file
@ -0,0 +1,3 @@
|
||||
%_sip_api_major 12
|
||||
%_sip_api_minor 7
|
||||
%_sip_api %{_sip_api_major}.%{_sip_api_minor}
|
21
SOURCES/sip-4.18-no_rpath.patch
Normal file
21
SOURCES/sip-4.18-no_rpath.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up sip-4.18/siputils.py.no_rpath sip-4.18/siputils.py
|
||||
--- sip-4.18/siputils.py.no_rpath 2015-03-25 06:00:24.000000000 -0500
|
||||
+++ sip-4.18/siputils.py 2016-04-13 11:34:48.179894616 -0500
|
||||
@@ -435,7 +435,7 @@ class Makefile:
|
||||
if l_dir in ("", ".", ".."):
|
||||
continue
|
||||
|
||||
- rpaths.append(l)
|
||||
+ #rpaths.append(l)
|
||||
|
||||
if self._python:
|
||||
incdir.append(self.config.py_inc_dir)
|
||||
@@ -612,7 +612,7 @@ class Makefile:
|
||||
# Handle library directories.
|
||||
libdir_qt = self.optional_list("LIBDIR_QT")
|
||||
libdir.extend(libdir_qt)
|
||||
- rpaths.extend(libdir_qt)
|
||||
+ #rpaths.extend(libdir_qt)
|
||||
|
||||
if qt_version >= 0x040000:
|
||||
# Try and read QT_LIBINFIX from qconfig.pri.
|
21
SOURCES/sip-4.18-no_strip.patch
Normal file
21
SOURCES/sip-4.18-no_strip.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up sip-4.18/siputils.py.no_strip sip-4.18/siputils.py
|
||||
--- sip-4.18/siputils.py.no_strip 2015-03-25 06:00:24.000000000 -0500
|
||||
+++ sip-4.18/siputils.py 2016-04-13 11:34:23.718690341 -0500
|
||||
@@ -1469,7 +1469,7 @@ class ModuleMakefile(Makefile):
|
||||
"""
|
||||
def __init__(self, configuration, build_file, install_dir=None, static=0,
|
||||
console=0, qt=0, opengl=0, threaded=0, warnings=1, debug=0,
|
||||
- dir=None, makefile="Makefile", installs=None, strip=1,
|
||||
+ dir=None, makefile="Makefile", installs=None, strip=0,
|
||||
export_all=0, universal=None, arch=None,
|
||||
deployment_target=None):
|
||||
"""Initialise an instance of a module Makefile.
|
||||
@@ -1780,7 +1780,7 @@ class SIPModuleMakefile(ModuleMakefile):
|
||||
"""
|
||||
def __init__(self, configuration, build_file, install_dir=None, static=0,
|
||||
console=0, qt=0, opengl=0, threaded=0, warnings=1, debug=0,
|
||||
- dir=None, makefile="Makefile", installs=None, strip=1,
|
||||
+ dir=None, makefile="Makefile", installs=None, strip=0,
|
||||
export_all=0, universal=None, arch=None, prot_is_public=0,
|
||||
deployment_target=None):
|
||||
"""Initialise an instance of a SIP generated module Makefile.
|
12
SOURCES/sip-4.19.18-no_hardcode_sip_so.patch
Normal file
12
SOURCES/sip-4.19.18-no_hardcode_sip_so.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up sip-4.19.18/configure.py.orig sip-4.19.18/configure.py
|
||||
--- sip-4.19.18/configure.py.orig 2019-07-04 12:28:08.000000000 -0400
|
||||
+++ sip-4.19.18/configure.py 2019-08-27 21:56:33.871428348 -0400
|
||||
@@ -447,7 +447,7 @@ def create_makefiles(macros):
|
||||
if sys.platform == 'win32':
|
||||
mod = 'sip.lib' if opts.static else 'sip.pyd'
|
||||
else:
|
||||
- mod = 'libsip.a' if opts.static else 'sip.so'
|
||||
+ mod = 'libsip.a' if opts.static else sip_module_name.split('.')[-1] + '.so'
|
||||
|
||||
all_installs.append((mod, sip_module_dest_dir))
|
||||
|
3
SOURCES/sip-wrapper.sh
Normal file
3
SOURCES/sip-wrapper.sh
Normal file
@ -0,0 +1,3 @@
|
||||
#!/bin/sh
|
||||
|
||||
exec sip -n @SIP_MODULE@ $@
|
1070
SPECS/sip.spec
Normal file
1070
SPECS/sip.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user