4.19.25 + sync with Fedora
This commit is contained in:
parent
c1d6f37048
commit
43311019eb
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/sip-4.19.22.tar.gz
|
||||
/sip-4.19.23.tar.gz
|
||||
/sip-4.19.24.tar.gz
|
||||
/sip-4.19.25.tar.gz
|
||||
|
1
.sip.metadata
Normal file
1
.sip.metadata
Normal file
@ -0,0 +1 @@
|
||||
dea579470269fabeb920976c405fa7f5e67cd4bd sip-4.19.25.tar.gz
|
@ -1,7 +1,7 @@
|
||||
diff -up sip-4.18/siputils.py.no_rpath sip-4.18/siputils.py
|
||||
--- sip-4.18/siputils.py.no_rpath 2015-03-25 06:00:24.000000000 -0500
|
||||
+++ sip-4.18/siputils.py 2016-04-13 11:34:48.179894616 -0500
|
||||
@@ -435,7 +435,7 @@ class Makefile:
|
||||
diff -rupN --no-dereference sip-4.19.25/siputils.py sip-4.19.25-new/siputils.py
|
||||
--- sip-4.19.25/siputils.py 2021-10-21 13:45:54.808566613 +0200
|
||||
+++ sip-4.19.25-new/siputils.py 2021-10-21 13:45:54.812566611 +0200
|
||||
@@ -436,7 +436,7 @@ class Makefile:
|
||||
if l_dir in ("", ".", ".."):
|
||||
continue
|
||||
|
||||
@ -10,7 +10,7 @@ diff -up sip-4.18/siputils.py.no_rpath sip-4.18/siputils.py
|
||||
|
||||
if self._python:
|
||||
incdir.append(self.config.py_inc_dir)
|
||||
@@ -612,7 +612,7 @@ class Makefile:
|
||||
@@ -613,7 +613,7 @@ class Makefile:
|
||||
# Handle library directories.
|
||||
libdir_qt = self.optional_list("LIBDIR_QT")
|
||||
libdir.extend(libdir_qt)
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up sip-4.18/siputils.py.no_strip sip-4.18/siputils.py
|
||||
--- sip-4.18/siputils.py.no_strip 2015-03-25 06:00:24.000000000 -0500
|
||||
+++ sip-4.18/siputils.py 2016-04-13 11:34:23.718690341 -0500
|
||||
@@ -1469,7 +1469,7 @@ class ModuleMakefile(Makefile):
|
||||
diff -rupN --no-dereference sip-4.19.25/siputils.py sip-4.19.25-new/siputils.py
|
||||
--- sip-4.19.25/siputils.py 2021-02-26 16:17:35.156108000 +0100
|
||||
+++ sip-4.19.25-new/siputils.py 2021-10-21 13:45:54.780566626 +0200
|
||||
@@ -1473,7 +1473,7 @@ class ModuleMakefile(Makefile):
|
||||
"""
|
||||
def __init__(self, configuration, build_file, install_dir=None, static=0,
|
||||
console=0, qt=0, opengl=0, threaded=0, warnings=1, debug=0,
|
||||
@ -10,7 +10,7 @@ diff -up sip-4.18/siputils.py.no_strip sip-4.18/siputils.py
|
||||
export_all=0, universal=None, arch=None,
|
||||
deployment_target=None):
|
||||
"""Initialise an instance of a module Makefile.
|
||||
@@ -1780,7 +1780,7 @@ class SIPModuleMakefile(ModuleMakefile):
|
||||
@@ -1784,7 +1784,7 @@ class SIPModuleMakefile(ModuleMakefile):
|
||||
"""
|
||||
def __init__(self, configuration, build_file, install_dir=None, static=0,
|
||||
console=0, qt=0, opengl=0, threaded=0, warnings=1, debug=0,
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up sip-4.19.18/configure.py.orig sip-4.19.18/configure.py
|
||||
--- sip-4.19.18/configure.py.orig 2019-07-04 12:28:08.000000000 -0400
|
||||
+++ sip-4.19.18/configure.py 2019-08-27 21:56:33.871428348 -0400
|
||||
@@ -447,7 +447,7 @@ def create_makefiles(macros):
|
||||
diff -rupN --no-dereference sip-4.19.25/configure.py sip-4.19.25-new/configure.py
|
||||
--- sip-4.19.25/configure.py 2021-02-26 16:28:41.621025600 +0100
|
||||
+++ sip-4.19.25-new/configure.py 2021-10-21 13:45:54.845566597 +0200
|
||||
@@ -449,7 +449,7 @@ def create_makefiles(macros):
|
||||
if sys.platform == 'win32':
|
||||
mod = 'sip.lib' if opts.static else 'sip.pyd'
|
||||
else:
|
||||
|
52
sip-4.19.25-py_ssize_t_clean.patch
Normal file
52
sip-4.19.25-py_ssize_t_clean.patch
Normal file
@ -0,0 +1,52 @@
|
||||
From: Jochen Sprickerhof <jspricke@debian.org>
|
||||
Date: Fri, 5 Nov 2021 09:13:14 +0100
|
||||
Subject: Make parser not break on py_ssize_t_clean directive from SIP v6.4
|
||||
|
||||
---
|
||||
sipgen/metasrc/lexer.l | 1 +
|
||||
sipgen/metasrc/parser.y | 13 +++++++++++++
|
||||
2 files changed, 14 insertions(+)
|
||||
|
||||
diff --git a/sipgen/metasrc/lexer.l b/sipgen/metasrc/lexer.l
|
||||
index a52b018..c328202 100644
|
||||
--- a/sipgen/metasrc/lexer.l
|
||||
+++ b/sipgen/metasrc/lexer.l
|
||||
@@ -174,6 +174,7 @@ SIP_QOBJECT {return TK_QOBJECT;}
|
||||
<directive>timestamp {return TK_TIMESTAMP;}
|
||||
<directive>type {return TK_TYPE;}
|
||||
<directive>use_argument_names {return TK_USEARGNAMES;}
|
||||
+<directive>py_ssize_t_clean {return TK_PYSSIZETCLEAN;}
|
||||
<directive>use_limited_api {return TK_USELIMITEDAPI;}
|
||||
<directive>all_raise_py_exception {return TK_ALLRAISEPYEXC;}
|
||||
<directive>call_super_init {return TK_CALLSUPERINIT;}
|
||||
diff --git a/sipgen/metasrc/parser.y b/sipgen/metasrc/parser.y
|
||||
index 5623dca..2d98380 100644
|
||||
--- a/sipgen/metasrc/parser.y
|
||||
+++ b/sipgen/metasrc/parser.y
|
||||
@@ -389,6 +389,7 @@ static scopedNameDef *fullyQualifiedName(scopedNameDef *snd);
|
||||
%token TK_TIMESTAMP
|
||||
%token TK_TYPE
|
||||
%token TK_USEARGNAMES
|
||||
+%token TK_PYSSIZETCLEAN
|
||||
%token TK_USELIMITEDAPI
|
||||
%token TK_ALLRAISEPYEXC
|
||||
%token TK_CALLSUPERINIT
|
||||
@@ -2012,6 +2013,18 @@ module_arg: TK_KWARGS '=' TK_STRING_VALUE {
|
||||
$$.call_super_init = -1;
|
||||
$$.def_error_handler = NULL;
|
||||
}
|
||||
+ | TK_PYSSIZETCLEAN '=' bool_value {
|
||||
+ $$.token = TK_PYSSIZETCLEAN;
|
||||
+
|
||||
+ $$.c_module = FALSE;
|
||||
+ $$.kwargs = defaultKwArgs;
|
||||
+ $$.name = NULL;
|
||||
+ $$.use_arg_names = FALSE;
|
||||
+ $$.use_limited_api = FALSE;
|
||||
+ $$.all_raise_py_exc = FALSE;
|
||||
+ $$.call_super_init = -1;
|
||||
+ $$.def_error_handler = NULL;
|
||||
+ }
|
||||
| TK_USELIMITEDAPI '=' bool_value {
|
||||
$$.token = TK_USELIMITEDAPI;
|
||||
|
12
sip.spec
12
sip.spec
@ -39,8 +39,8 @@
|
||||
|
||||
Summary: SIP - Python/C++ Bindings Generator
|
||||
Name: sip
|
||||
Version: 4.19.24
|
||||
Release: 6%{?dist}
|
||||
Version: 4.19.25
|
||||
Release: 1%{?dist}
|
||||
|
||||
# sipgen/parser.{c.h} is GPLv3+ with exceptions (bison)
|
||||
License: GPLv2 or GPLv3 and (GPLv3+ with exceptions)
|
||||
@ -61,6 +61,8 @@ Patch51: sip-4.18-no_rpath.patch
|
||||
#Patch52: sip-4.19.3-python3_sip_bin.patch
|
||||
# Avoid hardcoding sip.so (needed for wxpython's siplib.so)
|
||||
Patch53: sip-4.19.18-no_hardcode_sip_so.patch
|
||||
# Recognize the py_ssize_t_clean directive to avoid FTBFS with PyQt 5.15.6
|
||||
Patch54: sip-4.19.25-py_ssize_t_clean.patch
|
||||
|
||||
# extracted from sip.h, SIP_API_MAJOR_NR SIP_API_MINOR_NR defines
|
||||
Source1: macros.sip
|
||||
@ -207,7 +209,7 @@ This is the Python 3 build of wx-siplib.
|
||||
%patch50 -p1 -b .no_strip
|
||||
%patch51 -p1 -b .no_rpath
|
||||
%patch53 -p1 -b .no_sip_so
|
||||
|
||||
%patch54 -p1 -b .py_ssize_t_clean
|
||||
|
||||
%build
|
||||
%if %{with python2}
|
||||
@ -453,6 +455,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 04 2022 Jan Grulich <jgrulich@redhat.com> - 4.19.25-1
|
||||
- 4.19.25 + sync with Fedora
|
||||
Resolves: bz#2071605
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 4.19.24-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sip-4.19.24.tar.gz) = c9acf8c66da6ff24ffaeed254c11deabbc587cea0eb50164f2016199af30b85980f96a2d754ae5e7fe080f9076673b1abc82e2a6a41ff2ac442fb2b326fca1c0
|
||||
SHA512 (sip-4.19.25.tar.gz) = 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
|
||||
|
Loading…
Reference in New Issue
Block a user