Update to latest upstream release v0.0.5.
This commit is contained in:
parent
a9e428c0d7
commit
5c2e2ef095
@ -1,26 +0,0 @@
|
||||
commit 8bb6f6fd35342ab070d1a8a8ac4f2dbd18b7c063
|
||||
Author: Peter Rajnoha <prajnoha@redhat.com>
|
||||
Date: Mon Jan 25 10:42:45 2021 +0100
|
||||
|
||||
modules: ucmd: dm_mpath: sync with mpath_valid changes
|
||||
|
||||
Use symbolic MPATH_LOG_PRIO_NOLOG (instead of '-1') and MPATH_LOG_STDERR
|
||||
(instead of MPATH_LOG_STDOUT which was removed) for mpathvalid_init
|
||||
call.
|
||||
---
|
||||
src/modules/ucmd/block/dm_mpath/dm_mpath.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/modules/ucmd/block/dm_mpath/dm_mpath.c b/src/modules/ucmd/block/dm_mpath/dm_mpath.c
|
||||
index 2c474b6..a31fee0 100644
|
||||
--- a/src/modules/ucmd/block/dm_mpath/dm_mpath.c
|
||||
+++ b/src/modules/ucmd/block/dm_mpath/dm_mpath.c
|
||||
@@ -39,7 +39,7 @@ static int _dm_mpath_init(struct module *module, struct sid_ucmd_mod_ctx *ucmd_m
|
||||
{
|
||||
log_debug(MID, "init");
|
||||
/* TODO - set up dm/udev logging */
|
||||
- if (mpathvalid_init(-1, MPATH_LOG_STDIO)) {
|
||||
+ if (mpathvalid_init(MPATH_LOG_PRIO_NOLOG, MPATH_LOG_STDERR)) {
|
||||
log_error(MID, "failed to initialize mpathvalid");
|
||||
return -1;
|
||||
}
|
41
sid.spec
41
sid.spec
@ -13,8 +13,8 @@ Name: sid
|
||||
%if 0%{?rhel}
|
||||
Epoch: %{rhel}
|
||||
%endif
|
||||
Version: 0.0.4
|
||||
Release: 4%{?scmsnap:.%{scmsnap}}%{?dist}
|
||||
Version: 0.0.5
|
||||
Release: 1%{?scmsnap:.%{scmsnap}}%{?dist}
|
||||
Summary: Storage Instantiation Daemon (SID)
|
||||
|
||||
License: GPLv2+
|
||||
@ -25,13 +25,12 @@ Source0: https://github.com/sid-project/%{name}/archive/%{commit}/%{name}-%{shor
|
||||
Source0: https://github.com/sid-project/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
%endif
|
||||
|
||||
Patch0: sid-0-0-5-modules-ucmd-dm_mpath-sync-with-mpath_valid-changes.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
BuildRequires: gperf
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtool
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: systemd-devel >= 221
|
||||
BuildRequires: libudev-devel >= 174
|
||||
@ -292,6 +291,7 @@ This package contains tools to support Storage Instantiation Daemon (SID).
|
||||
|
||||
|
||||
%files tools
|
||||
%{_sbindir}/sidctl
|
||||
%{_udevrulesdir}/../usid
|
||||
%doc README.md
|
||||
|
||||
@ -365,12 +365,31 @@ Instantiation Daemon (SID).
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 29 2021 Peter Rajnoha <prajnoha@redhat.com> - 0.0.4-4
|
||||
- Add epoch to rpm spec file for RHEL-based releases.
|
||||
##############################################################################
|
||||
# SID-MOD-TYPE-DM
|
||||
##############################################################################
|
||||
|
||||
* Fri Jan 29 2021 Peter Rajnoha <prajnoha@redhat.com> - 0.0.4-3
|
||||
- Sync with mpath_valid changes.
|
||||
%package mod-type-dm
|
||||
Summary: Device-mapper type module for Storage Instantiation Daemon (SID)
|
||||
Requires: %{name}-log-libs%{?_isa} = %{?epoch}:%{version}-%{release}
|
||||
Requires: %{name}-resource-libs%{?_isa} = %{?epoch}:%{version}-%{release}
|
||||
%description mod-type-dm
|
||||
This package contains device-mapper type module for Storage Instantiation
|
||||
Daemon (SID).
|
||||
|
||||
%files mod-type-dm
|
||||
%dir %{_libdir}/sid
|
||||
%dir %{_libdir}/sid/modules
|
||||
%dir %{_libdir}/sid/modules/ucmd
|
||||
%dir %{_libdir}/sid/modules/ucmd/type
|
||||
%dir %{_libdir}/sid/modules/ucmd/type/dm
|
||||
%{_libdir}/sid/modules/ucmd/type/dm.so
|
||||
%doc README.md
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Apr 06 2021 Peter Rajnoha <prajnoha@redhat.com> - 0.0.5-1
|
||||
- Update to latest upstream release.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user