import sharutils-4.15.2-11.el8

This commit is contained in:
CentOS Sources 2023-01-15 11:41:22 +00:00 committed by Stepan Oksanichenko
commit 87e8807d63
6 changed files with 703 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/sharutils-4.15.2.tar.xz

1
.sharutils.metadata Normal file
View File

@ -0,0 +1 @@
250377131bcf7a081f066ed0f9c51a0b7e0b0c04 SOURCES/sharutils-4.15.2.tar.xz

View File

@ -0,0 +1,87 @@
From 851a240296ad2ec2a5f67e84d284d3bf7882745e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 15 Dec 2014 11:20:32 +0100
Subject: [PATCH] Pass compilation with -Werror=format-security
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
<https://bugzilla.redhat.com/show_bug.cgi?id=1037323>
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
libopts/genshell.h | 2 +-
src/shar-opts.h | 2 +-
src/unshar-opts.h | 2 +-
src/uudecode-opts.h | 2 +-
src/uuencode-opts.h | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/libopts/genshell.h b/libopts/genshell.h
index 1c18735..0a69bc2 100644
--- a/libopts/genshell.h
+++ b/libopts/genshell.h
@@ -168,7 +168,7 @@ extern tOptions genshelloptOptions;
# endif
# ifndef ATTRIBUTE_FORMAT_ARG
-# define ATTRIBUTE_FORMAT_ARG(_a)
+# define ATTRIBUTE_FORMAT_ARG(_a) __attribute__ ((format_arg(_a)))
# endif
static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1);
diff --git a/src/shar-opts.h b/src/shar-opts.h
index 64f2f12..a32b69d 100644
--- a/src/shar-opts.h
+++ b/src/shar-opts.h
@@ -374,7 +374,7 @@ extern tOptions sharOptions;
# endif
# ifndef ATTRIBUTE_FORMAT_ARG
-# define ATTRIBUTE_FORMAT_ARG(_a)
+# define ATTRIBUTE_FORMAT_ARG(_a) __attribute__ ((format_arg(_a)))
# endif
static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1);
diff --git a/src/unshar-opts.h b/src/unshar-opts.h
index ae697af..19e8be7 100644
--- a/src/unshar-opts.h
+++ b/src/unshar-opts.h
@@ -211,7 +211,7 @@ extern tOptions unsharOptions;
# endif
# ifndef ATTRIBUTE_FORMAT_ARG
-# define ATTRIBUTE_FORMAT_ARG(_a)
+# define ATTRIBUTE_FORMAT_ARG(_a) __attribute__ ((format_arg(_a)))
# endif
static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1);
diff --git a/src/uudecode-opts.h b/src/uudecode-opts.h
index d457488..fd11a20 100644
--- a/src/uudecode-opts.h
+++ b/src/uudecode-opts.h
@@ -189,7 +189,7 @@ extern tOptions uudecodeOptions;
# endif
# ifndef ATTRIBUTE_FORMAT_ARG
-# define ATTRIBUTE_FORMAT_ARG(_a)
+# define ATTRIBUTE_FORMAT_ARG(_a) __attribute__ ((format_arg(_a)))
# endif
static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1);
diff --git a/src/uuencode-opts.h b/src/uuencode-opts.h
index 7c7ed78..41352ea 100644
--- a/src/uuencode-opts.h
+++ b/src/uuencode-opts.h
@@ -185,7 +185,7 @@ extern tOptions uuencodeOptions;
# endif
# ifndef ATTRIBUTE_FORMAT_ARG
-# define ATTRIBUTE_FORMAT_ARG(_a)
+# define ATTRIBUTE_FORMAT_ARG(_a) __attribute__ ((format_arg(_a)))
# endif
static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1);
--
1.9.3

View File

@ -0,0 +1,58 @@
From 1067cdba6d08f2a765cb0ea371189a5b703eb4db Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 22 Feb 2018 16:39:43 +0100
Subject: [PATCH] Fix a heap-buffer-overflow in find_archive()
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
rw_buffer has allocated rw_base_size bytes. But subsequend fgets() in
find_archive() reads up-to BUFSIZ bytes.
On my system, BUFSIZ is 8192. rw_base_size is usually equaled to
a memory page size, 4096 on my system. Thus find_archive() can write
beyonded allocated memmory for rw_buffer array:
$ valgrind -- ./unshar /tmp/id\:000000\,sig\:06\,src\:000005+000030\,op\:splice\,rep\:4
==30582== Memcheck, a memory error detector
==30582== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==30582== Using Valgrind-3.13.0 and LibVEX; rerun with -h for copyright info
==30582== Command: ./unshar /tmp/id:000000,sig:06,src:000005+000030,op:splice,rep:4
==30582==
==30582== Invalid write of size 1
==30582== at 0x4EAB480: _IO_getline_info (in /usr/lib64/libc-2.27.so)
==30582== by 0x4EB47C2: fgets_unlocked (in /usr/lib64/libc-2.27.so)
==30582== by 0x10BF60: fgets_unlocked (stdio2.h:320)
==30582== by 0x10BF60: find_archive (unshar.c:243)
==30582== by 0x10BF60: unshar_file (unshar.c:379)
==30582== by 0x10BCCC: validate_fname (unshar-opts.c:604)
==30582== by 0x10BCCC: main (unshar-opts.c:639)
==30582== Address 0x523a790 is 0 bytes after a block of size 4,096 alloc'd
==30582== at 0x4C2DBBB: malloc (vg_replace_malloc.c:299)
==30582== by 0x10C670: init_unshar (unshar.c:450)
==30582== by 0x10BC55: main (unshar-opts.c:630)
This was reported in
<http://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00004.html>.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
src/unshar.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/unshar.c b/src/unshar.c
index 80bc3a9..0fc3773 100644
--- a/src/unshar.c
+++ b/src/unshar.c
@@ -240,7 +240,7 @@ find_archive (char const * name, FILE * file, off_t start)
off_t position = ftello (file);
/* Read next line, fail if no more and no previous process. */
- if (!fgets (rw_buffer, BUFSIZ, file))
+ if (!fgets (rw_buffer, rw_base_size, file))
{
if (!start)
error (0, 0, _("Found no shell commands in %s"), name);
--
2.13.6

View File

@ -0,0 +1,178 @@
From 0e2f412eeec2e1f7f5743ea23c62bdf98bf4102c Mon Sep 17 00:00:00 2001
From: Paul Eggert <eggert@cs.ucla.edu>
Date: Thu, 8 Mar 2018 16:42:45 -0800
Subject: [PATCH] fflush: adjust to glibc 2.28 libio.h removal
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Petr Písař: Ported to sharutils-4.15.2 from:
commit 4af4a4a71827c0bc5e0ec67af23edef4f15cee8e
Author: Paul Eggert <eggert@cs.ucla.edu>
Date: Mon Mar 5 10:56:29 2018 -0800
fflush: adjust to glibc 2.28 libio.h removal
Problem reported by Daniel P. Berrangé in:
https://lists.gnu.org/r/bug-gnulib/2018-03/msg00000.html
* lib/fbufmode.c (fbufmode):
* lib/fflush.c (clear_ungetc_buffer_preserving_position)
(disable_seek_optimization, rpl_fflush):
* lib/fpending.c (__fpending):
* lib/fpurge.c (fpurge):
* lib/freadable.c (freadable):
* lib/freadahead.c (freadahead):
* lib/freading.c (freading):
* lib/freadptr.c (freadptr):
* lib/freadseek.c (freadptrinc):
* lib/fseeko.c (fseeko):
* lib/fseterr.c (fseterr):
* lib/fwritable.c (fwritable):
* lib/fwriting.c (fwriting):
Check _IO_EOF_SEEN instead of _IO_ftrylockfile.
* lib/stdio-impl.h (_IO_IN_BACKUP) [_IO_EOF_SEEN]:
Define if not already defined.
commit 74d9d6a293d7462dea8f83e7fc5ac792e956a0ad
Author: Paul Eggert <eggert@cs.ucla.edu>
Date: Thu Mar 8 16:42:45 2018 -0800
fflush: be more paranoid about libio.h change
Suggested by Eli Zaretskii in:
https://lists.gnu.org/r/emacs-devel/2018-03/msg00270.html
* lib/fbufmode.c (fbufmode):
* lib/fflush.c (clear_ungetc_buffer_preserving_position)
(disable_seek_optimization, rpl_fflush):
* lib/fpending.c (__fpending):
* lib/fpurge.c (fpurge):
* lib/freadable.c (freadable):
* lib/freadahead.c (freadahead):
* lib/freading.c (freading):
* lib/freadptr.c (freadptr):
* lib/freadseek.c (freadptrinc):
* lib/fseeko.c (fseeko):
* lib/fseterr.c (fseterr):
* lib/fwritable.c (fwritable):
* lib/fwriting.c (fwriting):
Look at _IO_ftrylockfile as well as at _IO_EOF_SEEN.
This is needed for glibc-2.28 (First spotted with
glibc-2.27.9000-13.fc29 on Fedora).
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
lib/fflush.c | 9 ++++++---
lib/fpurge.c | 3 ++-
lib/freading.c | 3 ++-
lib/fseeko.c | 6 ++++--
lib/stdio-impl.h | 6 ++++++
5 files changed, 20 insertions(+), 7 deletions(-)
diff --git a/lib/fflush.c b/lib/fflush.c
index 5ae3e41..d887ecb 100644
--- a/lib/fflush.c
+++ b/lib/fflush.c
@@ -33,7 +33,8 @@
#undef fflush
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+/* GNU libc, BeOS, Haiku, Linux libc5 */
/* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
static void
@@ -72,7 +73,8 @@ clear_ungetc_buffer (FILE *fp)
#endif
-#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
+#if ! (defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1)
+/* GNU libc, BeOS, Haiku, Linux libc5 */
# if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
@@ -148,7 +150,8 @@ rpl_fflush (FILE *stream)
if (stream == NULL || ! freading (stream))
return fflush (stream);
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+ /* GNU libc, BeOS, Haiku, Linux libc5 */
clear_ungetc_buffer_preserving_position (stream);
diff --git a/lib/fpurge.c b/lib/fpurge.c
index f313b22..a760c4d 100644
--- a/lib/fpurge.c
+++ b/lib/fpurge.c
@@ -62,7 +62,8 @@ fpurge (FILE *fp)
/* Most systems provide FILE as a struct and the necessary bitmask in
<stdio.h>, because they need it for implementing getc() and putc() as
fast macros. */
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+# if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+ /* GNU libc, BeOS, Haiku, Linux libc5 */
fp->_IO_read_end = fp->_IO_read_ptr;
fp->_IO_write_ptr = fp->_IO_write_base;
/* Avoid memory leak when there is an active ungetc buffer. */
diff --git a/lib/freading.c b/lib/freading.c
index 0512b19..2341577 100644
--- a/lib/freading.c
+++ b/lib/freading.c
@@ -31,7 +31,8 @@ freading (FILE *fp)
/* Most systems provide FILE as a struct and the necessary bitmask in
<stdio.h>, because they need it for implementing getc() and putc() as
fast macros. */
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+# if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+ /* GNU libc, BeOS, Haiku, Linux libc5 */
return ((fp->_flags & _IO_NO_WRITES) != 0
|| ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
&& fp->_IO_read_base != NULL));
diff --git a/lib/fseeko.c b/lib/fseeko.c
index 1c65d2a..1b1cc2f 100644
--- a/lib/fseeko.c
+++ b/lib/fseeko.c
@@ -47,7 +47,8 @@ fseeko (FILE *fp, off_t offset, int whence)
#endif
/* These tests are based on fpurge.c. */
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+ /* GNU libc, BeOS, Haiku, Linux libc5 */
if (fp->_IO_read_end == fp->_IO_read_ptr
&& fp->_IO_write_ptr == fp->_IO_write_base
&& fp->_IO_save_base == NULL)
@@ -123,7 +124,8 @@ fseeko (FILE *fp, off_t offset, int whence)
return -1;
}
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
+ /* GNU libc, BeOS, Haiku, Linux libc5 */
fp->_flags &= ~_IO_EOF_SEEN;
fp->_offset = pos;
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
index 502d891..ea38ee2 100644
--- a/lib/stdio-impl.h
+++ b/lib/stdio-impl.h
@@ -18,6 +18,12 @@
the same implementation of stdio extension API, except that some fields
have different naming conventions, or their access requires some casts. */
+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
+ problem by defining it ourselves. FIXME: Do not rely on glibc
+ internals. */
+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
+# define _IO_IN_BACKUP 0x100
+#endif
/* BSD stdio derived implementations. */
--
2.14.3

378
SPECS/sharutils.spec Normal file
View File

@ -0,0 +1,378 @@
Summary: The GNU shar utilities for packaging and unpackaging shell archives
Name: sharutils
Version: 4.15.2
Release: 11%{?dist}
# The main code: GPLv3+
# intl/dngettext.c: LGPLv2+
# lib (gnulib): GPLv3+
# lib/md5.c: GPLv3+ and Public Domain
# libopts/file.c: LGPLv3+ or BSD
# libopts/genshell.h: LGPLv2+
# libopts/m4/libopts.m4: GPLv3+
# doc/sharutils.texi: GFDL
# src/uuencode.c: GPLv3+ and BSD
## Not in the binary package
# ar-lib: GPLv2+
# config.rpath: FSFULLR
# INSTALL: FSFAPP
# install-sh: MIT
License: GPLv3+ and (GPLv3+ and BSD) and (LGPLv3+ or BSD) and LGPLv2+ and Public Domain and GFDL
Group: Applications/Archiving
Source: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
# Pass compilation with -Werror=format-security, bug #1037323
Patch0: %{name}-4.14.2-Pass-compilation-with-Werror-format-security.patch
# Fix CVE-2018-1000097 (a heap buffer overflow in find_archive()),
# bug #1548019,
# <http://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00004.html>
Patch1: %{name}-4.15.2-Fix-a-heap-buffer-overflow-in-find_archive.patch
# Adapt bundled gnulib to glibc-2.28, bug #1611745
Patch2: %{name}-4.15.2-fflush-adjust-to-glibc-2.28-libio.h-removal.patch
URL: http://www.gnu.org/software/%{name}/
BuildRequires: binutils
BuildRequires: coreutils
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: glibc-common
BuildRequires: make
BuildRequires: sed
# Tests:
BuildRequires: diffutils
Requires(post): info
Requires(preun): info
Provides: bundled(gnulib)
# See libopts/autoopts/options.h for OPTIONS_DOTTED_VERSION
Provides: bundled(libopts) = 41.1
%description
The sharutils package contains the GNU shar utilities, a set of tools for
encoding and decoding packages of files (in binary or text format) in
a special plain text format called shell archives (shar). This format can be
sent through e-mail (which can be problematic for regular binary files). The
shar utility supports a wide range of capabilities (compressing, uuencoding,
splitting long files for multi-part mailings, providing check-sums), which
make it very flexible at creating shar files. After the files have been sent,
the unshar tool scans mail messages looking for shar files. Unshar
automatically strips off mail headers and introductory text and then unpacks
the shar files.
%prep
%setup -q
%patch0 -p1 -b .format
%patch1 -p1
%patch2 -p1
# convert TODO, THANKS to UTF-8
for i in TODO THANKS; do
iconv -f iso-8859-1 -t utf-8 -o $i{.utf8,}
mv $i{.utf8,}
done
%build
%configure
make %{?_smp_mflags}
%install
make DESTDIR=${RPM_BUILD_ROOT} install
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
chmod 644 AUTHORS ChangeLog COPYING NEWS README THANKS TODO
%find_lang %{name}
%check
make check
%post
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir ||:
%preun
if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
fi
%files -f %{name}.lang
%license COPYING
%doc AUTHORS ChangeLog NEWS README THANKS TODO
%{_bindir}/*
%{_infodir}/*info*
%{_mandir}/man1/*
%{_mandir}/man5/*
%changelog
* Fri Aug 03 2018 Petr Pisar <ppisar@redhat.com> - 4.15.2-11
- Adapt bundled gnulib to glibc-2.28 (bug #1611745)
* Tue Jul 24 2018 Petr Pisar <ppisar@redhat.com> - 4.15.2-10
- License corrected to "GPLv3+ and (GPLv3+ and BSD) and (LGPLv3+ or BSD) and
LGPLv2+ and Public Domain and GFDL"
* Thu Feb 22 2018 Petr Pisar <ppisar@redhat.com> - 4.15.2-9
- Fix CVE-2018-1000097 (a heap buffer overflow in find_archive())
(bug #1548019)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Jun 09 2016 Petr Pisar <ppisar@redhat.com> - 4.15.2-4
- Build-require gcc instead of glibc-headers (bug #1230494)
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon Jun 01 2015 Petr Pisar <ppisar@redhat.com> - 4.15.2-1
- 4.15.2 bump
- Specify all dependencies
* Mon May 04 2015 Petr Pisar <ppisar@redhat.com> - 4.15.1-1
- 4.15.1 bump
* Mon Feb 09 2015 Petr Pisar <ppisar@redhat.com> - 4.15-1
- 4.15 bump
* Mon Dec 15 2014 Petr Pisar <ppisar@redhat.com> - 4.14.2-1
- 4.14.2 bump
- License changed from (GPLv3+ and LGPLv3+ and (LGPLv3+ or BSD) and LGPLv2+
and Public Domain and GFDL) to (GPLv3+ and (LGPLv3+ or BSD) and LGPLv2+
and Public Domain and GFDL)
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.14-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.14-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Dec 04 2013 Petr Pisar <ppisar@redhat.com> - 4.14-2
- Pass compilation with -Werror=format-security (bug #1037323)
* Mon Oct 21 2013 Petr Pisar <ppisar@redhat.com> - 4.14-1
- 4.14 bump
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.13.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Tue May 28 2013 Petr Pisar <ppisar@redhat.com> - 4.13.5-2
- Correct license declaration (LGPLv3+ and (LGPLv3+ or BSD) and GFDL added)
* Mon Apr 15 2013 Petr Pisar <ppisar@redhat.com> - 4.13.5-1
- 4.13.5 bump
* Wed Apr 03 2013 Petr Pisar <ppisar@redhat.com> - 4.13.4-1
- 4.13.4 bump
* Fri Feb 08 2013 Petr Pisar <ppisar@redhat.com> - 4.13.3-3
- Collect message catalogs in install phase (bug #908967)
* Wed Jan 23 2013 Petr Pisar <ppisar@redhat.com> - 4.13.3-2
- Fix decoding from positional argument while overriding output file
(bug #901895)
- Fix decoding to standard output when output file is - or /dev/stdout
(bug #901895)
* Mon Jan 07 2013 Petr Pisar <ppisar@redhat.com> - 4.13.3-1
- 4.13.3 bump
* Thu Jan 03 2013 Petr Pisar <ppisar@redhat.com> - 4.13.1-2
- Fix MD5 checksum generation on big-endian machines
* Thu Jan 03 2013 Petr Pisar <ppisar@redhat.com> - 4.13.1-1
- 4.13.1 bump
* Thu Aug 02 2012 Petr Pisar <ppisar@redhat.com> - 4.11.1-5
- Fix building with glibc-2.16.6
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue May 15 2012 Petr Pisar <ppisar@redhat.com> - 4.11.1-3
- Export bundled(gnulib) (bug #821789)
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Fri May 06 2011 Petr Pisar <ppisar@redhat.com> - 4.11.1-1
- 4.11.1 bump
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Mon Feb 07 2011 Petr Pisar <ppisar@redhat.com> - 4.11-1
- 4.11 bump
- Do not install header files injected by gnulib-tool
- Remove BuildRoot stuff
* Mon Aug 30 2010 Petr Pisar <ppisar@redhat.com> - 4.10-1
- 4.10 bump (bug #628304)
* Thu Jun 3 2010 Petr Pisar <ppisar@redhat.com> - 4.9-1
- version bump to 4.9 (bug #569059, bug #583187)
* Mon Feb 1 2010 Stepan Kasal <skasal@redhat.com> - 4.7-6
- fix the License tag
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Thu Sep 04 2008 Jason L Tibbitts III <tibbs@math.uh.edu> - 4.7-3
- Requires(pre) should be Requires(post).
* Thu Sep 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 4.7-2
- forgot the new source
* Thu Sep 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 4.7-1
- update to 4.7
- fix license tag
- package cleanups
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.3-2
- Autorebuild for GCC 4.3
* Tue Apr 10 2007 Than Ngo <than@redhat.com> - 4.6.3-1
- 4.6.3
* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2
- rebuild
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-1.2
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-1.1
- rebuilt for new gcc4.1 snapshot and glibc changes
* Mon Feb 06 2006 Florian La Roche <laroche@redhat.com>
- 4.6.1
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Thu Nov 03 2005 Than Ngo <than@redhat.com> 4.6-2
- fix wrong permission #171889
* Wed Oct 26 2005 Than Ngo <than@redhat.com> 4.6-1
- update to 4.6
* Mon Apr 11 2005 Than Ngo <than@redhat.com> 4.2.1-27
- apply debian patch to fix insecure temporary file creation
in unshar #154049, CAN-2005-0990
* Thu Mar 31 2005 Than Ngo <than@redhat.com> 4.2.1-26
- apply patch to fix multiple buffer overflows #152571
* Mon Mar 07 2005 Than Ngo <than@redhat.com> 4.2.1-25
- cleanup
* Sat Mar 05 2005 Than Ngo <than@redhat.com> 4.2.1-24
- rebuilt
* Wed Feb 09 2005 Than Ngo <than@redhat.com> 4.2.1-23
- rebuilt
* Fri Oct 01 2004 Than Ngo <than@redhat.com> 4.2.1-22
- fix buffer overflow in shar, (from Ulf Harnhammer)
* Thu Jun 24 2004 Than Ngo <than@redhat.com> 4.2.1-21
- add builrequires on gettext, bug #126599
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri May 21 2004 Than Ngo <than@redhat.com> 4.2.1-19
- add suse patch, which fixes buffer overflow in handling of -o option, #123230
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Mon Jun 16 2003 Than Ngo <than@redhat.com> 4.2.1-17
- rebuilt
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt
* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 4.2.1-13
- rebuild on all arches
* Mon Jun 24 2002 Than Ngo <than@redhat.com> 4.2.1-12
- fixed #66892
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Sun Apr 14 2002 Than Ngo <than@redhat.com> 4.2.1-9
- added fix for Unsecure outputfile handling in uudecode (#63303)
- Copyright -> License
* Fri May 11 2001 Than Ngo <than@redhat.com>
- use find_lang macro
- use mktemp
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Sun Jun 18 2000 Than Ngo <than@redhat.de>
- fix typo (Bug# 12447)
* Sun Jun 18 2000 Than Ngo <than@redhat.de>
- rebuilt in the new build environment
* Thu Jun 08 2000 Than Ngo <than@redhat.de>
- add %%defattr(-,root,root) (Bug# 11990)
- use rpm macros
* Sun May 21 2000 Ngo Than <than@redhat.de>
- rebuild to put man pages and info files in right place
* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
- rebuild to gzip man pages
* Tue Dec 21 1999 Preston Brown <pbrown@redhat.com>
- sharutils 4.2.1 for Y2K (2 digit date) fix.
- ja message catalog move (#7878)
* Tue Sep 7 1999 Jeff Johnson <jbj@redhat.com>
- handle spaces in uuencoded file names (David Fox <dsfox@cogsci.ucsd.edu>).
* Wed Jul 28 1999 Cristian Gafton <gafton@redhat.com>
- use the /usr/share/locale for the localedir instead of /usr/lib/locale
(#2998)
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- auto rebuild in the new build environment (release 12)
* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
- build for glibc 2.1
* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
- manhattan rebuild
* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
- ALRIGHT! Woo-hoo! Erik already did the install-info stuff!
- added BuildRoot
- spec file cleanups
* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
- uses install-info
* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
- built against glibc