a4f9def9dd
Signed-off-by: Björn Esser <besser82@fedoraproject.org>
59 lines
1.8 KiB
Diff
59 lines
1.8 KiB
Diff
From c93897a8d71b9b1790caf3b2dee38dbe62518ae3 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
|
Date: Thu, 24 Jun 2021 12:39:27 +0200
|
|
Subject: [PATCH] lib/defines.h: Include <crypt.h> if present on the system.
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
The functions crypt(3), crypt_gensalt(3), and their
|
|
feature test macros may be defined in there.
|
|
|
|
Signed-off-by: Björn Esser <besser82@fedoraproject.org>
|
|
---
|
|
configure.ac | 2 +-
|
|
lib/defines.h | 10 ++++++++++
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
Index: shadow-4.8.1/configure.ac
|
|
===================================================================
|
|
--- shadow-4.8.1.orig/configure.ac
|
|
+++ shadow-4.8.1/configure.ac
|
|
@@ -32,7 +32,7 @@ AC_HEADER_STDC
|
|
AC_HEADER_SYS_WAIT
|
|
AC_HEADER_STDBOOL
|
|
|
|
-AC_CHECK_HEADERS(errno.h fcntl.h limits.h unistd.h sys/time.h utmp.h \
|
|
+AC_CHECK_HEADERS(crypt.h errno.h fcntl.h limits.h unistd.h sys/time.h utmp.h \
|
|
utmpx.h termios.h termio.h sgtty.h sys/ioctl.h syslog.h paths.h \
|
|
utime.h ulimit.h sys/capability.h sys/resource.h gshadow.h lastlog.h \
|
|
locale.h rpc/key_prot.h netdb.h acl/libacl.h attr/libattr.h \
|
|
Index: shadow-4.8.1/lib/defines.h
|
|
===================================================================
|
|
--- shadow-4.8.1.orig/lib/defines.h
|
|
+++ shadow-4.8.1/lib/defines.h
|
|
@@ -4,6 +4,8 @@
|
|
#ifndef _DEFINES_H_
|
|
#define _DEFINES_H_
|
|
|
|
+#include "config.h"
|
|
+
|
|
#if HAVE_STDBOOL_H
|
|
# include <stdbool.h>
|
|
#else
|
|
@@ -94,6 +96,14 @@ char *strchr (), *strrchr (), *strtok ();
|
|
# include <unistd.h>
|
|
#endif
|
|
|
|
+/*
|
|
+ * crypt(3), crypt_gensalt(3), and their
|
|
+ * feature test macros may be defined in here.
|
|
+ */
|
|
+#if HAVE_CRYPT_H
|
|
+# include <crypt.h>
|
|
+#endif
|
|
+
|
|
#if TIME_WITH_SYS_TIME
|
|
# include <sys/time.h>
|
|
# include <time.h>
|