fbf9d3a3ea
Resolves: #1859252 - libsubid: creation and nsswitch support - Creation of subid and subid-devel subpackages - man: mention NSS in new[ug]idmap manpages - libsubid: move development header to shadow folder - libsubid: don't print error messages on stderr by default - libsubid: libsubid_init return false if out of memory - useradd: fix SUB_UID_COUNT=0 - libsubid: don't return owner in list_owner_ranges API call - libsubid: libsubid_init don't print messages on error - libsubid: fix newusers when nss provides subids - man: clarify subid delegation - libsubid: make shadow_logfd not extern - login.defs: include HMAC_CRYPTO_ALGO key
90 lines
4.4 KiB
Diff
90 lines
4.4 KiB
Diff
diff -up shadow-4.8.1/lib/getdef.c.login_defs_HMAC_CRYPTO_ALGO shadow-4.8.1/lib/getdef.c
|
|
--- shadow-4.8.1/lib/getdef.c.login_defs_HMAC_CRYPTO_ALGO 2021-06-24 15:55:32.960558932 +0200
|
|
+++ shadow-4.8.1/lib/getdef.c 2021-06-24 15:55:32.975559187 +0200
|
|
@@ -61,6 +61,7 @@ struct itemdef {
|
|
{"ENV_TZ", NULL}, \
|
|
{"FAILLOG_ENAB", NULL}, \
|
|
{"FTMP_FILE", NULL}, \
|
|
+ {"HMAC_CRYPTO_ALGO", NULL}, \
|
|
{"ISSUE_FILE", NULL}, \
|
|
{"LASTLOG_ENAB", NULL}, \
|
|
{"LOGIN_STRING", NULL}, \
|
|
diff -up shadow-4.8.1/man/login.defs.5.xml.login_defs_HMAC_CRYPTO_ALGO shadow-4.8.1/man/login.defs.5.xml
|
|
--- shadow-4.8.1/man/login.defs.5.xml.login_defs_HMAC_CRYPTO_ALGO 2021-06-24 15:55:32.929558405 +0200
|
|
+++ shadow-4.8.1/man/login.defs.5.xml 2021-06-24 15:55:32.975559187 +0200
|
|
@@ -50,6 +50,7 @@
|
|
<!ENTITY FAKE_SHELL SYSTEM "login.defs.d/FAKE_SHELL.xml">
|
|
<!ENTITY FTMP_FILE SYSTEM "login.defs.d/FTMP_FILE.xml">
|
|
<!ENTITY GID_MAX SYSTEM "login.defs.d/GID_MAX.xml">
|
|
+<!ENTITY HMAC_CRYPTO_ALGO SYSTEM "login.defs.d/HMAC_CRYPTO_ALGO.xml">
|
|
<!ENTITY HOME_MODE SYSTEM "login.defs.d/HOME_MODE.xml">
|
|
<!ENTITY HUSHLOGIN_FILE SYSTEM "login.defs.d/HUSHLOGIN_FILE.xml">
|
|
<!ENTITY ISSUE_FILE SYSTEM "login.defs.d/ISSUE_FILE.xml">
|
|
@@ -197,6 +198,7 @@
|
|
&FAKE_SHELL;
|
|
&FTMP_FILE;
|
|
&GID_MAX; <!-- documents also GID_MIN -->
|
|
+ &HMAC_CRYPTO_ALGO;
|
|
&HOME_MODE;
|
|
&HUSHLOGIN_FILE;
|
|
&ISSUE_FILE;
|
|
diff -up shadow-4.8.1/man/login.defs.d/HMAC_CRYPTO_ALGO.xml.login_defs_HMAC_CRYPTO_ALGO shadow-4.8.1/man/login.defs.d/HMAC_CRYPTO_ALGO.xml
|
|
--- shadow-4.8.1/man/login.defs.d/HMAC_CRYPTO_ALGO.xml.login_defs_HMAC_CRYPTO_ALGO 2021-06-24 15:55:32.975559187 +0200
|
|
+++ shadow-4.8.1/man/login.defs.d/HMAC_CRYPTO_ALGO.xml 2021-06-24 15:55:32.975559187 +0200
|
|
@@ -0,0 +1,44 @@
|
|
+<!--
|
|
+ Copyright (c) 1991 - 1993, Julianne Frances Haugh
|
|
+ Copyright (c) 1991 - 1993, Chip Rosenthal
|
|
+ Copyright (c) 2007 - 2008, Nicolas François
|
|
+ All rights reserved.
|
|
+
|
|
+ Redistribution and use in source and binary forms, with or without
|
|
+ modification, are permitted provided that the following conditions
|
|
+ are met:
|
|
+ 1. Redistributions of source code must retain the above copyright
|
|
+ notice, this list of conditions and the following disclaimer.
|
|
+ 2. Redistributions in binary form must reproduce the above copyright
|
|
+ notice, this list of conditions and the following disclaimer in the
|
|
+ documentation and/or other materials provided with the distribution.
|
|
+ 3. The name of the copyright holders or contributors may not be used to
|
|
+ endorse or promote products derived from this software without
|
|
+ specific prior written permission.
|
|
+
|
|
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
|
+ ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
|
+ LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
|
|
+ PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
|
+ HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
+ SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
|
+ LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
|
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
|
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
|
+ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+-->
|
|
+<varlistentry condition="no_pam">
|
|
+ <term><option>HMAC_CRYPTO_ALGO</option> (string)</term>
|
|
+ <listitem>
|
|
+ <para>
|
|
+ Used to select the HMAC cryptography algorithm that the pam_timestamp
|
|
+ module is going to use to calculate the keyed-hash message authentication
|
|
+ code.
|
|
+ </para>
|
|
+ <para>
|
|
+ Note: Check <refentrytitle>hmac</refentrytitle><manvolnum>3</manvolnum>
|
|
+ to see the possible algorithms that are available in your system.
|
|
+ </para>
|
|
+ </listitem>
|
|
+</varlistentry>
|
|
diff -up shadow-4.8.1/man/Makefile.am.login_defs_HMAC_CRYPTO_ALGO shadow-4.8.1/man/Makefile.am
|
|
--- shadow-4.8.1/man/Makefile.am.login_defs_HMAC_CRYPTO_ALGO 2021-06-24 15:55:32.975559187 +0200
|
|
+++ shadow-4.8.1/man/Makefile.am 2021-06-24 15:57:11.231229970 +0200
|
|
@@ -136,6 +136,7 @@ login_defs_v = \
|
|
FAKE_SHELL.xml \
|
|
FTMP_FILE.xml \
|
|
GID_MAX.xml \
|
|
+ HMAC_CRYPTO_ALGO.xml \
|
|
HUSHLOGIN_FILE.xml \
|
|
ISSUE_FILE.xml \
|
|
KILLCHAR.xml \
|