25 lines
1.1 KiB
Diff
25 lines
1.1 KiB
Diff
diff -up shadow-4.6/configure.ac.respect_enable_static_no shadow-4.6/configure.ac
|
|
--- shadow-4.6/configure.ac.respect_enable_static_no 2021-11-03 12:09:39.852829632 +0100
|
|
+++ shadow-4.6/configure.ac 2021-11-03 12:10:32.447203434 +0100
|
|
@@ -311,6 +311,8 @@ if test "$with_sha_crypt" = "yes"; then
|
|
AC_DEFINE(USE_SHA_CRYPT, 1, [Define to allow the SHA256 and SHA512 password encryption algorithms])
|
|
fi
|
|
|
|
+AM_CONDITIONAL(ENABLE_SHARED, test "x$enable_shared" = "xyes")
|
|
+
|
|
if test "$with_nscd" = "yes"; then
|
|
AC_CHECK_FUNC(posix_spawn,
|
|
[AC_DEFINE(USE_NSCD, 1, [Define to support flushing of nscd caches])],
|
|
diff -up shadow-4.6/libsubid/Makefile.am.respect_enable_static_no shadow-4.6/libsubid/Makefile.am
|
|
--- shadow-4.6/libsubid/Makefile.am.respect_enable_static_no 2021-11-03 12:09:39.851829625 +0100
|
|
+++ shadow-4.6/libsubid/Makefile.am 2021-11-03 12:09:39.852829632 +0100
|
|
@@ -1,6 +1,8 @@
|
|
lib_LTLIBRARIES = libsubid.la
|
|
+if ENABLE_SHARED
|
|
libsubid_la_LDFLAGS = -Wl,-soname,libsubid.so.@LIBSUBID_ABI@ \
|
|
-shared -version-info @LIBSUBID_ABI_MAJOR@
|
|
+endif
|
|
libsubid_la_SOURCES = api.c
|
|
|
|
pkginclude_HEADERS = subid.h
|