8ad38eb650
Close: rhbz#1906260 Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
diff -up shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt.orig shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt
|
|
--- shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt.orig 2020-01-22 21:15:53.000000000 +0100
|
|
+++ shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt 2020-02-02 21:06:15.193583552 +0100
|
|
@@ -102,18 +102,10 @@ endif(MSVC)
|
|
|
|
# Configure subdirectories.
|
|
# We depend on these for later projects, so they should come first.
|
|
-add_subdirectory(third_party)
|
|
|
|
add_subdirectory(libshaderc_util)
|
|
add_subdirectory(libshaderc)
|
|
add_subdirectory(glslc)
|
|
-add_subdirectory(examples)
|
|
-
|
|
-add_custom_target(build-version
|
|
- ${PYTHON_EXECUTABLE}
|
|
- ${CMAKE_CURRENT_SOURCE_DIR}/utils/update_build_version.py
|
|
- ${shaderc_SOURCE_DIR} ${spirv-tools_SOURCE_DIR} ${glslang_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR}/build-version.inc
|
|
- COMMENT "Update build-version.inc in the Shaderc build directory (if necessary).")
|
|
|
|
function(define_pkg_config_file NAME LIBS)
|
|
add_custom_target(${NAME}-pkg-config ALL
|