9ead6910de
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/shaderc.git#3b1492aaeff6bedab22ddfafdd47ca950d4d5c6a
25 lines
1.1 KiB
Diff
25 lines
1.1 KiB
Diff
diff -up shaderc-24275a11d81a6b33ef345878f8a4ef929c95a116/CMakeLists.txt.orig shaderc-24275a11d81a6b33ef345878f8a4ef929c95a116/CMakeLists.txt
|
|
--- shaderc-24275a11d81a6b33ef345878f8a4ef929c95a116/CMakeLists.txt.orig 2021-03-05 13:50:35.469018657 +0100
|
|
+++ shaderc-24275a11d81a6b33ef345878f8a4ef929c95a116/CMakeLists.txt 2021-03-05 13:52:02.679524176 +0100
|
|
@@ -112,20 +112,10 @@ endif(MSVC)
|
|
|
|
# Configure subdirectories.
|
|
# We depend on these for later projects, so they should come first.
|
|
-add_subdirectory(third_party)
|
|
|
|
add_subdirectory(libshaderc_util)
|
|
add_subdirectory(libshaderc)
|
|
add_subdirectory(glslc)
|
|
-if(${SHADERC_ENABLE_EXAMPLES})
|
|
- add_subdirectory(examples)
|
|
-endif()
|
|
-
|
|
-add_custom_target(build-version
|
|
- ${PYTHON_EXECUTABLE}
|
|
- ${CMAKE_CURRENT_SOURCE_DIR}/utils/update_build_version.py
|
|
- ${shaderc_SOURCE_DIR} ${spirv-tools_SOURCE_DIR} ${glslang_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR}/build-version.inc
|
|
- COMMENT "Update build-version.inc in the Shaderc build directory (if necessary).")
|
|
|
|
function(define_pkg_config_file NAME LIBS)
|
|
add_custom_target(${NAME}-pkg-config ALL
|