dos2unix'ed the patch

This commit is contained in:
Jan Synacek 2012-11-19 09:10:36 +01:00
parent ed0d3a7e7a
commit cc7218052b
2 changed files with 30 additions and 27 deletions

View File

@ -1,33 +1,33 @@
--- sgpio/Makefile.orig 2008-10-29 09:55:50.000000000 +0100
+++ sgpio/Makefile 2008-10-29 09:59:00.000000000 +0100
@@ -23,12 +23,15 @@
MANDIR ?= /usr/local/man
MANDIR ?= /usr/local/man
+SBIN_DIR = /sbin
+INSTALL =/usr/bin/install -c
ALL = sgpio
ALL = sgpio
+CFLAGS = -g -Wall
all: $(ALL)
sgpio.o: sgpio.c
- gcc -g -Wall -c sgpio.c
+ gcc $(CFLAGS) -c sgpio.c
sgpio: sgpio.o
gcc -g sgpio.o -o sgpio
@@ -38,10 +41,10 @@ clean:
install: $(ALL)
for i in $(ALL); do \
- install $$i /sbin/$$i; \
+ $(INSTALL) -D $$i $(SBIN_DIR)/$$i; \
done
- install -d $(MANDIR)/man1
- install -m 0644 *.1 $(MANDIR)/man1
all: $(ALL)
sgpio.o: sgpio.c
- gcc -g -Wall -c sgpio.c
+ gcc $(CFLAGS) -c sgpio.c
sgpio: sgpio.o
gcc -g sgpio.o -o sgpio
@@ -38,10 +41,10 @@ clean:
install: $(ALL)
for i in $(ALL); do \
- install $$i /sbin/$$i; \
+ $(INSTALL) -D $$i $(SBIN_DIR)/$$i; \
done
- install -d $(MANDIR)/man1
- install -m 0644 *.1 $(MANDIR)/man1
+ $(INSTALL) -d $(MANDIR)/man1
+ $(INSTALL) -m 0644 *.1 $(MANDIR)/man1
uninstall:
for i in $(ALL); do \
+ $(INSTALL) -m 0644 *.1 $(MANDIR)/man1
uninstall:
for i in $(ALL); do \

View File

@ -1,7 +1,7 @@
Summary: SGPIO captive backplane tool
Name: sgpio
Version: 1.2.0.10
Release: 8%{?dist}
Release: 9%{?dist}
License: GPLv2+
Group: System Environment/Base
URL: http://sources.redhat.com/lvm2/wiki/DMRAID_Eventing
@ -34,6 +34,9 @@ make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT SBIN_DIR=$RPM_BUI
%{_mandir}/man1/sgpio.*
%changelog
* Mon Nov 19 2012 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-9
- dos2unix'ed the patch
* Thu Aug 23 2012 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-8
- Improve spec