import sgpio-1.2.0.10-21.el8

This commit is contained in:
CentOS Sources 2021-03-09 08:11:35 +00:00 committed by Andrew Lukoshko
commit 9f09fff30d
5 changed files with 161 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/sgpio-1.2-0.10-src.tar.gz

1
.sgpio.metadata Normal file
View File

@ -0,0 +1 @@
dc5f0343a3e54ca91a97ecc100011196a0a7cfb7 SOURCES/sgpio-1.2-0.10-src.tar.gz

View File

@ -0,0 +1,16 @@
Assume buffer overflow even if it's not possible.
Found by coverity.
Author: Jan Synacek <jsynacek@redhat.com>
--- sgpio/sgpio.c.orig 2012-11-30 14:14:09.000000000 +0100
+++ sgpio/sgpio.c 2012-11-30 14:14:17.437228466 +0100
@@ -629,7 +629,7 @@
return -1;
}
- strcpy(location, sys_scsi_path);
+ strncpy(location, sys_scsi_path, FS_PATH_LEN);
len = strlen(location);
for(i=0;i<dir_qan;i++){

View File

@ -0,0 +1,39 @@
Fedora specific Makefile patch.
--- sgpio/Makefile 2008-11-24 12:27:12.000000000 +0100
+++ sgpio-new/Makefile 2018-02-26 11:32:14.394597823 +0100
@@ -23,25 +23,29 @@
MANDIR ?= /usr/local/man
+SBIN_DIR = /sbin
+INSTALL =/usr/bin/install -c
ALL = sgpio
+CFLAGS = -g -Wall
+LDFLAGS =
all: $(ALL)
sgpio.o: sgpio.c
- gcc -g -Wall -c sgpio.c
+ gcc $(CFLAGS) -c sgpio.c
sgpio: sgpio.o
- gcc -g sgpio.o -o sgpio
+ gcc $(LDFLAGS) sgpio.o -o sgpio
clean:
rm -f sgpio.o sgpio
install: $(ALL)
for i in $(ALL); do \
- install $$i /sbin/$$i; \
+ $(INSTALL) -D $$i $(SBIN_DIR)/$$i; \
done
- install -d $(MANDIR)/man1
- install -m 0644 *.1 $(MANDIR)/man1
+ $(INSTALL) -d $(MANDIR)/man1
+ $(INSTALL) -m 0644 *.1 $(MANDIR)/man1
uninstall:
for i in $(ALL); do \

104
SPECS/sgpio.spec Normal file
View File

@ -0,0 +1,104 @@
Summary: SGPIO captive backplane tool
Name: sgpio
Version: 1.2.0.10
Release: 21%{?dist}
License: GPLv2+
Group: System Environment/Base
URL: http://sources.redhat.com/lvm2/wiki/DMRAID_Eventing
Source: sgpio-1.2-0.10-src.tar.gz
# there is no official download link for the latest package
#Source: http://sources.redhat.com/lvm2/wiki/DMRAID_Eventing?action=AttachFile&do=get&target=sgpio-1.2.tgz
Patch0: sgpio-1.2-makefile.patch
Patch1: sgpio-1.2-coverity.patch
BuildRequires: dos2unix
%description
Intel SGPIO enclosure management utility
%prep
%setup -q -n sgpio
dos2unix --keepdate Makefile README
%patch0 -p1 -b .makefile
%patch1 -p1 -b .coverity
chmod a-x *
%build
#@@@ workaround for #474755 - remove with next update
make clean
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
%install
make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT SBIN_DIR=$RPM_BUILD_ROOT%{_sbindir} MANDIR=$RPM_BUILD_ROOT%{_mandir}
%files
%doc README
%{_sbindir}/sgpio
%{_mandir}/man1/sgpio.*
%changelog
* Mon Feb 26 2018 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-21
- use distribution LDFLAGS during build (#1548559)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0.10-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0.10-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0.10-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0.10-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0.10-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Fri Nov 30 2012 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-10
- Use strncpy instead of strcpy (coverity)
- Comment makefile patch
* Mon Nov 19 2012 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-9
- dos2unix'ed the patch
- Call dos2unix before patching and dos2unix Makefile as well
- Use %%{_sbindir} instead of '/sbin'
* Thu Aug 23 2012 Jan Synáček <jsynacek@redhat.com> - 1.2.0.10-8
- Improve spec
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jan 05 2012 Jan Synáček <jsynacek@redhat.com> 1.2.0.10-6
- Rebuilt for GCC 4.7
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.10-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Mon Jun 1 2009 Jiri Moskovcak <jmoskovc@redhat.com> 1.2.0.10-3
- rebuild for F12
* Tue Apr 14 2009 Jiri Moskovcak <jmoskovc@redhat.com> 1.2.0.10-2
- move the EOL conversion and the removal of
executable bits from %%install to %%prep section
* Wed Dec 10 2008 Jiri Moskovcak <jmoskovc@redhat.com> 1.2.0_10-1
- initial Fedora release