setroubleshoot-3.3.22-6.fc33
- Do not try to report a bug on None package (#1809801)
This commit is contained in:
parent
678fd233e3
commit
3242bcadb0
87
0012-Drop-updater.py-it-s-not-used-and-doesn-t-work.patch
Normal file
87
0012-Drop-updater.py-it-s-not-used-and-doesn-t-work.patch
Normal file
@ -0,0 +1,87 @@
|
|||||||
|
From fe8a0ac76b8ef52dda1a77e935eb96f0e3c5a33b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Petr Lautrbach <plautrba@redhat.com>
|
||||||
|
Date: Fri, 28 Feb 2020 18:28:34 +0100
|
||||||
|
Subject: [PATCH] Drop updater.py - it's not used and doesn't work
|
||||||
|
|
||||||
|
---
|
||||||
|
framework/po/POTFILES.in | 1 -
|
||||||
|
framework/src/Makefile.am | 1 -
|
||||||
|
framework/src/updater.py | 42 ---------------------------------------
|
||||||
|
3 files changed, 44 deletions(-)
|
||||||
|
delete mode 100644 framework/src/updater.py
|
||||||
|
|
||||||
|
diff --git a/framework/po/POTFILES.in b/framework/po/POTFILES.in
|
||||||
|
index 1ee587af3fe4..483999606950 100644
|
||||||
|
--- a/framework/po/POTFILES.in
|
||||||
|
+++ b/framework/po/POTFILES.in
|
||||||
|
@@ -17,7 +17,6 @@ src/setroubleshoot/rpc_interfaces.py
|
||||||
|
src/setroubleshoot/server.py
|
||||||
|
src/setroubleshoot/serverconnection.py
|
||||||
|
src/setroubleshoot/signature.py
|
||||||
|
-src/updater.py
|
||||||
|
src/setroubleshoot/util.py
|
||||||
|
src/setroubleshoot/uuid.py
|
||||||
|
src/seappletlegacy.c
|
||||||
|
diff --git a/framework/src/Makefile.am b/framework/src/Makefile.am
|
||||||
|
index bf53763b3084..9bf1d6384854 100644
|
||||||
|
--- a/framework/src/Makefile.am
|
||||||
|
+++ b/framework/src/Makefile.am
|
||||||
|
@@ -38,7 +38,6 @@ pkglibexec_SCRIPTS = \
|
||||||
|
pkgdir = $(datarootdir)/setroubleshoot
|
||||||
|
pkg_SCRIPTS = \
|
||||||
|
SetroubleshootFixit.py \
|
||||||
|
- updater.py \
|
||||||
|
SetroubleshootPrivileged.py
|
||||||
|
|
||||||
|
pkgconfig_DATA = \
|
||||||
|
diff --git a/framework/src/updater.py b/framework/src/updater.py
|
||||||
|
deleted file mode 100644
|
||||||
|
index 7aba95132a8a..000000000000
|
||||||
|
--- a/framework/src/updater.py
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,42 +0,0 @@
|
||||||
|
-#/usr/bin/env python
|
||||||
|
-
|
||||||
|
-# Author: Thomas Liu <tliu@redhat.com>
|
||||||
|
-import yum
|
||||||
|
-import gettext
|
||||||
|
-from setroubleshoot.config import parse_config_setting, get_config
|
||||||
|
-gettext.install(domain=get_config('general', 'i18n_text_domain'),
|
||||||
|
- localedir=get_config('general', 'i18n_locale_dir'))
|
||||||
|
-
|
||||||
|
-installed = []
|
||||||
|
-try:
|
||||||
|
- yb = yum.YumBase()
|
||||||
|
- yb.conf.cache = True
|
||||||
|
- installed = yb.rpmdb.searchNevra('selinux-policy')
|
||||||
|
- if installed:
|
||||||
|
- for pkg in sorted(installed):
|
||||||
|
- if pkg.name == 'selinux-policy':
|
||||||
|
- print(_("current: %s ") % pkg.printVer())
|
||||||
|
- try:
|
||||||
|
- pl = yb.doPackageLists(patterns=['selinux-policy'])
|
||||||
|
- except yum.Errors.RepoError as msg:
|
||||||
|
- yb.conf.cache = False
|
||||||
|
- pl = yb.doPackageLists(patterns=['selinux-policy'])
|
||||||
|
-
|
||||||
|
- if pl.available:
|
||||||
|
- for pkg in sorted(pl.available):
|
||||||
|
- print(_("newer: %s ") % pkg.printVer())
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-except yum.Errors.RepoError as msg:
|
||||||
|
- print("error: ", str(msg))
|
||||||
|
-
|
||||||
|
-except yum.Errors.ConfigError as msg:
|
||||||
|
- print("error: ", str(msg))
|
||||||
|
-
|
||||||
|
-except TypeError as msg:
|
||||||
|
- print("error: ", str(msg))
|
||||||
|
-except Exception as e:
|
||||||
|
- print("error: " + str(e))
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-print("done")
|
||||||
|
--
|
||||||
|
2.25.1
|
||||||
|
|
24
0013-sealert-Drop-unused-import-slib.dbus.service.patch
Normal file
24
0013-sealert-Drop-unused-import-slib.dbus.service.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From 8c48bbe8193ffdc788d040d2f7619654c452d71d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Petr Lautrbach <plautrba@redhat.com>
|
||||||
|
Date: Sat, 29 Feb 2020 13:28:13 +0100
|
||||||
|
Subject: [PATCH] sealert: Drop unused import slib.dbus.service
|
||||||
|
|
||||||
|
---
|
||||||
|
framework/src/sealert | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/framework/src/sealert b/framework/src/sealert
|
||||||
|
index 42dc976b26d0..7839367fd002 100755
|
||||||
|
--- a/framework/src/sealert
|
||||||
|
+++ b/framework/src/sealert
|
||||||
|
@@ -39,7 +39,6 @@ import selinux
|
||||||
|
import socket as Socket
|
||||||
|
import fcntl
|
||||||
|
import sys
|
||||||
|
-import slip.dbus.service
|
||||||
|
|
||||||
|
from dbus.mainloop.glib import DBusGMainLoop
|
||||||
|
DBusGMainLoop(set_as_default=True)
|
||||||
|
--
|
||||||
|
2.25.1
|
||||||
|
|
@ -0,0 +1,27 @@
|
|||||||
|
From b652a0e38e93cfb8fcb4e4a02c277cc25006eacb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Petr Lautrbach <plautrba@redhat.com>
|
||||||
|
Date: Wed, 4 Mar 2020 10:56:05 +0100
|
||||||
|
Subject: [PATCH] framework/browser: Do not try to report a bug on None package
|
||||||
|
|
||||||
|
There are cases when local_policy_package can be None. It's better to use
|
||||||
|
policy_rpm in these cases.
|
||||||
|
---
|
||||||
|
framework/src/setroubleshoot/browser.py | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/framework/src/setroubleshoot/browser.py b/framework/src/setroubleshoot/browser.py
|
||||||
|
index 4b1c143fac9a..1f6cae0b29f6 100644
|
||||||
|
--- a/framework/src/setroubleshoot/browser.py
|
||||||
|
+++ b/framework/src/setroubleshoot/browser.py
|
||||||
|
@@ -998,6 +998,8 @@ class BugReport:
|
||||||
|
content = text_buf.get_text(text_buf.get_start_iter(),
|
||||||
|
text_buf.get_end_iter(), False)
|
||||||
|
local_policy_package = get_rpm_source_package(self.alert.environment.local_policy_rpm)
|
||||||
|
+ if local_policy_package is None:
|
||||||
|
+ local_policy_package = self.alert.environment.policy_rpm
|
||||||
|
signature = report.createAlertSignature(local_policy_package,
|
||||||
|
"setroubleshoot",
|
||||||
|
self.alert.get_hash(),
|
||||||
|
--
|
||||||
|
2.25.1
|
||||||
|
|
@ -4,7 +4,7 @@
|
|||||||
Summary: Helps troubleshoot SELinux problems
|
Summary: Helps troubleshoot SELinux problems
|
||||||
Name: setroubleshoot
|
Name: setroubleshoot
|
||||||
Version: 3.3.22
|
Version: 3.3.22
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://pagure.io/setroubleshoot
|
URL: https://pagure.io/setroubleshoot
|
||||||
Source0: https://releases.pagure.org/setroubleshoot/%{name}-%{version}.tar.gz
|
Source0: https://releases.pagure.org/setroubleshoot/%{name}-%{version}.tar.gz
|
||||||
@ -22,6 +22,9 @@ Patch0008: 0008-Add-Local-SELinux-policy-package-version-to-analyses.patch
|
|||||||
Patch0009: 0009-Report-bug-on-a-package-which-owns-the-related-SELin.patch
|
Patch0009: 0009-Report-bug-on-a-package-which-owns-the-related-SELin.patch
|
||||||
Patch0010: 0010-Use-pydbus-a-modern-Python-dbus-API-for-Setroublesho.patch
|
Patch0010: 0010-Use-pydbus-a-modern-Python-dbus-API-for-Setroublesho.patch
|
||||||
Patch0011: 0011-root-user-doesn-t-need-to-use-SetroubleshootPrivileg.patch
|
Patch0011: 0011-root-user-doesn-t-need-to-use-SetroubleshootPrivileg.patch
|
||||||
|
Patch0012: 0012-Drop-updater.py-it-s-not-used-and-doesn-t-work.patch
|
||||||
|
Patch0013: 0013-sealert-Drop-unused-import-slib.dbus.service.patch
|
||||||
|
Patch0014: 0014-framework-browser-Do-not-try-to-report-a-bug-on-None.patch
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libcap-ng-devel
|
BuildRequires: libcap-ng-devel
|
||||||
BuildRequires: intltool gettext python3 python3-devel
|
BuildRequires: intltool gettext python3 python3-devel
|
||||||
@ -108,7 +111,7 @@ BuildRequires: python3-devel
|
|||||||
Requires: python3-slip-dbus systemd-python3 >= 206-1
|
Requires: python3-slip-dbus systemd-python3 >= 206-1
|
||||||
Requires: python3-gobject-base >= 3.11
|
Requires: python3-gobject-base >= 3.11
|
||||||
Requires: dbus
|
Requires: dbus
|
||||||
Requires: python3-dbus
|
Requires: python3-dbus python3-pydbus
|
||||||
Requires: polkit
|
Requires: polkit
|
||||||
Requires(pre): /usr/sbin/useradd /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/useradd /usr/sbin/groupadd
|
||||||
|
|
||||||
@ -177,7 +180,6 @@ chown -R setroubleshoot:setroubleshoot %{pkgvardatadir}
|
|||||||
%dir %{pkgdatadir}
|
%dir %{pkgdatadir}
|
||||||
%{pkgdatadir}/SetroubleshootFixit.py
|
%{pkgdatadir}/SetroubleshootFixit.py
|
||||||
%{pkgdatadir}/SetroubleshootPrivileged.py
|
%{pkgdatadir}/SetroubleshootPrivileged.py
|
||||||
%{pkgdatadir}/updater.py
|
|
||||||
%config(noreplace) %{pkgconfigdir}/%{name}.conf
|
%config(noreplace) %{pkgconfigdir}/%{name}.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.fedoraproject.Setroubleshootd.conf
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.fedoraproject.Setroubleshootd.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.fedoraproject.SetroubleshootPrivileged.conf
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.fedoraproject.SetroubleshootPrivileged.conf
|
||||||
@ -211,6 +213,9 @@ SELinux troubleshoot legacy applet
|
|||||||
%{_bindir}/seappletlegacy
|
%{_bindir}/seappletlegacy
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 4 2020 Petr Lautrbach <plautrba@redhat.com> - 3.3.22-6
|
||||||
|
- Do not try to report a bug on None package (#1809801)
|
||||||
|
|
||||||
* Fri Feb 28 2020 Petr Lautrbach <plautrba@redhat.com> - 3.3.22-5
|
* Fri Feb 28 2020 Petr Lautrbach <plautrba@redhat.com> - 3.3.22-5
|
||||||
- root user doesn't need to use SetroubleshootPrivileged API
|
- root user doesn't need to use SetroubleshootPrivileged API
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user