setroubleshoot-3.3.34

- data: update app icon
- Disable bug reporting, if libreport is not available
- Enable Georgian and Arabic (ar) languages in configure.ac
- Update translations

Resolves: RHEL-65790
This commit is contained in:
Petr Lautrbach 2024-11-06 08:14:14 +01:00
parent 4088c1e70a
commit 14fb87bd94
6 changed files with 10 additions and 2026 deletions

1
.gitignore vendored
View File

@ -218,3 +218,4 @@ setroubleshoot-2.2.93.tar.gz
/setroubleshoot-3.3.31.tar.gz
/setroubleshoot-3.3.32.tar.gz
/setroubleshoot-3.3.33.tar.gz
/setroubleshoot-3.3.34.tar.gz

View File

@ -1,36 +0,0 @@
From dce909e06ba1471d5bbc2174bd7672be684bdf64 Mon Sep 17 00:00:00 2001
From: Petr Lautrbach <lautrbach@redhat.com>
Date: Mon, 3 Jun 2024 15:44:28 +0200
Subject: [PATCH] gitlab-ci: fix Fedora and Debian build requirements
Content-type: text/plain
Signed-off-by: Petr Lautrbach <lautrbach@redhat.com>
---
.gitlab-ci.yml | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index bea5081bb0b9..f316357a9164 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -31,6 +31,7 @@ build:debian:
apt-get -y install autoconf automake libglib2.0-dev libdbus-glib-1-dev libnotify-dev
libgtk-3-dev gcc python3-selinux python3-gi python3-dbus python3-six python3-sepolicy
xdg-utils make intltool libaudit-dev libauparse-dev python3-pip python3-dasbus
+ python3-setuptools
- ./autogen.sh
- make
- make install
@@ -44,7 +45,8 @@ build:fedora:
dnf -y install make gcc automake autoconf libcap-ng-devel intltool gettext
python3 python3-devel desktop-file-utils dbus-glib-devel gtk2-devel libnotify-devel
audit-libs-devel libselinux-devel polkit-devel python3-libselinux python3-dasbus
- python3-gobject gtk3-devel xdg-utils intltool gettext python3 python3-devel
+ python3-gobject gtk3-devel xdg-utils intltool gettext
+ python3-setuptools python3-wheel python3-pip
- ./autogen.sh
- make
- make install
--
2.44.0

File diff suppressed because it is too large Load Diff

View File

@ -1,62 +0,0 @@
From e72f22bac65ed67849d8df28b7119c76df077c67 Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Thu, 22 Aug 2024 12:14:53 +0200
Subject: [PATCH] Disable bug reporting, if libreport is not available
libreport doesn't support JIRA, so it won't be in RHEL.
Resolves: RHEL-52902
Signed-off-by: Michal Srb <michal@redhat.com>
---
src/setroubleshoot/browser.py | 20 ++++++++++++++------
1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/src/setroubleshoot/browser.py b/src/setroubleshoot/browser.py
index c98b075..33272db 100644
--- a/src/setroubleshoot/browser.py
+++ b/src/setroubleshoot/browser.py
@@ -64,10 +64,17 @@ from setroubleshoot.util import *
from setroubleshoot.html_util import html_to_text
import re
import dbus
-import report
-import report.io
-import report.io.GTKIO
-import report.accountmanager
+
+has_libreport = False
+try:
+ import report
+ import report.io
+ import report.io.GTKIO
+ import report.accountmanager
+ has_libreport = True
+except ImportError:
+ # Bug reporting won't be available
+ pass
from gi.repository import Gio
@@ -278,7 +285,8 @@ class BrowserApplet:
self.make_treeview()
self.troubleshoot_visible = False
self.current_alert = -1
- self.accounts = report.accountmanager.AccountManager()
+ if has_libreport:
+ self.accounts = report.accountmanager.AccountManager()
def get_current_alert(self):
try:
@@ -541,7 +549,7 @@ class BrowserApplet:
report_button.connect("clicked", self.fix_bug, alert.local_id, plugin.analysis_id)
vbox.add(report_button)
- elif plugin.report_bug:
+ elif plugin.report_bug and has_libreport:
report_button = Gtk.Button()
report_button.set_label(_("Report\nBug"))
report_button.show()
--
2.46.0

View File

@ -5,8 +5,8 @@
Summary: Helps troubleshoot SELinux problems
Name: setroubleshoot
Version: 3.3.33
Release: 5.1%{?dist}
Version: 3.3.34
Release: 1%{?dist}
License: GPL-2.0-or-later
URL: https://gitlab.com/setroubleshoot/setroubleshoot
Source0: https://gitlab.com/setroubleshoot/setroubleshoot/-/archive/%{version}/setroubleshoot-%{version}.tar.gz
@ -14,9 +14,6 @@ Source1: %{name}.tmpfiles
Source2: %{name}.sysusers
# git format-patch -N 3.3.33
# i=1; for j in 00*patch; do printf "Patch%04d: %s\n" $i $j; i=$((i+1));done
Patch0001: 0001-gitlab-ci-fix-Fedora-and-Debian-build-requirements.patch
Patch0002: 0002-data-update-app-icon.patch
Patch0003: 0003-disable-bug-reporting-if-libreport-is-not-available.patch
BuildRequires: gcc
BuildRequires: make
BuildRequires: libcap-ng-devel
@ -199,6 +196,12 @@ to user preference. The same tools can be run on existing log files.
%doc AUTHORS COPYING ChangeLog DBUS.md NEWS README TODO
%changelog
* Mon Nov 04 2024 Petr Lautrbach <lautrbach@redhat.com> - 3.3.34-1
- data: update app icon
- Disable bug reporting, if libreport is not available
- Enable Georgian and Arabic (ar) languages in configure.ac
- Update translations
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 3.3.33-5.1
- Bump release for October 2024 mass rebuild:
Resolves: RHEL-64018

View File

@ -1 +1,2 @@
SHA512 (setroubleshoot-3.3.33.tar.gz) = d70af05d1259b2b5c48f15a47e656865f2c0eb1d09a2441e651089914128340a0ac56cb5d40bd2b66bf64a25bf630086b7b11ae726d9e152257bc2e4a47b9c45
SHA512 (setroubleshoot-3.3.34.tar.gz) = fde36a45ab25dd1e48364488ea725372ab0fafe416ac693b94347d750a7e474451be7db58952aaf297601aa767517dea85334c3d5dd0e17be7206d7b4418bf9f