a7fa5b8401
Fri Apr 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3-1 - Fix doc location Fri Apr 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3-1 - Latest from TRESYS Tue Apr 13 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-8 - fix location of policy.conf file Tue Apr 06 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-7 - Obsolete setools-devel Tue Apr 06 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-6 - Fix location of Tue Apr 06 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-5 - Remove devel libraries - Fix installdir for lib64 Sat Apr 03 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-4 - Add usr_t file read to policy Thu Mar 25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.1-3 - Use tcl8.4
170 lines
5.4 KiB
Diff
170 lines
5.4 KiB
Diff
--- setools-1.3/policy/seuser.te.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/policy/seuser.te 2004-04-16 08:11:13.510100184 -0400
|
|
@@ -54,7 +54,7 @@
|
|
allow seuser_t locale_t:dir { search};
|
|
allow seuser_t { var_run_t var_t}:dir search;
|
|
|
|
-allow seuser_t usr_t:dir { search };
|
|
+r_dir_file(seuser_t, usr_t)
|
|
allow seuser_t shlib_t:file { read getattr execute};
|
|
allow seuser_t shlib_t:lnk_file { read };
|
|
allow seuser_t shlib_t:dir {search};
|
|
--- setools-1.3/secmds/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/secmds/Makefile 2004-04-16 08:30:10.564241680 -0400
|
|
@@ -42,7 +42,7 @@
|
|
|
|
install: $(SE_CMDS)
|
|
install -m 755 $(SE_CMDS) $(BINDIR);
|
|
- chcon system_u:object_r:setfiles_exec_t $(BINDIR)/replcon
|
|
+# chcon system_u:object_r:setfiles_exec_t $(BINDIR)/replcon
|
|
|
|
%.o: %.c
|
|
$(CC) $(CFLAGS) $(INCLUDE) -c $<
|
|
--- setools-1.3/libseuser/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/libseuser/Makefile 2004-04-16 08:11:13.523098208 -0400
|
|
@@ -11,6 +11,10 @@
|
|
|
|
libseuser-tcl: ../lib/libseuser-tcl.a
|
|
|
|
+install: libseuser libseuser-tcl
|
|
+ install -m 644 ../lib/libseuser.a $(INSTALL_LIBDIR)
|
|
+ install -m 644 *.h $(INCLUDEDIR)
|
|
+
|
|
../lib/libseuser.a: ../lib $(LIB-OBJ)
|
|
ar cr $@ $(LIB-OBJ)
|
|
|
|
@@ -20,7 +24,7 @@
|
|
%.o: %.c
|
|
$(CC) $(CFLAGS) -c $<
|
|
|
|
-
|
|
+
|
|
../lib:
|
|
mkdir -p $@
|
|
|
|
--- setools-1.3/packages/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/packages/Makefile 2004-04-16 08:48:43.045118880 -0400
|
|
@@ -3,11 +3,13 @@
|
|
# by Kevin Carr kcarr@tresys.com
|
|
|
|
# Make sure INSTALL_PATH is set properly for your system!
|
|
-INSTALL_PATH=/usr/share/tcl8.3/
|
|
+TCLVER = $(shell env tclsh ../tcl_vars version)
|
|
+INSTALL_PATH=$(DESTDIR)/usr/share/tcl$(TCLVER)/
|
|
|
|
|
|
install:
|
|
- tar -zxvf BWidget-1.4.1.tar.gz
|
|
+ mkdir -p $(INSTALL_PATH)
|
|
+ tar -zxf BWidget-1.4.1.tar.gz
|
|
mv BWidget-1.4.1 $(INSTALL_PATH)
|
|
|
|
remove:
|
|
@@ -20,4 +22,4 @@
|
|
rm -rf BWidget-1.4.1/
|
|
|
|
bare:
|
|
- clean
|
|
\ No newline at end of file
|
|
+ clean
|
|
--- setools-1.3/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/Makefile 2004-04-16 08:44:10.811504680 -0400
|
|
@@ -21,7 +21,7 @@
|
|
# File location defaults; used in various places in code
|
|
# Change these if you want different defaults
|
|
POLICY_SRC_DIR = $(DESTDIR)/etc/security/selinux/src
|
|
-POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy.conf
|
|
+POLICY_SRC_FILE = $(POLICY_SRC_DIR)/policy/policy.conf
|
|
DEFAULT_LOG_FILE = /var/log/messages
|
|
|
|
# Compile options
|
|
@@ -83,6 +83,8 @@
|
|
@echo " install-seuserx: build and install seuser and seuserx (selinux required)"
|
|
@echo " install-secmds: build and install command line tools (selinux not required)"
|
|
@echo " install-seaudit: build and install seaudit (selinux not required)"
|
|
+ @echo " install-bwidget: build and install BWidget (selinux not required)"
|
|
+ @echo " install-libraries: build and install libraries"
|
|
@echo " "
|
|
@echo " all: build everything, but don't install"
|
|
@echo " all-nogui: only build non-GUI tools and libraries"
|
|
@@ -116,7 +118,7 @@
|
|
echo "Could not build awish."; \
|
|
echo "Tcl library is not built or not in expected location(s)."; \
|
|
fi
|
|
-
|
|
+
|
|
seuser: selinux_tool
|
|
cd seuser; $(MAKE) seuser
|
|
|
|
@@ -137,9 +139,9 @@
|
|
|
|
secmds: selinux_tool
|
|
cd secmds; $(MAKE) all
|
|
-
|
|
+
|
|
libapol: selinux_tool
|
|
- cd libapol; $(MAKE) libapol
|
|
+ cd libapol; $(MAKE) libapol
|
|
|
|
libapol-tcl: selinux_tool
|
|
cd libapol;
|
|
@@ -186,6 +188,15 @@
|
|
echo "Tcl library is not built or not in expected location(s)."; \
|
|
fi
|
|
|
|
+install-libseuser:
|
|
+ cd libseuser; $(MAKE) install
|
|
+
|
|
+install-libapol:
|
|
+ cd libapol; $(MAKE) install INSTALL_HELPDIR=$(INSTALL_HELPDIR)
|
|
+
|
|
+install-libraries: install-libseuser install-libapol
|
|
+ cd libseuser; $(MAKE) install
|
|
+
|
|
# installs both GUI and non-GUI versions
|
|
install-seuserx: $(INSTALL_LIBDIR)
|
|
cd seuser;
|
|
@@ -211,8 +222,14 @@
|
|
|
|
install-nogui: $(INSTALL_LIBDIR) install-seuser install-secmds
|
|
|
|
+install-bwidget:
|
|
+ cd packages; make
|
|
+
|
|
+install-docs: docs
|
|
+ install -m 755 -d $(INSTALL_HELPDIR)
|
|
+ cd docs-src; $(MAKE) install INSTALL_HELPDIR=$(INSTALL_HELPDIR)
|
|
|
|
-install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit
|
|
+install: install-apol install-seuserx install-sepcut install-awish install-secmds install-seaudit install-bwidget install-docs
|
|
|
|
# Next four targets are to support installation as part of a system
|
|
# install. These targets are deprecated.
|
|
--- setools-1.3/docs-src/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/docs-src/Makefile 2004-04-16 08:11:13.549094256 -0400
|
|
@@ -55,3 +55,14 @@
|
|
for file in $(TOP-DOCS); do \
|
|
rm -f ../$$file; \
|
|
done
|
|
+
|
|
+install:
|
|
+ for file in KNOWN-BUGS README; do \
|
|
+ cat $$file.in | sed -e 's/RELEASE_VERSION/$(shell cat ../VERSION)/g' | \
|
|
+ sed -e 's/MOD_DATE/$(shell date '+%B %d, %G')/g' > ${INSTALL_HELPDIR}/$$file; \
|
|
+ done
|
|
+ install -m 644 ../seaudit/seaudit_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../seuser/seuser_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../sepct/sepcut_help.txt ${INSTALL_HELPDIR}
|
|
+ install -m 644 ../apol/*.txt ${INSTALL_HELPDIR}
|
|
+
|
|
--- setools-1.3/apol/Makefile.rhat 2004-04-15 18:50:22.000000000 -0400
|
|
+++ setools-1.3/apol/Makefile 2004-04-16 08:11:13.562092280 -0400
|
|
@@ -55,6 +55,7 @@
|
|
done \
|
|
fi
|
|
install -m 644 apol.tcl $(APOL_HELP_FILES) $(APOL_PERM_MAPS) $(INSTALL_LIBDIR)
|
|
+ install -m 644 $(APOL_HELP_FILES) $(APOL_PERM_MAPS) ${INSTALL_HELPDIR}
|
|
cd $(INSTALL_LIBDIR); ln -sf $(APOL_DFLT_PMAP) apol_perm_mapping
|
|
|
|
clean:
|