7a283c335f
- Revised sediff method for TE rules. This drastically reduced memory and run time. - Added infiniband context support to seinfo, sediff, and apol. - Added apol configuration for location of Qt assistant. - Fixed sediff issue where properties header would display when not requested. - Fixed sediff issue with type_transition file name comparison. - Fixed permission map socket sendto information flow direction. - Added methods to TypeAttribute class to make it a complete Python collection. - Genfscon now will look up classes rather than using fixed values which were dropped from libsepol.
25 lines
765 B
Diff
25 lines
765 B
Diff
From a2faa263c9dd8bcf51465861046e0406a84975c0 Mon Sep 17 00:00:00 2001
|
|
From: Petr Lautrbach <plautrba@redhat.com>
|
|
Date: Thu, 2 Apr 2020 16:06:14 +0200
|
|
Subject: [PATCH] Require networkx on package level
|
|
|
|
It allows us to ship python3-setools without dependency on python3-networkx
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 457c83049ca5..4bfd438002bb 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -170,5 +170,5 @@ setup(name='setools',
|
|
# setup also requires libsepol and libselinux
|
|
# C libraries and headers to compile.
|
|
setup_requires=['setuptools', 'Cython>=0.27'],
|
|
- install_requires=['setuptools', 'networkx>=2.0']
|
|
+ install_requires=['setuptools']
|
|
)
|
|
--
|
|
2.26.0.rc2
|
|
|