Do not use -Werror during build
There are new warnings when setools are built with gcc 7 therefore we want to suppress -Werror for now Fixes: libqpol/policy_extend.c: In function ‘policy_extend’: libqpol/policy_extend.c:161:27: error: ‘%04zd’ directive output may be truncated writing between 4 and 10 bytes into a region of size 5 [-Werror=format-truncation=] snprintf(buff, 9, "@ttr%04zd", i + 1); ^~~~~ libqpol/policy_extend.c:161:22: note: directive argument in the range [1, 4294967295] snprintf(buff, 9, "@ttr%04zd", i + 1); ^~~~~~~~~~~ In file included from /usr/include/stdio.h:939:0, from /usr/include/sepol/policydb/policydb.h:53, from libqpol/policy_extend.c:29: /usr/include/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 9 and 15 bytes into a destination of size 9 return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ __bos (__s), __fmt, __va_arg_pack ()); ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors error: command 'gcc' failed with exit status 1
This commit is contained in:
parent
442c972d4b
commit
fdd5e434b3
49
0001-Do-not-use-Werror-during-build.patch
Normal file
49
0001-Do-not-use-Werror-during-build.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
From 617c3ae83c1c72ead627a57e1529724c62df807f Mon Sep 17 00:00:00 2001
|
||||||
|
From: rpm-build <rpm-build>
|
||||||
|
Date: Thu, 23 Feb 2017 08:17:07 +0100
|
||||||
|
Subject: [PATCH 1/2] Do not use -Werror during build
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
There are new warnings when setools are built with gcc 7 therefore we
|
||||||
|
want to suppress -Werror for now
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
libqpol/policy_extend.c: In function ‘policy_extend’:
|
||||||
|
libqpol/policy_extend.c:161:27: error: ‘%04zd’ directive output may be truncated writing between 4 and 10 bytes into a region of size 5 [-Werror=format-truncation=]
|
||||||
|
snprintf(buff, 9, "@ttr%04zd", i + 1);
|
||||||
|
^~~~~
|
||||||
|
libqpol/policy_extend.c:161:22: note: directive argument in the range [1, 4294967295]
|
||||||
|
snprintf(buff, 9, "@ttr%04zd", i + 1);
|
||||||
|
^~~~~~~~~~~
|
||||||
|
In file included from /usr/include/stdio.h:939:0,
|
||||||
|
from /usr/include/sepol/policydb/policydb.h:53,
|
||||||
|
from libqpol/policy_extend.c:29:
|
||||||
|
/usr/include/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 9 and 15 bytes into a destination of size 9
|
||||||
|
return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
|
||||||
|
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
__bos (__s), __fmt, __va_arg_pack ());
|
||||||
|
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
cc1: all warnings being treated as errors
|
||||||
|
error: command 'gcc' failed with exit status 1
|
||||||
|
---
|
||||||
|
setup.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 4e7645c..f697ed7 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -145,7 +145,7 @@ ext_py_mods = [Extension('setools.policyrep._qpol',
|
||||||
|
'libqpol/policy_scan.c',
|
||||||
|
'libqpol/xen_query.c'],
|
||||||
|
include_dirs=include_dirs,
|
||||||
|
- extra_compile_args=['-Werror', '-Wextra',
|
||||||
|
+ extra_compile_args=['-Wextra',
|
||||||
|
'-Waggregate-return',
|
||||||
|
'-Wcast-align',
|
||||||
|
'-Wfloat-equal',
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
@ -19,6 +19,7 @@ URL: https://github.com/TresysTechnology/setools/wiki
|
|||||||
Source0: https://github.com/TresysTechnology/setools/archive/%{version}%{?setools_pre_ver:-%{setools_pre_ver}}.tar.gz
|
Source0: https://github.com/TresysTechnology/setools/archive/%{version}%{?setools_pre_ver:-%{setools_pre_ver}}.tar.gz
|
||||||
Source1: setools.pam
|
Source1: setools.pam
|
||||||
Source2: apol.desktop
|
Source2: apol.desktop
|
||||||
|
Patch1: 0001-Do-not-use-Werror-during-build.patch
|
||||||
|
|
||||||
Obsoletes: setools < 4.0.0, setools-devel < 4.0.0
|
Obsoletes: setools < 4.0.0, setools-devel < 4.0.0
|
||||||
BuildRequires: flex, bison
|
BuildRequires: flex, bison
|
||||||
@ -86,7 +87,6 @@ Python modules designed to facilitate SELinux policy analysis.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p 1 -S git
|
%autosetup -p 1 -S git
|
||||||
sed -i "s%'-Werror', '-Wextra'%'-Wextra'%" setup.py
|
|
||||||
|
|
||||||
cp -a ../setools-%{version}%{?setools_pre_ver:-%{setools_pre_ver}} ../setools-%{version}%{?setools_pre_ver:-%{setools_pre_ver}}-python2
|
cp -a ../setools-%{version}%{?setools_pre_ver:-%{setools_pre_ver}} ../setools-%{version}%{?setools_pre_ver:-%{setools_pre_ver}}-python2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user