Add 0012-Fix-configure.ac-to-use-SWIG-3.0.0.patch
This commit is contained in:
parent
f346ebaaf7
commit
ed27604c5e
51
0012-Fix-configure.ac-to-use-SWIG-3.0.0.patch
Normal file
51
0012-Fix-configure.ac-to-use-SWIG-3.0.0.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
From 9fbf625c8606ff4a51d3d797b002bbf698592154 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Miroslav Grepl <mgrepl@redhat.com>
|
||||||
|
Date: Sun, 13 Apr 2014 20:58:14 +0200
|
||||||
|
Subject: [PATCH] Fix configure.ac to use SWIG-3.0.0
|
||||||
|
|
||||||
|
---
|
||||||
|
configure.ac | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 5b1da5e..11c0e3e 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -194,7 +194,7 @@ AC_ARG_ENABLE(swig-java,
|
||||||
|
enable_jswig="$enableval")
|
||||||
|
if test "x${enable_jswig}" = xyes; then
|
||||||
|
if test ${do_swigify} = no; then
|
||||||
|
- AC_PROG_SWIG(2.0.0)
|
||||||
|
+ AC_PROG_SWIG(3.0.0)
|
||||||
|
fi
|
||||||
|
AC_JAVA_OPTIONS
|
||||||
|
if test "x$JAVAPREFIX" = x; then
|
||||||
|
@@ -225,14 +225,14 @@ AC_ARG_ENABLE(swig-python,
|
||||||
|
enable_pyswig="$enableval")
|
||||||
|
if test "x${enable_pyswig}" = xyes; then
|
||||||
|
if test ${do_swigify} = no; then
|
||||||
|
- AC_PROG_SWIG(2.0.0)
|
||||||
|
+ AC_PROG_SWIG(3.0.0)
|
||||||
|
fi
|
||||||
|
SWIG_PYTHON
|
||||||
|
do_swigify_python=yes
|
||||||
|
do_swigify=yes
|
||||||
|
fi
|
||||||
|
if test ${do_swigify} = "yes"; then
|
||||||
|
- AC_PROG_SWIG(2.0.0)
|
||||||
|
+ AC_PROG_SWIG(3.0.0)
|
||||||
|
fi
|
||||||
|
build_apol=yes
|
||||||
|
AC_ARG_ENABLE(swig-tcl,
|
||||||
|
@@ -241,7 +241,7 @@ AC_ARG_ENABLE(swig-tcl,
|
||||||
|
enable_tclswig="$enableval", enable_tclswig="yes")
|
||||||
|
if test "x${enable_tclswig}" = xyes; then
|
||||||
|
if test ${do_swigify} = no; then
|
||||||
|
- AC_PROG_SWIG(2.0.0)
|
||||||
|
+ AC_PROG_SWIG(3.0.0)
|
||||||
|
fi
|
||||||
|
TEA_INIT(3.5)
|
||||||
|
TEA_PATH_TCLCONFIG
|
||||||
|
--
|
||||||
|
1.8.5.3
|
||||||
|
|
@ -22,6 +22,7 @@ Patch8: 0008-Add-alias-support-to-seinfo-t.patch
|
|||||||
Patch9: 0009-Fix-help-message-on-sesearch-D.patch
|
Patch9: 0009-Fix-help-message-on-sesearch-D.patch
|
||||||
Patch10: 0010-Apply-swig-patch-to-make-apol-work-again.patch
|
Patch10: 0010-Apply-swig-patch-to-make-apol-work-again.patch
|
||||||
Patch11: 0011-Fix-Wformat-security-issues.patch
|
Patch11: 0011-Fix-Wformat-security-issues.patch
|
||||||
|
Patch12: 0012-Fix-configure.ac-to-use-SWIG-3.0.0.patch
|
||||||
|
|
||||||
Summary: Policy analysis tools for SELinux
|
Summary: Policy analysis tools for SELinux
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -34,7 +35,7 @@ Requires: setools-libs = %{version}-%{release} setools-libs-tcl = %{version}-%{r
|
|||||||
%define sepol_ver 2.1.8-5
|
%define sepol_ver 2.1.8-5
|
||||||
%define selinux_ver 2.1.12-10
|
%define selinux_ver 2.1.12-10
|
||||||
%define sqlite_ver 3.2.0
|
%define sqlite_ver 3.2.0
|
||||||
%define swig_ver 2.0.7-3
|
%define swig_ver 3.0.0
|
||||||
%define tcltk_ver 8.4.9
|
%define tcltk_ver 8.4.9
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -160,13 +161,15 @@ This package includes the following graphical tools:
|
|||||||
%patch9 -p 1 -b .sesearch-D
|
%patch9 -p 1 -b .sesearch-D
|
||||||
%patch10 -p 1 -b .wig-patch
|
%patch10 -p 1 -b .wig-patch
|
||||||
%patch11 -p 1 -b .Wformat-security
|
%patch11 -p 1 -b .Wformat-security
|
||||||
|
%patch12 -p 1 -b .version
|
||||||
|
|
||||||
%ifarch sparc sparcv9 sparc64 s390 s390x
|
%ifarch sparc sparcv9 sparc64 s390 s390x
|
||||||
for file in `find . -name Makefile.am`; do
|
for file in `find . -name Makefile.am`; do
|
||||||
sed -i -e 's:-fpic:-fPIC:' $file;
|
sed -i -e 's:-fpic:-fPIC:' $file;
|
||||||
done
|
done
|
||||||
%endif
|
%endif
|
||||||
# Fixup expected version of SWIG:
|
# Fixup expected version of SWIG:
|
||||||
sed -i -e "s|AC_PROG_SWIG(1.3.28)|AC_PROG_SWIG(2.0.0)|g" configure.ac
|
sed -i -e "s|AC_PROG_SWIG(1.3.28)|AC_PROG_SWIG(3.0.0)|g" configure.ac
|
||||||
# and rebuild the autotooled files:
|
# and rebuild the autotooled files:
|
||||||
aclocal
|
aclocal
|
||||||
autoreconf -if
|
autoreconf -if
|
||||||
|
Loading…
Reference in New Issue
Block a user