- Update to upstream
This commit is contained in:
parent
b78fe8b71b
commit
e3cde34ed8
@ -1,20 +1,135 @@
|
|||||||
--- setools-2.3/Makefile.rhat 2006-01-23 10:58:42.000000000 -0500
|
--- setools-3.0/Makefile.am.rhat 2006-10-04 12:15:08.000000000 -0400
|
||||||
+++ setools-2.3/Makefile 2006-01-31 16:18:43.000000000 -0500
|
+++ setools-3.0/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
@@ -12,7 +12,7 @@
|
@@ -9,6 +9,7 @@
|
||||||
PREFIX ?= $(DESTDIR)/usr
|
SUBDIRS = libqpol libapol libpoldiff libsefs libseaudit secmds sechecker sediff man $(MAYBE_GUI) $(MAYBE_BWIDGET)
|
||||||
|
|
||||||
INCLUDE_DIR = $(PREFIX)/include
|
EXTRA_DIST = VERSION KNOWN-BUGS
|
||||||
-SHARED_LIB_INSTALL_DIR = $(PREFIX)/lib
|
+doc_DATA = KNOWN-BUGS README
|
||||||
+SHARED_LIB_INSTALL_DIR = $(DESTDIR)$(LIBDIR)
|
|
||||||
STATIC_LIB_INSTALL_DIR = $(SHARED_LIB_INSTALL_DIR)
|
libqpol:
|
||||||
#SETOOLS_INCLUDE = $(INCLUDE_DIR)/setools-$(SETOOLS_VER)
|
$(MAKE) -C $(top_srcdir)/libqpol
|
||||||
TCLVER = $(shell env tclsh tcl_vars)
|
--- setools-3.0/sechecker/Makefile.am.rhat 2006-10-04 12:14:44.000000000 -0400
|
||||||
@@ -37,7 +37,7 @@
|
+++ setools-3.0/sechecker/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
# instead of "/usr/share/setools/". This probably needs to become more
|
@@ -1,7 +1,7 @@
|
||||||
# robust in the future.
|
setoolsdir = @setoolsdir@
|
||||||
#
|
bin_PROGRAMS = sechecker
|
||||||
-INSTALL_LIBDIR = $(PREFIX)/share/setools-$(SETOOLS_VER)
|
|
||||||
+INSTALL_LIBDIR = $(PREFIX)/share/setools
|
-dist_setools_DATA = \
|
||||||
# all apps that have a te/fc file need to be listed here
|
+doc_DATA = \
|
||||||
POLICYINSTALLDIRS =
|
sechecker_help.txt
|
||||||
# Help files here
|
|
||||||
|
profilesdir = @profile_install_dir@
|
||||||
|
--- setools-3.0/seaudit/Makefile.am.rhat 2006-10-06 15:14:34.000000000 -0400
|
||||||
|
+++ setools-3.0/seaudit/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
|
@@ -10,6 +10,9 @@
|
||||||
|
@GTK_LIBS@ @GLADE_LIBS@ @XML_LIBS@ -rdynamic
|
||||||
|
LDADD = @SELINUX_LIB_FLAG@ $(top_builddir)/libseaudit/libseaudit.a @APOL_LIB_FLAG@ @QPOL_LIB_FLAG@
|
||||||
|
|
||||||
|
+doc_DATA = \
|
||||||
|
+ seaudit_help.txt
|
||||||
|
+
|
||||||
|
dist_setools_DATA = \
|
||||||
|
customize_filter_window.glade \
|
||||||
|
filter_window.glade \
|
||||||
|
@@ -18,7 +21,6 @@
|
||||||
|
query_window.glade \
|
||||||
|
report_window.glade \
|
||||||
|
seaudit.glade \
|
||||||
|
- seaudit_help.txt \
|
||||||
|
seaudit-report.conf \
|
||||||
|
seaudit-report.css
|
||||||
|
|
||||||
|
--- setools-3.0/apol/Makefile.am.rhat 2006-10-13 13:56:21.000000000 -0400
|
||||||
|
+++ setools-3.0/apol/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
|
@@ -4,9 +4,10 @@
|
||||||
|
bin_PROGRAMS = apol
|
||||||
|
dist_setools_SCRIPTS = apol.tcl
|
||||||
|
|
||||||
|
-dist_setools_DATA = apol_help.txt domaintrans_help.txt file_relabel_help.txt \
|
||||||
|
- infoflow_help.txt types_relation_help.txt \
|
||||||
|
- perm_maps/apol_perm_mapping_ver12 \
|
||||||
|
+doc_DATA = apol_help.txt domaintrans_help.txt file_relabel_help.txt \
|
||||||
|
+ infoflow_help.txt types_relation_help.txt
|
||||||
|
+
|
||||||
|
+dist_setools_DATA = perm_maps/apol_perm_mapping_ver12 \
|
||||||
|
perm_maps/apol_perm_mapping_ver15 \
|
||||||
|
perm_maps/apol_perm_mapping_ver16 \
|
||||||
|
perm_maps/apol_perm_mapping_ver17 \
|
||||||
|
--- setools-3.0/packages/Makefile.am.rhat 2006-10-11 12:50:16.000000000 -0400
|
||||||
|
+++ setools-3.0/packages/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
|
@@ -1,10 +1,8 @@
|
||||||
|
-bwidget_destdir = @BWIDGET_DESTDIR@
|
||||||
|
-
|
||||||
|
dist_noinst_DATA = BWidget-1.8.0.tar.bz2 combobox.tcl mainframe.tcl notebook.tcl Doxyfile
|
||||||
|
|
||||||
|
install-data-local:
|
||||||
|
tar jxf BWidget-1.8.0.tar.bz2
|
||||||
|
- mv BWidget-1.8.0 $(bwidget_destdir)
|
||||||
|
+ mv BWidget-1.8.0 $(BWIDGET_DESTDIR)
|
||||||
|
|
||||||
|
uninstall-local:
|
||||||
|
- -rm -rf $(bwidget_destdir)/BWidget-1.8.0
|
||||||
|
+ -rm -rf $(BWIDGET_DESTDIR)/BWidget-1.8.0
|
||||||
|
--- setools-3.0/sediff/Makefile.am.rhat 2006-10-04 12:14:48.000000000 -0400
|
||||||
|
+++ setools-3.0/sediff/Makefile.am 2006-10-24 13:14:16.000000000 -0400
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
setoolsdir = @setoolsdir@
|
||||||
|
|
||||||
|
-dist_setools_DATA = sediff_help.txt sediff.glade
|
||||||
|
+doc_DATA = sediff_help.txt
|
||||||
|
+dist_setools_DATA = sediff.glade
|
||||||
|
|
||||||
|
if BUILD_GUI
|
||||||
|
MAYBE_SEDIFFX = sediffx
|
||||||
|
--- setools-3.0/configure.ac.rhat 2006-10-13 14:59:34.000000000 -0400
|
||||||
|
+++ setools-3.0/configure.ac 2006-10-24 13:18:31.000000000 -0400
|
||||||
|
@@ -3,6 +3,10 @@
|
||||||
|
AC_CONFIG_HEADER(config.h)
|
||||||
|
AM_INIT_AUTOMAKE(setools, 3.0)
|
||||||
|
|
||||||
|
+docdir="\${datadir}/doc/$PACKAGE_NAME-$PACKAGE_VERSION"
|
||||||
|
+AC_SUBST(docdir)
|
||||||
|
+AC_SUBST(YFLAGS)
|
||||||
|
+
|
||||||
|
dnl *** update these variables as versions change; also update AC_INIT ***
|
||||||
|
libqpol_version=1.0.0
|
||||||
|
libqpol_soname=libqpol.so.1
|
||||||
|
@@ -19,7 +23,7 @@
|
||||||
|
|
||||||
|
libseaudit_version=3.0.0
|
||||||
|
|
||||||
|
-setoolsdir='${prefix}/share/setools-3.0'
|
||||||
|
+setoolsdir='${prefix}/share/setools'
|
||||||
|
|
||||||
|
version_min_sepol_major=1
|
||||||
|
version_min_sepol_minor=12
|
||||||
|
@@ -249,17 +253,21 @@
|
||||||
|
AC_ARG_WITH(sepol-devel,
|
||||||
|
AC_HELP_STRING([--with-sepol-devel],
|
||||||
|
[prefix where sepol development files are installed]),
|
||||||
|
- sepol_devel="$withval",
|
||||||
|
- sepol_devel="/usr")
|
||||||
|
+ sepol_devel_incdir="${withval}/include"
|
||||||
|
+ sepol_devel_libdir="${withval}/lib"
|
||||||
|
+ ,
|
||||||
|
+ sepol_devel_incdir="/usr/include"
|
||||||
|
+ sepol_devel_libdir="${libdir}"
|
||||||
|
+ )
|
||||||
|
AC_ARG_WITH(selinux-devel,
|
||||||
|
AC_HELP_STRING([--with-selinux-devel],
|
||||||
|
[prefix where SELinux development files are installed]),
|
||||||
|
- selinux_devel="$withval",
|
||||||
|
- selinux_devel="/usr")
|
||||||
|
-sepol_devel_incdir="${sepol_devel}/include"
|
||||||
|
-sepol_devel_libdir="${sepol_devel}/lib"
|
||||||
|
-selinux_devel_incdir="${selinux_devel}/include"
|
||||||
|
-selinux_devel_libdir="${selinux_devel}/lib"
|
||||||
|
+ selinux_devel_incdir="${withval}/include"
|
||||||
|
+ selinux_devel_libdir="${withval}/lib"
|
||||||
|
+ ,
|
||||||
|
+ selinux_devel_incdir="/usr/include"
|
||||||
|
+ selinux_devel_libdir="${libdir}"
|
||||||
|
+ )
|
||||||
|
AC_MSG_CHECKING([for sepol/sepol.h])
|
||||||
|
selinux_save_CFLAGS="${CFLAGS}"
|
||||||
|
SELINUX_LIB_FLAG="-L${sepol_devel_libdir} -L${selinux_devel_libdir}"
|
||||||
|
59
setools.spec
59
setools.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: SELinux tools for managing policy
|
Summary: SELinux tools for managing policy
|
||||||
Name: setools
|
Name: setools
|
||||||
Version: 2.4
|
Version: 3.0
|
||||||
Release: 2.1
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://www.tresys.com/
|
URL: http://www.tresys.com/
|
||||||
@ -14,18 +14,18 @@ Source9: sediffx.desktop
|
|||||||
Source10: seaudit.png
|
Source10: seaudit.png
|
||||||
Source11: apol.png
|
Source11: apol.png
|
||||||
Source12: sediffx.png
|
Source12: sediffx.png
|
||||||
|
Patch: setools-rhat.patch
|
||||||
|
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: checkpolicy, policycoreutils, tcl >= 8.3
|
Requires: checkpolicy, policycoreutils, tcl >= 8.3
|
||||||
Buildrequires: tk-devel >= 8.3, tcl-devel >= 8.3
|
Buildrequires: tk-devel >= 8.3, tcl-devel >= 8.3 libsepol-devel >= 1.15.1
|
||||||
BuildRequires: gtk2-devel, libglade2-devel
|
BuildRequires: gtk2-devel, libglade2-devel
|
||||||
BuildRequires: libselinux-devel, libxml2-devel
|
BuildRequires: libselinux-devel, libxml2-devel
|
||||||
|
BuildRequires: autoconf
|
||||||
BuildRequires: libcap-devel
|
BuildRequires: libcap-devel
|
||||||
BuildPrereq: bison, flex, pkgconfig
|
BuildPrereq: bison, flex, pkgconfig
|
||||||
|
|
||||||
Patch0: setools-rhat.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Security-enhanced Linux is a patch of the Linux kernel and a number of
|
Security-enhanced Linux is a patch of the Linux kernel and a number of
|
||||||
utilities with enhanced security functionality designed to add
|
utilities with enhanced security functionality designed to add
|
||||||
@ -82,11 +82,13 @@ tools.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .rhat
|
%patch -p1 -b .rhat
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoconf
|
||||||
|
%configure --disable-bwidget-check --disable-selinux-check
|
||||||
make clean
|
make clean
|
||||||
make INSTALL_HELPDIR=/usr/share/doc/setools-%{version} LIBDIR=%{_libdir} all
|
make LIBDIR=%{_libdir} MAYBE_BWIDGET=packages all
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
@ -98,7 +100,7 @@ mkdir -p $RPM_BUILD_ROOT/usr/share/doc/setools-%{version}
|
|||||||
mkdir -p $RPM_BUILD_ROOT/usr/share/tcl8.4
|
mkdir -p $RPM_BUILD_ROOT/usr/share/tcl8.4
|
||||||
mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps
|
mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps
|
||||||
|
|
||||||
make DESTDIR="${RPM_BUILD_ROOT}" INSTALL_HELPDIR=$RPM_BUILD_ROOT/usr/share/doc/setools-%{version} LIBDIR=%{_libdir} install install-bwidget
|
make DESTDIR="${RPM_BUILD_ROOT}" LIBDIR=%{_libdir} MAYBE_BWIDGET=packages BWIDGET_DESTDIR="${RPM_BUILD_ROOT}/usr/share/tcl8.4/" install
|
||||||
rm -f ${RPM_BUILD_ROOT}/usr/bin/findcon
|
rm -f ${RPM_BUILD_ROOT}/usr/bin/findcon
|
||||||
rm -f ${RPM_BUILD_ROOT}/usr/bin/replcon
|
rm -f ${RPM_BUILD_ROOT}/usr/bin/replcon
|
||||||
rm -f ${RPM_BUILD_ROOT}/usr/bin/searchcon
|
rm -f ${RPM_BUILD_ROOT}/usr/bin/searchcon
|
||||||
@ -129,32 +131,22 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
%files gui
|
%files gui
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir /usr/share/tcl8.4/BWidget-1.7.0
|
%dir /usr/share/tcl8.4/BWidget-1.8.0
|
||||||
/usr/share/tcl8.4/BWidget-1.7.0/*
|
/usr/share/tcl8.4/BWidget-1.8.0/*
|
||||||
%{_bindir}/apol
|
%{_bindir}/apol
|
||||||
%{_bindir}/sediffx
|
%{_bindir}/sediffx
|
||||||
%{_bindir}/awish
|
%{_bindir}/awish
|
||||||
%{_bindir}/seaudit
|
%{_bindir}/seaudit
|
||||||
|
%{_bindir}/seaudit_report
|
||||||
%{_sbindir}/seaudit
|
%{_sbindir}/seaudit
|
||||||
%{_sbindir}/seaudit-report
|
|
||||||
%{_datadir}/applications/apol.desktop
|
%{_datadir}/applications/apol.desktop
|
||||||
%{_datadir}/applications/seaudit.desktop
|
%{_datadir}/applications/seaudit.desktop
|
||||||
%{_datadir}/applications/sediffx.desktop
|
%{_datadir}/applications/sediffx.desktop
|
||||||
%config(noreplace) %{_sysconfdir}/pam.d/seaudit
|
%config(noreplace) %{_sysconfdir}/pam.d/seaudit
|
||||||
%config(noreplace) %{_sysconfdir}/security/console.apps/seaudit
|
%config(noreplace) %{_sysconfdir}/security/console.apps/seaudit
|
||||||
/usr/share/doc/setools-%{version}/apol*
|
/usr/share/doc/setools-%{version}/*.txt
|
||||||
/usr/share/doc/setools-%{version}/seaudit_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/types_relation_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/dta_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/file_relabel_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/flow_assertion_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/iflow_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/obj_perms_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/sechecker_help.txt
|
|
||||||
/usr/share/doc/setools-%{version}/sediff_help.txt
|
|
||||||
|
|
||||||
/usr/share/setools/apol.tcl
|
/usr/share/setools/apol.tcl
|
||||||
/usr/share/setools/apol_perm_mapping
|
|
||||||
/usr/share/setools/apol_perm_mapping_ver12
|
/usr/share/setools/apol_perm_mapping_ver12
|
||||||
/usr/share/setools/apol_perm_mapping_ver15
|
/usr/share/setools/apol_perm_mapping_ver15
|
||||||
/usr/share/setools/apol_perm_mapping_ver16
|
/usr/share/setools/apol_perm_mapping_ver16
|
||||||
@ -162,6 +154,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
/usr/share/setools/apol_perm_mapping_ver18
|
/usr/share/setools/apol_perm_mapping_ver18
|
||||||
/usr/share/setools/apol_perm_mapping_ver19
|
/usr/share/setools/apol_perm_mapping_ver19
|
||||||
/usr/share/setools/apol_perm_mapping_ver20
|
/usr/share/setools/apol_perm_mapping_ver20
|
||||||
|
/usr/share/setools/apol_perm_mapping_ver21
|
||||||
/usr/share/setools/customize_filter_window.glade
|
/usr/share/setools/customize_filter_window.glade
|
||||||
/usr/share/setools/dot_seaudit
|
/usr/share/setools/dot_seaudit
|
||||||
/usr/share/setools/filter_window.glade
|
/usr/share/setools/filter_window.glade
|
||||||
@ -192,13 +185,18 @@ Headers, static libraries and API docs for SETools.
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/libapol
|
%{_includedir}/apol
|
||||||
%{_includedir}/libseaudit
|
%{_includedir}/poldiff
|
||||||
|
%{_includedir}/qpol
|
||||||
|
%{_includedir}/sefs
|
||||||
%{_includedir}/selinux/apol
|
%{_includedir}/selinux/apol
|
||||||
%{_includedir}/libsefs
|
|
||||||
%{_libdir}/libsefs.a
|
%{_libdir}/libsefs.a
|
||||||
%{_libdir}/libapol.a
|
%{_libdir}/libapol.a
|
||||||
|
%{_libdir}/libapol-tcl.a
|
||||||
|
%{_libdir}/libqpol.a
|
||||||
%{_libdir}/libseaudit.a
|
%{_libdir}/libseaudit.a
|
||||||
|
%{_libdir}/libpoldiff.a
|
||||||
|
|
||||||
%post devel -p /sbin/ldconfig
|
%post devel -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -218,14 +216,17 @@ Headers, static libraries and API docs for SETools.
|
|||||||
%{_mandir}/man1/sediff.1.gz
|
%{_mandir}/man1/sediff.1.gz
|
||||||
%{_mandir}/man1/sesearch.1.gz
|
%{_mandir}/man1/sesearch.1.gz
|
||||||
%attr(755,root,root) %dir /usr/share/setools
|
%attr(755,root,root) %dir /usr/share/setools
|
||||||
%attr(755,root,root) %dir /usr/share/setools/sechecker
|
%attr(755,root,root) %dir /usr/share/setools/sechecker-profiles
|
||||||
%attr(755,root,root) %dir /usr/share/setools/sechecker/profiles
|
/usr/share/setools/sechecker-profiles/*
|
||||||
/usr/share/setools/sechecker/profiles/*
|
|
||||||
%{_libdir}/libapol.so*
|
%{_libdir}/libapol.so*
|
||||||
%{_libdir}/libseaudit.so*
|
%{_libdir}/libqpol.so*
|
||||||
|
%{_libdir}/libpoldiff.so*
|
||||||
%{_libdir}/libsefs.so*
|
%{_libdir}/libsefs.so*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 15 2006 Dan Walsh <dwalsh@redhat.com> 3.0-1
|
||||||
|
- Update to upstream
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
|
||||||
- rebuild
|
- rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user